Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister WordPress Subscriber account
-
ExploitSend crafted HTTP request to WpEvently action
-
ExecutionBypass missing authorization check
-
ImpactRead restricted event or plugin data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires the attacker to hold at minimum a WordPress Subscriber account on the target site, confirmed by the CVSS PR:L metric. On WordPress sites with open user registration enabled (Settings > General), any unauthenticated visitor can self-register as a Subscriber, effectively reducing the practical barrier. The WpEvently plugin must be installed and active on the site. Impact is bounded to confidentiality only (C:L) - the attacker cannot modify data or cause a denial of service through this flaw alone. Sites that disable open registration, require administrator approval for new accounts, or do not use WpEvently are not exposed. Exploitation is also limited to the data and functionality accessible within WpEvently's scope; lateral movement to broader WordPress admin functionality is not indicated by the available data. |
| Impact | The CVSS 3.1 score of 4.3 (Medium) reflects a network-accessible flaw requiring low privileges (PR:L) with low confidentiality impact and no integrity or availability impact. The PR:L requirement is the most significant limiting factor: exploitation is gated behind possession of at minimum a WordPress Subscriber account, which meaningfully restricts opportunistic exploitation compared to unauthenticated flaws. Sites with open user registration - where any visitor can self-register as a Subscriber - are most exposed. No CISA KEV listing and no public exploit code identified at time of analysis; EPSS data was not provided in the input. The unchanged scope (S:U) and C:L impact confirm this is an information disclosure class issue, not a site takeover vector. Real-world risk is best characterized as moderate for open-registration sites and low for sites with closed or curated user enrollment. |
| Exploit ScenarioDerived | An attacker registers a free WordPress Subscriber account on the target site - trivially possible on any site with open registration - then crafts HTTP requests targeting WpEvently plugin endpoints or AJAX actions that lack authorization checks, accessing event data or configurations intended for Editor or Administrator roles. No public exploit code has been identified at time of analysis, but the well-understood CWE-862 class and low attack complexity make independent exploitation straightforward for any attacker familiar with WordPress plugin internals. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Aug 28, 2026
Broken access control in WpEvently WordPress plugin versions 5.5.0 and earlier permits authenticated subscribers to invoke functionality or access data restricted to higher-privileged roles. The flaw is rooted in CWE-862 (Missing Authorization), meaning the plugin fails to enforce proper capability checks on one or more actions accessible to low-privilege users. No public exploit has been identified at time of analysis, and the absence of a KEV listing combined with the PR:L requirement limits opportunistic mass exploitation, though sites with open user registration face meaningful risk.
RemediationAI
Upgrade WpEvently to a version beyond 5.5.0 once a patched release is confirmed available via the WordPress Plugin Repository or the MagePeople Inc. vendor channel. No exact patched version is confirmed from the available input data; consult the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/mage-eventpress/vulnerability/wordpress-wpevently-plugin-5-5-0-broken-access-control-vulnerability-2 for the verified fix version before upgrading. As an immediate compensating control, disable open user registration under WordPress Settings > General by unchecking 'Anyone can register' - this removes the attacker's pathway to obtaining the subscriber account required for exploitation, though it does not address the underlying flaw. Sites where subscriber registration is operationally required should consider deploying a WordPress security plugin such as Patchstack or Wordfence with virtual patching enabled to block exploitation attempts while awaiting a vendor fix.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
WpEvently is a WordPress event management plugin developed by MagePeople Inc., identified by CPE cpe:2.3:a:magepeople_inc.:wpevently:*:*:*:*:*:*:*:*. The root cause is CWE-862 (Missing Authorization), a class of flaw where software does not perform adequate authorization checks before granting access to a protected resource or operation. In the WordPress plugin context, this typically manifests as AJAX handlers, REST API routes, or admin-facing actions that lack the requisite current_user_can() or capability checks, allowing any authenticated user - including the default Subscriber role - to trigger functionality normally gated to Editor or Administrator roles. The CVSS vector (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N) confirms the vulnerability is network-reachable with minimal complexity and results in limited confidentiality exposure with no integrity or availability impact.
Know when Wpevently gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Requires active subscriber account (PR:L) for exploitation; confidentiality-only impact with no integrity or availability effect confirmed by description.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Subscriber Broken Access Control in WpEvently <= 5.5.0 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Unauthenticated integrity compromise in the WpEvently WordPress plugin (versions 5.3.3 and earlier) by MagePeople allows
A Reflected Cross-Site Scripting (XSS) vulnerability exists in the WpEvently WordPress plugin (mage-eventpress) affectin
Unauthenticated IDOR in the WpEvently WordPress plugin (versions ≤ 5.6.0) allows remote attackers with no credentials to
Broken access control in WpEvently WordPress plugin versions 5.5.0 and earlier permits contributor-level authenticated u
WpEvently versions prior to 5.1.9 inadvertently expose sensitive information in transmitted data, allowing unauthenticat
Cross-site scripting (CWE-80) in the WpEvently WordPress plugin from Magepeople Inc. affects all versions through 5.7.9
Cross-Site request forgery (CSRF) vulnerability in Magepeople inc. Rated medium severity (CVSS 4.3), this vulnerability
EUVD-2026-67733
GHSA-hrgh-vmmc-69vj
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB