Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAttacker authenticates with low-privileged Metasys account
-
DeliveryInjects malicious script via unsanitized input field
-
ExploitHigher-privileged operator loads affected page
-
ExecutionBrowser executes attacker JavaScript in operator's session
-
ImpactSession token exfiltrated or unauthorized BMS action performed
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires the attacker to hold a valid, low-privileged authenticated session on the Johnson Controls Metasys web interface (PR:L from CVSS 4.0 vector). A victim user with higher privileges must then load or interact with the page containing the injected payload (UI:P). The vulnerability is limited to Metasys versions 14.x before 14.1.5 and 15.x before 15.0.1; systems already updated to the fixed releases are not affected. Exploitation is bounded to the web interface context and does not directly extend to subsequent systems per the CVSS 4.0 SC:N/SI:N/SA:N metrics. External internet-exposed deployments of the Metasys web interface would face a broader threat surface than air-gapped or VPN-only deployments. |
| Impact | The NVD CVSS score of 6.1 and the CVSS 4.0 vector (AV:N/AC:L/AT:N/PR:L/UI:P) suggest moderate exploitability with a meaningful but conditional threat profile. The PR:L requirement means an attacker must first obtain low-privileged access to the Metasys web interface, which constrains the attack surface to authenticated sessions. The UI:P flag confirms a victim must actively view the injected content, limiting opportunistic exploitation. The CVSS 4.0 vector assigns VC:H/VI:H/VA:H, which appears elevated relative to a typical web-only XSS vulnerability - however, in the context of a BMS like Metasys, session hijacking of a privileged operator could yield high-impact control over building systems, which may justify these ratings. The EPSS score is not provided, and the E:U supplemental flag confirms no known exploitation in the wild. This vulnerability is not in the CISA KEV catalog and no proof-of-concept code has been identified, supporting a treat-with-urgency-but-not-emergency posture. CONFLICT NOTE: The CVSS 6.1 score is inconsistent with the VC:H/VI:H/VA:H CVSS 4.0 vector provided - the latter would typically yield a CVSS 4.0 score above 7.0. This discrepancy should be verified against the Johnson Controls advisory. |
| Exploit ScenarioDerived | An attacker with low-privileged access to the Metasys web interface - such as a contractor or facility technician - submits crafted input containing a malicious JavaScript payload into a field that is later rendered unsanitized in another user's browser session. When a higher-privileged Metasys operator views the affected page, the script executes in their browser context, potentially stealing their session token or performing unauthorized building automation actions on the attacker's behalf. No public proof-of-concept code has been identified at the time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Aug 24, 2026
Reflected or stored cross-site scripting in Johnson Controls Metasys 14 (before 14.1.5) and Metasys 15 (before 15.0.1) allows a low-privileged attacker to inject malicious scripts into web pages that execute in a victim user's browser. Metasys is a building automation and management system, meaning successful exploitation could enable session hijacking or unauthorized interaction with building infrastructure controls accessible through the web interface. No public exploit has been identified and no active exploitation is confirmed; a vendor-released patch is available.
RemediationAI
Upgrade Johnson Controls Metasys 14 to version 14.1.5 or later, and Metasys 15 to version 15.0.1 or later, as confirmed by the vendor advisory at https://www.johnsoncontrols.com/trust-center/cybersecurity/security-advisories. If immediate patching is not feasible, restrict access to the Metasys web interface to trusted internal network segments or VPN-controlled access only, reducing exposure from unauthenticated external threat actors who would first need to obtain credentials. Additionally, enforce least-privilege principles on Metasys web accounts to limit the ability of low-privileged users to submit content that could be rendered to higher-privileged operators. Content Security Policy (CSP) headers, if configurable on the Metasys web server, may reduce XSS exploitability as a compensating control, though this is not a substitute for patching.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Johnson Controls Metasys is a web-based building management system (BMS) used to monitor and control HVAC, access control, and other building infrastructure. The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation) - commonly referred to as cross-site scripting - though the CWE field was not formally populated in the advisory. Affected CPEs are cpe:2.3:a:johnson_controls:metasys_14 (all versions before 14.1.5) and cpe:2.3:a:johnson_controls:metasys_15 (all versions before 15.0.1). The root cause is failure to properly encode or sanitize user-supplied input before rendering it within HTML output, a well-understood class of web vulnerability. The CVSS 4.0 vector (PR:L/UI:P) indicates the attacker must be authenticated with low privileges and victim interaction is required, consistent with a stored or DOM-based XSS scenario where a privileged user loads a page containing attacker-supplied content.
Know when Metasys 14 gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Network-accessible web XSS; PR:L because attacker must be authenticated; UI:R and S:C for browser-context execution; C:L/I:L for session/DOM impact only.
Primary rating from Vendor (jci).
CVSS VectorVendor: jci
Lifecycle Timeline
1DescriptionCVE.org
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Johnson Controls Metasys 14 and Johnson Controls Metasys 15 allows Cross Site Scripting.
This issue affects Metasys 14: before 14.1.5; Metasys 15: before 15.0.1.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-65005
GHSA-2fj7-6j2c-3972
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB