Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister subscriber account on target site
-
DeliveryInject XSS payload into FluentCommunity content field
-
ExploitAdmin user views community content containing payload
-
ExecutionMalicious script executes in admin browser context
-
ImpactExfiltrate session cookie or perform privileged admin actions
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires the attacker to hold a valid subscriber-level (or higher) WordPress user account on the target site - this is the minimum registered user role in WordPress. Sites with open registration are therefore at significantly higher risk as attackers can self-register. Additionally, exploitation requires that a privileged user (such as an administrator) actively views or interacts with the community content containing the injected payload (UI:R); the attack does not execute autonomously on the server. The FluentCommunity plugin must be installed and active. Limiting factors include: the need for an authenticated attacker account (not a zero-interaction attack), the dependency on admin user interaction with community content, and the requirement that the site uses FluentCommunity versions 2.7.5 or below. Sites with closed registration or where only trusted users hold subscriber roles have substantially reduced exposure. |
| Impact | The CVSS 6.5 Medium score reflects meaningful but bounded risk: AV:N/AC:L confirms network-accessible exploitation with no special configuration complexity, while PR:L caps the threat to environments where attacker-controlled subscriber accounts exist, and UI:R requires a privileged user to view the injected content. EPSS data was not provided in the intelligence sources, so exploitation probability cannot be quantified. No CISA KEV listing is present, and no POC code is referenced - exploitation status is 'no public exploit identified at time of analysis.' In practice, XSS-via-subscriber-to-admin is a well-understood WordPress attack chain with real consequences: successful exploitation can yield full administrative takeover via session cookie theft or CSRF-chained actions. The risk is highest for sites with open registration (allowing attacker subscriber accounts) and active admin engagement with community content. The A:L availability impact in the vendor CVSS vector is atypical for XSS and may be inflated; concrete availability impact is not described in available data. |
| Exploit ScenarioDerived | An attacker registers a subscriber account on a WordPress site running FluentCommunity, then submits a community post or profile field containing a crafted JavaScript payload such as a cookie-stealing script. When a site administrator navigates to view community content and encounters the injected payload, the script executes in the administrator's browser session, exfiltrating their session cookie or WordPress nonce to an attacker-controlled endpoint, enabling full administrative account takeover without requiring further interaction. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Aug 13, 2026
Subscriber-level Cross-Site Scripting in FluentCommunity (WordPress plugin) versions up to and including 2.7.5 allows authenticated users with subscriber-level access to inject malicious scripts that execute in the browser context of other users, including administrators. The scope change (S:C in CVSS) indicates the injected payload affects a different security principal than the attacker, enabling session hijacking, credential theft, or unauthorized administrative actions. No public exploit code or CISA KEV listing has been identified at time of analysis, though the low privilege requirement and network-accessible attack surface make this a realistic threat for multi-user WordPress deployments running community features.
RemediationAI
Update FluentCommunity to a version above 2.7.5 - the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/fluent-community/vulnerability/wordpress-fluentcommunity-plugin-2-7-5-cross-site-scripting-xss-vulnerability should be consulted to confirm the exact patched release version, which is not independently confirmed in the available data. As compensating controls pending a patch, disable open user registration to prevent unauthenticated parties from obtaining subscriber accounts, since PR:L exploitation requires an attacker-controlled account. Additionally, restrict which user roles can post or interact with community content fields that render HTML; many WordPress community plugins expose role-based content permissions. Implementing a Web Application Firewall (WAF) with XSS filtering rules (e.g., Wordfence or Cloudflare WAF) can reduce exploitation risk but is not a substitute for patching, as WAF rules can be bypassed. Reviewing and hardening Content Security Policy (CSP) headers to restrict inline script execution is an effective supplementary control with low operational impact.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
FluentCommunity is a WordPress community-building plugin developed by WP Manage Ninja (CPE: cpe:2.3:a:wpmanageninja:fluentcommunity:*:*:*:*:*:*:*:*). CWE-79 (Improper Neutralization of Input During Web Page Generation) indicates that user-supplied input from subscriber-level accounts is not adequately sanitized or escaped before being rendered in the browser. The PR:L designation in the CVSS vector pinpoints the 'Subscriber' WordPress role - the lowest registered user role - as the privilege tier sufficient to trigger injection. The S:C (Scope Changed) metric confirms the vulnerability crosses trust boundaries: a subscriber injects content that executes in the browser session of a distinct, higher-privileged user such as an administrator. This is a classic stored or reflected XSS pattern common in WordPress plugin community or forum features where user-generated content is displayed to other users.
Know when Fluentcommunity gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
PR:L confirmed by subscriber role requirement; A:N substituted for A:L as XSS does not credibly cause availability impact per available description.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Subscriber Cross Site Scripting (XSS) in FluentCommunity <= 2.7.5 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-57886
GHSA-4rc5-2q8r-3mf5
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB