Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend crafted POST request to coupon REST API
-
ExploitInterpolate malicious SQL payload into raw query
-
ExecutionExecute unauthorized SQL statements
-
ImpactRetrieve sensitive database contents
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Parameterized queries, prepared statements
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Persistence The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No special conditions - remote unauthenticated exploitation against default configurations of any WordPress site running Premium Packages plugin version ≤ 6.2.0 with the WordPress REST API enabled (enabled by default). The attack does not require any user interaction or prior authentication. |
| Impact | CVSS 3.1 scores this 7.5 (High) with a vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N, indicating easily exploitable unauthenticated remote access to confidential data with no impact to integrity or availability. No EPSS score or CISA KEV entry is available, and public proof-of-concept code has not been confirmed at the time of analysis. Therefore, while the vulnerability is trivial to exploit and exposes all database contents, the lack of known exploitation or automated attack tooling reduces the immediate urgency compared to actively mass-exploited issues. However, any public disclosure of a working exploit would rapidly escalate risk due to the low attack complexity and unauthenticated nature. |
| Exploit ScenarioDerived | An attacker sends a specially crafted POST request to https://victim-site.com/wp-json/wpdmpp/v1/cart/coupon with a malicious payload in the 'code' parameter, such as ' OR 1=1--, to modify the SQL query and extract database information like user credentials or sensitive site data. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 28, 2026
Unauthenticated SQL injection in the WordPress Premium Packages - Sell Digital Products Securely plugin (wpdm-premium-packages) allows any remote attacker to extract sensitive data from the website’s database. The vulnerability exists in the coupon processing REST API endpoint and stems from user input being directly interpolated into a raw SQL query without any sanitization or prepared statements.
RemediationAI
Update to a version later than 6.2.0 once a patched release is made available. The development team has committed a fix in changeset r3595291, but a tagged release number is not yet published. In the interim, disable the vulnerable coupon API endpoint by deactivating the REST API route '/wpdmpp/v1/cart/coupon' through custom code or a firewall rule, or consider temporarily deactivating the plugin if the coupon functionality is not critical. Web application firewalls (WAF) can also block SQL injection attempts targeting this parameter, but updating remains the definitive fix. Monitor the plugin’s WordPress page for an official release containing the patch.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the CouponCodes::find() method of the WP Download Manager - Premium Packages plugin, which handles coupon code validation for the cart system. The 'code' parameter from the POST /wp-json/wpdmpp/v1/cart/coupon REST API endpoint is inserted directly into a SQL query string without using $wpdb->prepare() or esc_sql(). This classic SQL injection (CWE-89) allows an attacker to append arbitrary SQL commands. The affected plugin is a commercial extension for selling digital products, identified by the slug 'wpdm-premium-packages' in the WordPress plugin repository.
Know when WordPress gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Network-accessible, trivial complexity, no privileges or user interaction, scope unchanged, high confidentiality impact.
Primary rating from Vendor (wordfence).
CVSS VectorVendor: wordfence
DescriptionCVE.org
The Premium Packages - Sell Digital Products Securely plugin for WordPress is vulnerable to SQL Injection via the 'code' parameter of the POST /wp-json/wpdmpp/v1/cart/coupon REST API endpoint in versions up to, and including, 6.2.0. This is due to insufficient escaping on the user-supplied parameter, which is interpolated directly into a raw SQL query string in the CouponCodes::find() method without use of $wpdb->prepare() or esc_sql(). This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Articles & Coverage 1
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
SQL injection exploits the way applications construct database queries by mixing user input directly into SQL statements.
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra para
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail comman
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The GiveWP - Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
Remote code execution in WordPress 6.9.x (before 6.9.5) and 7.0.x (before 7.0.2) arises from a REST API batch endpoint r
EUVD-2026-49723
GHSA-jqfx-7h8g-gj4q
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB