Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend HTTP request with malicious SQL in form_data[s]
-
ExploitTrigger SQL injection in plugin search query
-
ImpactExtract sensitive database information
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Parameterized queries, prepared statements
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Persistence The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No special conditions required - the vulnerable WP Fast Total Search plugin must be installed and active on the WordPress site. The search feature, which is typically accessible to unauthenticated users, directly handles the tainted parameter without sanitization, leading to exploitable SQL injection. No user interaction or elevated privileges are needed. |
| Impact | CVSS 7.5 (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N) indicates a remotely exploitable flaw with low attack complexity and no privileges required, impacting confidentiality only. However, EPSS data is not available, and the vulnerability is not listed in CISA KEV, nor is any public exploit code known. Without confirmation of active exploitation or a proof-of-concept, the current real-world risk is moderate. The lack of authentication and low complexity make exploitation likely if an exploit emerges, but the absence of a patched version increases urgency for mitigation. |
| Exploit ScenarioDerived | An attacker sends a crafted HTTP request to a vulnerable WordPress site, injecting SQL payloads via the 'form_data[s]' parameter. The malicious query executes in the plugin's search database call, allowing the extraction of sensitive data such as user credentials or personal information without user interaction or prior authentication. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 28, 2026
Remote unauthenticated SQL injection in the WordPress WP Fast Total Search plugin up to version 1.80.280 allows attackers to extract sensitive database information via the 'form_data[s]' parameter. The flaw requires no authentication or user interaction, making it easily exploitable over the network. No public exploit code or active exploitation has been confirmed at this time.
RemediationAI
No patched version higher than 1.80.280 has been released by the vendor at this time. Users should immediately disable the plugin if it is not critical, or closely monitor for an update. A temporary compensating control is to block access to the search endpoint or disable the search feature entirely, though this will remove the plugin's core functionality. No official workaround has been published. Consult the Wordfence advisory for the latest fix status.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The WP Fast Total Search plugin for WordPress (slug 'fulltext-search') fails to properly escape user-supplied input passed through the 'form_data[s]' parameter before incorporating it into SQL queries. This insecurity occurs in the search functionality defined in fulltext-search.php and wpfts_search.php, leading to SQL injection (CWE-89). The vulnerability exists because the plugin does not use parameterized queries or sufficient escaping, allowing attackers to manipulate SQL logic.
Know when WordPress gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Unauthenticated network access, low complexity, no user interaction; high confidentiality impact, no integrity or availability impact.
Primary rating from Vendor (wordfence).
CVSS VectorVendor: wordfence
DescriptionCVE.org
The WP Fast Total Search - The Power of Indexed Search plugin for WordPress is vulnerable to generic SQL Injection via the 'form_data[s]' parameter in all versions up to, and including, 1.80.280 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Articles & Coverage 1
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
SQL injection exploits the way applications construct database queries by mixing user input directly into SQL statements.
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra para
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail comman
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The GiveWP - Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
Remote code execution in WordPress 6.9.x (before 6.9.5) and 7.0.x (before 7.0.2) arises from a REST API batch endpoint r
EUVD-2026-49716
GHSA-235p-5qrp-j5rw
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB