Skip to main content

Unlimited Elements For Elementor EUVDEUVD-2026-45876

| CVE-2026-10081 HIGH
Cross-site Scripting (XSS) (CWE-79)
2026-07-20 WPScan GHSA-jv99-4c76-v7q4
8.8
CVSS 3.1 · Vendor: WPScan
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK

2 techniques across 2 tactics: Initial Access, Execution

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

This Week Schedule remediation this week. Why: HIGH severity (CVSS 7.0-8.9).
Patch available 0.2% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Jul 20, 2026

Stored cross-site scripting in the Unlimited Elements For Elementor WordPress plugin (all versions before 2.0.11) lets an unauthenticated attacker plant a malicious Google review on a targeted business's Google listing that, once fetched via the Serp API and rendered unescaped in the Google Reviews widget, executes JavaScript in the browser of every visitor — including logged-in administrators — of any page showing that Place ID's reviews. Publicly available exploit code exists and the vendor has shipped a fix, but there is no public exploit identified as being used in active attacks. The injection is delivered through third-party review content rather than a direct request to the WordPress site, making it a supply-chain-style stored XSS.

Affected VersionsENISA

Unlimited Elements For Elementor 0 <2.0.11

Affected Packages

euvd unlimited_elements_for_elementor fix: 2.0.11

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Know when Unlimited Elements For Elementor gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

Vendor (WPScan) PRIMARY 8.8 HIGH
AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Primary rating from Vendor (WPScan) · only source for this CVE.

CVSS VectorVendor: WPScan

Attack Vector
Network
Attack Complexity
Low
Privileges Required
None
User Interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Lifecycle Timeline

4
CVSS changed
Jul 20, 2026 - 14:22 NVD
8.8 (HIGH)
Patch available
Jul 20, 2026 - 09:17 EUVD
CVE Published
Jul 20, 2026 - 06:00 cve.org
UNKNOWN (no severity yet)
CVE Published
Jul 20, 2026 - 06:00 cve.org
HIGH 8.8

DescriptionCVE.org

The Unlimited Elements For Elementor WordPress plugin before 2.0.11 does not sanitize or escape Google review content fetched from the Serp API before rendering it in the Google Reviews widget output, allowing unauthenticated attackers who submit a malicious review on the targeted business's Google listing to deliver Stored XSS to any visitor (including administrators) of any WP page displaying that Place ID's reviews.

Executive ViewAI

Why It Matters

Unlimited Elements For Elementor plugin (pre-2.0.11) has a stored XSS vulnerability with publicly available exploit code that permits unauthenticated attackers to inject JavaScript through Google reviews, executing in all visitor browsers including administrator sessions. Affected organizations face risk of customer data compromise, admin account hijacking, and brand reputation damage. Vendor-released patch 2.0.11 is available.

Recommended Action

Within 24 hours, audit all WordPress installations for Unlimited Elements For Elementor plugin versions prior to 2.0.11 and document affected sites. Within 7 days, update all affected installations to version 2.0.11 and verify the update completed successfully. Within 30 days, conduct security scanning on affected sites to detect potential malicious content in Google reviews or stored XSS payloads, and review administrator account activity logs for unauthorized access during the vulnerable period.

Business Impact: High
Compensating Controls

Apply vendor patch.

Threat Intelligence Overview

EPSS Score
0.2%
Top 93% exploitable
Exploit
POC
Public exploit code exists
Social Media
1
Sightings
Data Quality
6 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity HIGH
CISA KEV No
Public POC Yes
EPSS 0.2%
Patch available Yes
Active threat No
Deciding rule
HIGH severity (CVSS 7.0-8.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision
Scheduled
Exploitation
Poc
System Exposure· derived
Open
Automatable
No
Human Impact
High
Technical Impact
Total

Priority Score

64
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +44
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.

CVE-2024-29792 HIGH POC
7.1 Mar 27

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Unlimited Elements

CVE-2026-85017 HIGH POC
7.5 Sep 20

PHP object injection in the Unlimited Elements For Elementor WordPress plugin (versions before 2.0.20) lets authenticate

CVE-2026-85568 MEDIUM POC
6.8 Oct 03

Unauthenticated SQL injection in the WordPress plugin Unlimited Elements for Elementor (versions 1.5.139 through before

CVE-2026-85015 MEDIUM POC
6.6 Oct 03

Authenticated path traversal in the Unlimited Elements for Elementor WordPress plugin before 2.0.21 lets a privileged us

CVE-2026-92923 MEDIUM POC
6.3 Oct 03

Blind SQL injection in the Unlimited Elements for Elementor WordPress plugin (all releases before 2.0.21) allows an auth

CVE-2023-6743 HIGH
8.8 May 29

The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to Remote Code

CVE-2023-31090 CRITICAL
9.9 Apr 24

Unrestricted Upload of File with Dangerous Type vulnerability in Unlimited Elements Unlimited Elements For Elementor (Fr

CVE-2023-31231 CRITICAL
9.9 Dec 20

Unrestricted Upload of File with Dangerous Type vulnerability in Unlimited Elements Unlimited Elements For Elementor (Fr

CVE-2024-49271 CRITICAL
9.1 Oct 16

Deserialization of Untrusted Data vulnerability in Unlimited Elements Unlimited Elements For Elementor (Free Widgets, Ad

CVE-2026-92924 MEDIUM POC
5.4 Oct 02

Authenticated WordPress users holding a role as low as Subscriber can cause arbitrary shortcodes to be executed on sites

CVE-2024-5329 HIGH
8.8 Jun 06

The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to blind SQL I

CVE-2024-4779 HIGH
8.8 May 23

The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to SQL Injecti

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy