Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconGain WordPress Contributor access
-
DeliveryNavigate to post editor
-
ExploitInject malicious URL in Threads embed
-
InstallScript stored in database
-
C2Victim views page
-
ExecuteJavaScript executes in victim browser
-
ImpactSession token stolen or malware injected
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Attacker must possess WordPress Contributor-level account access (or higher, such as Editor or Administrator role). The Social Post Embed plugin must be installed and activated on the target WordPress site. The Threads embed handler functionality must be enabled within the plugin (default state unknown but implied by vulnerability presence in handler code). The attacker must have permission to create or edit WordPress posts or pages that support embed blocks. Stored XSS requires victim users to subsequently visit the page containing the injected payload-there is no requirement for victim interaction beyond page view. No special WordPress configuration or plugin settings are required for exploitation beyond plugin installation and activation. Exploitation is limited by WordPress access control; users without Contributor role or above cannot exploit this vulnerability. |
| Impact | While the CVSS score of 6.4 (Medium) indicates moderate severity, the real-world risk must be contextualized carefully. The CVSS vector (AV:N/AC:L/PR:L/UI:N/S:C) shows network-accessible, low-complexity exploitation requiring only Contributor-level privileges (not unauthenticated), and no user interaction required once payload is stored. This is a stored XSS variant, meaning the attack is persistent and impacts all site visitors without additional attacker interaction. However, the exploitation conditions significantly limit scope: an attacker must first gain Contributor-level WordPress access, which is a meaningful but surmountable barrier given WordPress site compromise rates. The Scope:Changed (S:C) indicates cross-site impact is possible. Given no public exploit code identified and no CISA KEV listing, this represents a real but not urgently weaponized vulnerability. For WordPress administrators, the practical risk depends heavily on user management-sites with restrictive contributor access and regular user audits face lower risk, while sites with numerous or loosely vetted contributors face higher exposure. The CVSS Medium rating is appropriate for the actual attack complexity and privilege requirement, though organizations hosting user-generated content should prioritize patching. |
| Exploit ScenarioDerived | A WordPress site with multiple contributors allows a malicious insider or account-compromised contributor to navigate to a post edit screen, locate the Threads embed section, and inject a malicious URL containing JavaScript payload (e.g., a URL that references a JavaScript file or includes encoded script tags). The plugin stores this unvalidated input directly in the database. When any site visitor (including administrators and other users) views the post, the injected script executes in their browser context, stealing session cookies or WordPress authentication tokens without any user interaction required. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 28, 2026
Stored Cross-Site Scripting in Social Post Embed plugin for WordPress up to version 2.0.1 allows authenticated attackers with Contributor-level access to inject arbitrary JavaScript into page content via the Threads embed handler due to insufficient input sanitization and output escaping. Injected scripts execute when any user views the affected page, enabling session hijacking, credential theft, or malware distribution from trusted WordPress sites. No public exploit code or active exploitation has been identified at the time of analysis.
RemediationAI
Update Social Post Embed to version 2.0.2 or later immediately. The vendor has released a patched version that corrects the input sanitization and output escaping issues in the Threads embed handler (references show fixes applied in threads.php at lines 49, 50, and 61 in version 2.0.2). WordPress administrators can update via the WordPress admin dashboard (Plugins → Updates) or via command line with wp plugin update social-post-embed. For sites unable to update immediately, restrict Contributor-level access to only trusted users by reviewing WordPress user roles (Settings → Users) and demoting or removing suspicious accounts. Disable the Threads embed feature if it is not actively used by visiting the plugin settings and removing any enabled Threads embed functionality. Monitor for suspicious posts/pages created by contributor accounts between the last security audit and patching, and audit all post revisions for injected scripts.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the Threads embed handler (threads.php) of the Social Post Embed plugin, which processes user-supplied URLs for embedding social media posts. The underlying issue is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation), a foundational weakness in web application security. The plugin fails to properly sanitize URL inputs before storing them in the database and does not escape output when rendering embedded content, allowing malicious JavaScript to be injected directly into WordPress post/page HTML. This affects the core embed functionality where user input is expected to contain legitimate Threads URLs but is instead processed without validation or encoding, making it a classic stored XSS vector. The CPE cpe:2.3:a:dartiss:social_post_embed:*:*:*:*:*:*:*:* confirms all versions through 2.0.1 are affected.
Know when Social Post Embed gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The Social Post Embed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Threads embed handler in all versions up to, and including, 2.0.1. This is due to insufficient input sanitization and output escaping on the user-supplied URL. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-25987
NVD
CVE.org
EPSS
Vulnrichment
GitHub PoC
Exploit-DB