Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain admin credentials
-
DeliveryCraft XSS payload for showconfig
-
ExploitSend malicious URL to victim
-
ExecutionVictim clicks link and visits page
-
PersistMalicious script executes in victim's browser
-
ImpactSteal session or perform unauthorized actions
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS 4.6 reflects a low-risk profile: network-accessible but requiring high administrative privileges (PR:H), user interaction (UI:A), and resulting only in limited integrity impact (VI:L) to other sessions, not confidentiality or availability. The SSVC framework supports this low priority: exploitation is non-critical because (1) prerequisites require compromised admin accounts (rare), (2) the attack is not automatable in a mass-exploitation sense (requires per-victim interaction), and (3) technical impact is limited to XSS of other users, not system compromise. However, in organizations where admin compromise is a realistic threat model, this becomes a privilege-escalation concern. The existence of public exploit code lowers the barrier for motivated threat actors with admin access, but the required high privileges and user interaction mean this is a moderate practical risk rather than critical. |
| Exploit ScenarioDerived | An attacker with stolen or compromised LibreNMS administrator credentials crafts a malicious URL containing JavaScript payload in the showconfig page parameters. The attacker sends this URL to another administrator or privileged user (via email, chat, or by embedding it in a report). When the victim clicks the link and visits the showconfig page, the injected script executes in their browser session, potentially stealing session cookies, performing unauthorized configuration changes on their behalf, or harvesting additional credentials. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 13, 2026
Cross-site Scripting (XSS) in LibreNMS versions before 26.3.0 allows authenticated administrators to inject malicious scripts on the showconfig page, enabling attacks against other authorized users. The vulnerability requires high administrative privileges and user interaction (clicking a malicious link) to execute, resulting in integrity impact to other users' sessions. Publicly available exploit code exists, though CISA KEV status is not confirmed.
RemediationAI
Upgrade LibreNMS to version 26.3.0 or later, which includes the fix for XSS on the showconfig page. Administrators should prioritize this update in their patching cycle, particularly for instances exposed to untrusted networks or with multiple administrative accounts. In the interim, restrict administrative console access to trusted networks via firewall rules and monitor admin activity for suspicious behavior. Refer to the ProjectBlack security advisory at https://projectblack.io/blog/librenms-authenticated-rce-and-xss/#xss-on-showconfig-page-2630 for additional context and verification of patched versions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This is a Stored or Reflected XSS vulnerability (CWE-79: Improper Neutralization of Input During Web Page Generation) in LibreNMS, a network monitoring and management platform. The showconfig page fails to properly sanitize or encode user-supplied input before rendering it in HTML context. Because LibreNMS is built as a PHP-based web application, insufficient output encoding allows an attacker with admin credentials to inject JavaScript that executes in victims' browsers. The attack surface is limited to the showconfig page specifically, and exploitation requires the victim to access a crafted URL or interact with the compromised page while logged in.
Know when Librenms gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
4DescriptionCVE.org
LibreNMS versions before 26.3.0 are affected by an authenticated Cross-site Scripting vulnerability on the showconfig page. Successful exploitation requires administrative privileges. Exploitation could result in XSS attacks being performed against other users with access to the page.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
An issue was discovered in LibreNMS through 1.47. Rated high severity (CVSS 7.2), this vulnerability is remotely exploit
Librenms 21.11.0 is affected by a path manipulation vulnerability in includes/html/pages/device/showconfig.inc.php. Rate
An issue was discovered in LibreNMS through 1.47. Rated critical severity (CVSS 9.8), this vulnerability is remotely exp
Authentication bypass in the LibreNMS REST API (all versions before 26.8.0) lets unauthenticated remote attackers reach
SQL injection in LibreNMS 25.12.0 and below. PoC and patch available.
An issue was discovered in LibreNMS through 1.47. Rated critical severity (CVSS 9.1), this vulnerability is remotely exp
SQL injection in LibreNMS versions 25.12.0 and below allows authenticated users to extract sensitive database informatio
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Rated high severity (CVSS 8.8), this vulnera
An issue was discovered in LibreNMS before 1.65.1. Rated high severity (CVSS 8.8), this vulnerability is remotely exploi
An issue was discovered in LibreNMS 1.50.1. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable,
An issue was discovered in LibreNMS through 1.47. Rated high severity (CVSS 8.8), this vulnerability is remotely exploit
Command injection in LibreNMS's Virtualization Discovery module enables authenticated administrator-level users to execu
EUVD-2026-21907
GHSA-5gm9-622f-qcg5
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB