Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as non-admin operator
-
DeliveryInitiate backend reconnect
-
ExploitRequest elevated operator.admin scope
-
ExecutionBypass pairing verification
-
ImpactGain unauthorized administrative privileges
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V6 - Authentication Incorrect use of privileged APIs
|
| Exploitation Conditions | Requires authenticated access as non-admin operator to OpenClaw before version 2026.3.25. Attacker must initiate a backend reconnect to exploit the privilege escalation and bypass pairing requirements, self-requesting operator.admin scope elevation. |
| Impact | CVSS 8.8 reflects high impact across confidentiality, integrity, and availability. Authenticated network attack with low complexity enables privilege escalation to admin. Patch availability reduces urgency but unauthenticated pre-compromise is not a factor here-existing operator access is prerequisite. Priority depends on operator account distribution and backend reconnect frequency in deployments. |
| Exploit ScenarioDerived | Authenticated operator initiates backend reconnect and self-requests operator.admin scope in reconnection payload, bypassing pairing validation. System grants elevated privileges, allowing unauthorized administrative actions. No public exploit code identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
Privilege escalation in OpenClaw versions prior to 2026.3.25 allows authenticated low-privilege operators to bypass pairing requirements during backend reconnection, self-requesting elevated scopes to gain operator.admin privileges. Attackers with existing operator credentials exploit improper scope validation (CWE-648) to escalate from limited operator access to full administrative control over the OpenClaw system. Exploitation requires network access and low-privilege authentication (CVSS:3.1 PR:L), enabling high-impact compromise of confidentiality, integrity, and availability. No public exploit identified at time of analysis.
RemediationAI
Vendor-released patch: upgrade to OpenClaw version 2026.3.25 or later, which implements strict scope validation during backend reconnection. Apply commit d3d8e316bd819d3c7e34253aeb7eccb2510f5f48 from the upstream repository if building from source. Organizations unable to immediately upgrade should restrict operator account provisioning to trusted personnel only, monitor backend reconnection logs for anomalous scope elevation attempts, and enforce network segmentation to limit operator access surfaces. Disable backend reconnect functionality if operationally feasible until patching completes. Review existing operator accounts for unauthorized privilege escalation and revoke compromised credentials. Consult vendor advisory at https://github.com/openclaw/openclaw/security/advisories/GHSA-9hjh-fr4f-gxc4 and detailed analysis at https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-backend-reconnect-scope-self-claim for implementation guidance.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Root cause stems from insufficient verification of scope claims during backend reconnect operations (CWE-648 Incorrect Use of Privileged APIs). The reconnection handler fails to validate whether requesting operators hold legitimate entitlements for administrator-level scopes, permitting self-escalation from operator to operator.admin without pairing enforcement. Vendor-released patch d3d8e316bd819d3c7e34253aeb7eccb2510f5f48 addresses scope validation logic.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.25 contains a privilege escalation vulnerability allowing non-admin operators to self-request broader scopes during backend reconnect. Attackers can bypass pairing requirements to reconnect as operator.admin, gaining unauthorized administrative privileges.
Blast Radius
ecosystem impact- 3 npm packages depend on openclaw (3 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.24.
Executive ViewAI
OpenClaw versions before 2026.3.25 contain a privilege escalation vulnerability that allows authenticated operators with low-level access to bypass security controls and grant themselves administrator privileges, creating a direct path for insiders or compromised accounts to gain complete system control. Organizations running affected OpenClaw deployments face immediate risk of unauthorized administrative access, data breach, and operational disruption from users with minimal initial privileges.
Apply vendor patch. Until patching is complete, implement network segmentation to restrict operator access to critical OpenClaw systems, enforce strict monitoring of scope escalation requests, disable or restrict low-privilege operator accounts where operationally feasible, and require multi-factor authentication for any scope elevation requests.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Related Vulnerabilities in OpenClaw Multiple Authorization and Privilege Escalation
View all 29Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21472
GHSA-9hjh-fr4f-gxc4
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB