Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 score of 5.4 with vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L correctly reflects a moderate privilege escalation risk. The attack vector is network-based with low complexity, requiring only low-privilege authentication (PR:L), making it easily exploitable by any subscriber account. The impact is limited to integrity and availability (image deletion, option modification) without confidentiality breach from the normal user perspective, though log file access ( |
| Exploit ScenarioDerived | An authenticated subscriber on a WordPress site with WP-Optimize plugin active could trigger the vulnerable Heartbeat handler by opening the WordPress dashboard or front-end pages that load the Heartbeat script. Without requiring any additional user interaction or elevated privileges, the attacker sends a heartbeat request containing a call to admin-restricted Smush methods such as |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
WP-Optimize plugin for WordPress allows authenticated subscribers and higher to execute admin-only operations including log file access, backup image deletion, and bulk image processing due to missing capability checks in the Heartbeat handler function. The vulnerability affects all versions up to 4.5.0 and requires user authentication but no elevated privileges, enabling privilege escalation from subscriber-level accounts to perform administrative image optimization tasks that should be restricted to site administrators.
RemediationAI
Update the WP-Optimize plugin immediately to a patched version released after 4.5.0. Site administrators should upgrade through the WordPress admin dashboard (Plugins > Installed Plugins > WP-Optimize, then click Update if available) or manually download the latest version from plugins.wordpress.org/wp-optimize/. Pending patch availability, restrict plugin functionality by disabling the Heartbeat API for non-administrator users through server-side filtering or by using security plugins that enforce capability checks on AJAX handlers. Review WordPress user roles to ensure subscriber and contributor accounts are assigned only to trusted users; consider elevating critical image optimization tasks to administrator-only roles. Check Wordfence threat intelligence at https://www.wordfence.com/threat-intel/vulnerabilities/id/6a0a376e-ea3a-40ca-9341-f28f92e15e02 and the WordPress plugin repository change log for confirmation of patched versions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the receive_heartbeat() function within includes/class-wp-optimize-heartbeat.php, which implements WordPress's Heartbeat API for periodic client-server communication. This handler directly invokes methods from the Updraft_Smush_Manager_Commands class without performing the security checks enforced by the standard AJAX handler updraft_smush_ajax. Specifically, the code bypasses three security layers: user capability verification, WordPress nonce token validation, and the whitelist of allowed commands. CWE-863 (Incorrect Authorization) classifies this as an authorization flaw where access control decisions are not properly implemented. The Heartbeat API is designed for authenticated users, but the missing checks in this specific handler allow any authenticated user-even those with minimal subscriber-level permissions-to invoke administrative functions intended only for site managers.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The WP-Optimize plugin for WordPress is vulnerable to unauthorized access of functionality due to missing capability checks in the receive_heartbeat() function in includes/class-wp-optimize-heartbeat.php in all versions up to, and including, 4.5.0. This is due to the Heartbeat handler directly invoking Updraft_Smush_Manager_Commands methods without verifying user capabilities, nonce tokens, or the allowed commands whitelist that the normal AJAX handler (updraft_smush_ajax) enforces. This makes it possible for authenticated attackers, with Subscriber-level access and above, to invoke admin-only Smush operations including reading log files (get_smush_logs), deleting all backup images (clean_all_backup_images), triggering bulk image processing (process_bulk_smush), and modifying Smush options (update_smush_options).
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
EUVD-2026-21254
NVD
CVE.org
EPSS
Vulnrichment
GitHub PoC
Exploit-DB