Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessEstablish local access to paired device
-
DeliveryTrigger silent shared-auth reconnection
-
ExploitAuto-approve scope-upgrade request silently
-
ExecutionEscalate operator.read to operator.admin
-
ImpactExecute arbitrary code on node
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V6 - Authentication Incorrect use of privileged APIs
|
| Exploitation Conditions | OpenClaw before 2026.3.25 with paired device authentication enabled. Requires low-privilege local access to trigger silent shared-auth reconnection. Attacker can exploit auto-approval of scope-upgrade requests without user interaction to escalate from operator.read to operator.admin privileges. |
| Impact | CVSS 8.5 reflects high-severity local privilege escalation to remote code execution. Requires authenticated access (PR:L) but no user interaction. Silent auto-approval of scope upgrades from operator.read to operator.admin creates direct RCE pathway on paired devices. Patch availability reduces immediate risk, but unpatched deployments face complete node compromise. |
| Exploit ScenarioDerived | Authenticated attacker triggers local reconnection event on paired device. OpenClaw silently auto-approves scope-upgrade request, escalating privileges to admin. Attacker leverages admin access to execute arbitrary code on node. No public exploit identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 09, 2026
Privilege escalation in OpenClaw (versions prior to 2026.3.25) enables authenticated local attackers to silently elevate permissions from operator.read to operator.admin during shared-auth reconnection events, achieving remote code execution on affected nodes. The vulnerability exploits auto-approval of scope-upgrade requests in local reconnection flows, requiring low-privilege local access (PR:L) with no user interaction. No public exploit identified at time of analysis. Vendor-released patch available via commit 81ebc7e0344fd19c85778e883bad45e2da972229.
RemediationAI
Vendor-released patch: Upgrade to OpenClaw version 2026.3.25 or later. Apply commit 81ebc7e0344fd19c85778e883bad45e2da972229 from upstream repository if building from source. Organizations unable to immediately patch should restrict local access to OpenClaw nodes, disable shared-authentication reconnection features in configuration files, or implement strict authorization controls for paired devices. Review audit logs for suspicious operator permission escalations from operator.read to operator.admin during reconnection events. Vendor advisory: https://github.com/openclaw/openclaw/security/advisories/GHSA-fqw4-mph7-2vr8. Patch commit details: https://github.com/openclaw/openclaw/commit/81ebc7e0344fd19c85778e883bad45e2da972229. Additional technical analysis: https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-silent-local-shared-auth-reconnect.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-648 (Incorrect Use of Privileged APIs) stems from shared-authentication reconnection logic failing to validate scope-upgrade requests. Local reconnection triggers silent auto-approval, escalating operator.read permissions to operator.admin without authorization checks. Exploitation chain: trigger local reconnect → auto-approve scope upgrade → execute privileged operations → achieve RCE on node infrastructure. Affects all OpenClaw versions prior to 2026.3.25.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.25 contains a privilege escalation vulnerability where silent local shared-auth reconnects auto-approve scope-upgrade requests, widening paired device permissions from operator.read to operator.admin. Attackers can exploit this by triggering local reconnection to silently escalate privileges and achieve remote code execution on the node.
Blast Radius
ecosystem impact- 3 npm packages depend on openclaw (3 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.24.
Executive ViewAI
OpenClaw versions prior to 2026.3.25 contain a privilege escalation vulnerability that allows authenticated local users to gain administrative access and execute code on affected nodes during reconnection events. This impacts any organization running vulnerable OpenClaw instances with local user access, potentially compromising system integrity and enabling lateral movement within infrastructure.
Apply vendor patch. If immediate patching is not feasible: (1) Restrict local system access to trusted operators only, (2) disable or closely monitor shared-auth reconnection events, (3) implement logging and alerting for scope-upgrade requests, (4) segregate OpenClaw nodes from general user access networks.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.
Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21108
GHSA-8vgj-c3fx-pprx
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB