Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS score of 5.3 indicates moderate severity with network-based attack vector, low complexity, and no privilege requirements-suggesting an easily triggerable flaw. However, EPSS exploitation probability of 0.02% percentile (4th percentile) significantly dampens real-world risk, indicating very low likelihood of active exploitation. CISA SSVC framework assessment confirms no observed exploitation, though the impact is marked as 'partial' and the flaw is automatable, meaning once weaponized it could scale quickly. The confidentiality impact is limited (C:L) with no integrity or availability risk. Cross-referencing signals: the high CVSS vs. minimal EPSS discrepancy suggests this is a technically valid but contextually low-priority flaw-important to patch for WooCommerce sites handling sensitive book content, but not an urgent priority for organizations without this plugin or with limited book commerce operations. The broken access control class (CWE-862) ranks high in severity taxonomies, but exploitation requires the plugin to be actively used and improperly configured. |
| Exploit ScenarioDerived | An unauthenticated attacker scans a WooCommerce site running Book Previewer for WooCommerce ≤1.0.6 and crafts a direct request (GET/POST) to the plugin's preview endpoint without authentication. Due to missing authorization checks, the plugin returns preview content that should be restricted to paying customers or administrators, allowing the attacker to read sensitive book excerpts, metadata, or cover images. No sophisticated tools or user interaction are required, making the exploit low-complexity and automatable at scale across vulnerable installations, though current public exploit code availability is not confirmed. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
Book Previewer for WooCommerce plugin versions up to 1.0.6 fail to enforce authorization checks on sensitive functionality, allowing unauthenticated remote attackers to access restricted content with low-complexity exploitation. The vulnerability stems from missing access control validation, enabling attackers to bypass intended security boundaries without user interaction. While CVSS rates this as moderate (5.3), EPSS exploitation probability remains minimal at 0.02% percentile, and no public exploit code or active exploitation has been confirmed.
RemediationAI
Update Book Previewer for WooCommerce to a patched version beyond 1.0.6 immediately. WordPress plugin updates are available directly from the WordPress admin dashboard (Plugins > Installed Plugins > Book Previewer for WooCommerce > Update) or manually from the WordPress plugin repository at https://wordpress.org/plugins/book-previewer-for-woocommerce/. For detailed vulnerability information and patch confirmation, refer to the Patchstack advisory at https://patchstack.com/database/Wordpress/Plugin/book-previewer-for-woocommerce/vulnerability/wordpress-book-previewer-for-woocommerce-plugin-1-0-6-broken-access-control-vulnerability. Until patching is completed, site administrators should verify that book preview access is restricted to authorized users at the WooCommerce product/customer level, though this may not fully compensate for plugin-level access control flaws.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This is a broken access control vulnerability (CWE-862) in the Book Previewer for WooCommerce WordPress plugin, which integrates with WooCommerce to provide book preview functionality. The plugin fails to implement proper authorization checks on its exposed endpoints or functions, likely in the REST API or AJAX handlers that retrieve or display book preview content. The affected component relies on incorrectly configured access control security levels that do not validate user permissions or capabilities before serving restricted resources. WordPress plugins are vulnerable to this class of issue when they expose functionalities without checking the current user's role or capabilities, allowing both unauthenticated and unprivileged users to perform actions intended only for administrators or paying customers.
Know when Book Previewer For Woocommerce gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Missing Authorization vulnerability in g5theme Book Previewer for Woocommerce book-previewer-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Book Previewer for Woocommerce: from n/a through <= 1.0.6.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-20342
GHSA-j4m2-98ph-wgm7
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB