Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as WordPress admin
-
DeliveryCraft XSS payload in Qubely block
-
ExploitStore payload in page/post
-
ExecutionVictim visits compromised page
-
PersistMalicious script executes in victim browser
-
ImpactAttacker exfiltrates session cookie or credentials
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Successful exploitation requires the attacker to possess WordPress administrator or editor-level privileges (PR:H) and the victim to view the page containing the injected payload (UI:R). No special plugin configuration or non-default settings are required-the vulnerability exists in the standard Qubely page builder interface used during normal page and post creation. The attacker must use authenticated access to the WordPress admin dashboard or editor to inject the XSS payload via Qubely's content blocks or page elements. |
| Impact | This vulnerability presents moderate but contained risk. The CVSS score of 5.9 (Medium) reflects high attack complexity due to authentication and user interaction requirements (PR:H, UI:R), which significantly restrict exploitation scope compared to unauthenticated network vectors. The EPSS score of 0.03% (8th percentile) indicates exploitation is extremely unlikely in practice despite public awareness, suggesting limited attacker interest or technical barriers. The stored XSS impact (C:L, I:L, A:L) is further constrained by scope change (S:C), meaning impact is limited to the confidentiality, integrity, and availability of the affected application itself, not other systems. Real-world risk depends on WordPress site exposure: high-traffic sites with multiple editors face elevated risk from insider threats, while private or low-traffic installations face minimal exploitation probability. This is a legitimate vulnerability requiring patching, but not an urgent emergency-response scenario. |
| Exploit ScenarioDerived | An authenticated WordPress administrator or editor with malicious intent uses the Qubely page builder interface to inject JavaScript code (e.g., <script>steal_cookies()</script>) into a page element or block. The payload is stored in the WordPress database without sanitization. When other site users (including additional administrators) view the compromised page, the script executes in their browsers, potentially capturing session cookies, redirecting to phishing sites, or injecting advertisements. No public exploit code is required-the attack is manual and relies on the attacker's existing admin credentials and the victim's page view. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Stored cross-site scripting (XSS) in Themeum Qubely WordPress plugin version 1.8.14 and earlier allows authenticated high-privilege users to inject malicious scripts that execute in the browsers of other site visitors, compromising session integrity and enabling credential theft or malware distribution. The vulnerability requires administrator authentication and user interaction (UI:R), limiting immediate risk, but stored persistence means injected payloads remain active until remediated. EPSS exploitation probability is extremely low at 0.03%, suggesting minimal real-world targeting despite public disclosure.
RemediationAI
Update Themeum Qubely to a version newer than 1.8.14 immediately; consult the plugin's official release page or WordPress.org plugin repository for the latest patched version number. If an immediate upgrade is not possible, restrict administrative and editor access to trusted users only, disable the plugin temporarily, or implement Web Application Firewall (WAF) rules to detect and block stored XSS payloads in Qubely-generated content. Review WordPress user roles and audit recent posts/pages created or modified by high-privilege accounts for suspicious script injections. Additional guidance is available at https://patchstack.com/database/Wordpress/Plugin/qubely/vulnerability/wordpress-qubely-plugin-1-8-14-cross-site-scripting-xss-vulnerability and https://nvd.nist.gov/vuln/detail/CVE-2026-39638.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Qubely is a WordPress page builder plugin that handles user-supplied input during web page generation without proper sanitization or encoding, allowing attackers to bypass input validation mechanisms. The vulnerability exploits CWE-79 (Improper Neutralization of Input During Web Page Generation), a class of weaknesses where untrusted data is rendered in HTML contexts without neutralization. The affected plugin versions (CPE:a:themeum:qubely:*) fail to escape or validate content at the point of storage or output, enabling stored XSS payloads to persist in the WordPress database and execute within the security context of authenticated users viewing the compromised page.
Know when Qubely gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themeum Qubely qubely allows Stored XSS.This issue affects Qubely: from n/a through <= 1.8.14.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
The Qubely - Advanced Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themeum Qubely - A
Broken access control in the Qubely WordPress Gutenberg block plugin (versions up to and including 1.8.14) allows unauth
EUVD-2026-20296
GHSA-338c-7gw3-rg6c
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB