Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While the CVSS score of 3.0 (Low) reflects the impact constraints-high privilege requirement (PR:H), high attack complexity (AC:H), limited confidentiality impact (C:L), no integrity or availability impact-the real-world risk hinges on organizational deployment context. The requirement for high-privilege credentials significantly limits the threat surface; however, insider threats from administrative users with legitimate platform access represent a credible attack vector. The authentication requirement (PR:H per CVSS vector) reduces likelihood of external exploitation substantially. No EPSS probability data, active exploitation evidence (KEV status not provided), or public proof-of-concept is available, indicating low immediate prioritization. Organizations managing multi-tenant or heavily compartmentalized environments should assess their administrative access governance and monitor for unauthorized record access patterns. This is best characterized as a privilege-boundary-enforcement issue rather than a critical threat. |
| Exploit ScenarioDerived | A high-privilege administrator with legitimate access to runZero Platform's management console could intentionally or inadvertently query MCP endpoints to retrieve asset records, vulnerability data, or configuration information belonging to other organizations within the same platform instance. Due to the high attack complexity (AC:H) and privilege requirement, exploitation requires either deliberate abuse by an insider or a sophisticated social engineering scenario convincing an administrator to execute specific MCP queries. No public exploit code exists to automate this action, limiting the attack surface to knowledgeable internal users or threat actors with compromised administrative credentials. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
Incorrect authorization in runZero Platform MCP endpoints allows authenticated high-privilege users to access records outside their authorized organization scope, exposing sensitive data across organizational boundaries. The vulnerability affects runZero Platform versions prior to 4.0.260206.0 and requires high-privilege credentials to exploit, resulting in limited confidentiality impact. No public exploit code or active exploitation has been identified.
RemediationAI
Organizations should immediately upgrade to runZero Platform version 4.0.260206.0 or later, which includes the fix for the MCP endpoint authorization controls. Until patching is completed, restrict high-privilege administrative access to only personnel requiring MCP endpoint interaction, and implement network segmentation to limit unauthorized administrative sessions if deployment architecture permits. Verify remediation by testing cross-organization record access attempts with high-privilege credentials. Consult the runZero release notes (https://help.runzero.com/docs/release-notes/#402602060) and advisory (https://www.runzero.com/advisories/runzero-platform-mcp-infoleak-cve-2026-5382/) for additional deployment guidance.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is rooted in CWE-863 (Incorrect Authorization), a class of flaw where access control mechanisms fail to properly enforce organizational boundaries. The MCP (Management Control Plane) endpoints in runZero Platform lack sufficient authorization checks to validate that requesting users are restricted to their assigned organization scope. This allows privilege escalation within the application's authorization model, where high-privilege users can bypass organization isolation controls to query and retrieve records belonging to other organizations, even though no actual privilege elevation occurs at the user account level. The issue manifests through the platform's API/endpoint layer rather than in underlying authentication mechanisms.
Know when Platform gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N
Primary rating from Vendor (runZero) · only source for this CVE.
CVSS VectorVendor: runZero
Lifecycle Timeline
2DescriptionCVE.org
An issue that could expose records outside of the authorized organization scope through the MCP endpoints has been resolved. This is an instance of CWE-863: Incorrect Authorization, and has an estimated CVSS score of CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N (3.0 Low). This issue was fixed in version 4.0.260206.0 of the runZero Platform.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Server-side request forgery in Huly Platform's /import endpoint allows authenticated workspace users to coerce the front
Affected 1E Platform versions have a Blind SQL Injection vulnerability that can lead to arbitrary code execution. Rated
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dash
Pega Platform before version 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability in the comment tags.
The Richtext Editor in Pega Platform before 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability. Rate
Improper privilege management in runZero Platform allows organization administrators to escalate privileges to superuser
Improper link resolution before file access in the Nomad module of the 1E Client, in versions prior to 25.3, enables an
Incorrect access control in the component ApiPayController.java of platform v1.0.0 allows attackers to access sensitive
Incorrect access control in the component orderService.queryObject of platform v1.0.0 allows attackers to access sensiti
Incorrect access control in the component ApiOrderService.java of platform v1.0.0 allows attackers to access sensitive i
The 1E-Exchange-DisplayMessageinstruction that is part of the End-User Interaction product pack available on the 1E Exch
The 1E-Exchange-CommandLinePing instruction that is part of the Network product pack available on the 1E Exchange does n
EUVD-2026-19699
GHSA-69vg-gq6x-ppc2
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB