Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Least privilege enforcement
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 4.0 vector (AV:N AC:H AT:P PR:N UI:N VC:N VI:L VA:N) indicates remote network-based attack with high complexity, partial attack time, and no user interaction required. The impact is limited to integrity (VI:L), with no confidentiality or availability loss. The EPSS exploitation probability is not provided, but the high attack complexity and partial timing window (AT:P) suggest this is not a trivial exploitation path-an attacker must find a specific timing or state condition and possess knowledge of subscription tiers. The CVSS score of 6.3 reflects medium risk; however, real-world impact depends on the value of premium features in the Discourse deployment and whether subscription revenue is material. This is a privilege-escalation vulnerability affecting payment integrity rather than system compromise, making it a business-critical rather than operationally-critical risk. No KEV status or public POC is noted, suggesting no active exploitation campaign is currently tracked. |
| Exploit ScenarioDerived | An attacker with network access to a Discourse instance identifies the subscription purchase workflow and discovers that tier benefits are granted via a separate, insufficiently-protected call. The attacker purchases a lower-cost subscription plan and, during a specific timing window or via direct parameter manipulation, triggers the benefit-grant endpoint to assign higher-tier benefits. If the subscription system does not validate that the granted benefits match the purchased tier, the attacker gains premium features (e.g., advanced analytics, priority support, or exclusive forum access) at a discounted rate. The high attack complexity suggests this requires either precise timing, knowledge of internal APIs, or trial-and-error testing, making it less likely to be exploited at scale in the wild but potentially valuable to cost-conscious users seeking premium features. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 31, 2026
Discourse versions 2026.1.0-2026.1.2, 2026.2.0-2026.2.1, and 2026.3.0-pre allow authenticated users to escalate their subscription tier by purchasing a lower-cost plan while obtaining benefits reserved for higher-tier subscriptions. The vulnerability has a CVSS 6.3 score reflecting the integrity impact, requires high attack complexity and partial timing conditions, but affects confidentiality minimally. Vendor-released patches address the flaw in versions 2026.1.3, 2026.2.2, and 2026.3.0, and the exploit likely requires knowledge of the subscription grant mechanism.
RemediationAI
Vendor-released patches: Upgrade Discourse to version 2026.1.3 or later for the 2026.1 branch, version 2026.2.2 or later for the 2026.2 branch, or version 2026.3.0 or later for the 2026.3 branch. The fix is committed in https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80. For organizations unable to upgrade immediately, review subscription grant logic in the codebase and implement additional authorization checks to verify that a user's purchased tier matches the benefits being provisioned. Audit active subscriptions to identify any instances where lower-cost plans were granted higher-tier benefits, and remediate affected accounts by adjusting their subscription tier or benefits accordingly. Consult the GitHub Security Advisory for additional mitigation context.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 3 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is rooted in improper access control (CWE-269: Improper Access Control) within Discourse's subscription tier management system. Discourse is a Ruby on Rails-based discussion and community platform that manages user roles, permissions, and subscription benefits. The flaw allows privilege escalation through subscription tier manipulation-a user can purchase a lower-cost subscription plan but trigger a code path that assigns benefits typically reserved for higher-tier subscriptions. This suggests inadequate authorization checks between the purchase transaction and the benefit-grant operation, or a race condition in the subscription provisioning logic. The CPE cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* indicates all prior versions of Discourse are in scope until the patched releases.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, a user may be able to purchase a lower tier subscription but grant themselves the benefits that comes along with a higher tier subscription. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
EUVD-2026-17569
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB