Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | This is a low-priority vulnerability despite public exploit availability. CVSS 3.5 (low severity) combined with PR:L (requires authenticated login) and UI:R (requires user interaction to click/interact with malicious content) significantly restricts real-world exploitability compared to unauthenticated remote code execution. EPSS exploitation probability is likely moderate given public POC exists, but the authentication barrier and user-interaction requirement limit mass exploitation potential. SSVC perspective: exploitation is PUBLIC (POC available), but automatable only if an attacker already has authenticated access and can trick users into specific interactions within the OpenUI annotator interface. Technical impact is integrity-only (I:L - minor data integrity impact), not confidentiality or availability. This is a legitimate but low-severity issue suitable for patching in a routine maintenance cycle rather than emergency response, though authenticated users should be aware of the risk if running vulnerable versions. |
| Exploit ScenarioDerived | An authenticated user (e.g., an organization member with OpenUI access) crafts a malicious message payload targeting the Window Message Event Handler in the annotator interface. The attacker sends this payload (via postMessage or social engineering link) to trick another authenticated user into interacting with it within the annotator context. The injected JavaScript executes in the victim's browser session with their permissions, potentially exfiltrating annotation data, modifying project settings, or stealing session tokens. Publicly available exploit code demonstrates this attack path and can be adapted by an attacker with basic JavaScript knowledge. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 28, 2026
Stored cross-site scripting (XSS) in wandb OpenUI up to version 1.0 via the Window Message Event Handler in frontend/public/annotator/index.html allows authenticated remote attackers to inject malicious scripts with user interaction. The vulnerability has a low CVSS score (3.5) due to authentication and user-interaction requirements, but publicly available exploit code exists and the vendor has not responded to early disclosure notifications.
RemediationAI
Upgrade wandb OpenUI to a version newer than 1.0 when available from the vendor. Immediate workaround options are limited due to vendor non-responsiveness; however, users should restrict access to the annotator interface to trusted users only and apply input validation/content security policies (CSP) at the web server level to mitigate XSS impact. The exploit code is documented in the VulDB reference (https://vuldb.com/?id.353882) and a proof-of-concept is publicly available at https://gist.github.com/YLChen-007/899f210b2d78e163d13561bb7f49b4da, which can be used to validate whether your instance is vulnerable. Given the vendor's lack of response to early disclosure, monitor community channels and security mailing lists for unofficial patches or vendor updates.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from improper sanitization of window message events in the annotator component (CWE-79: Improper Neutralization of Input During Web Page Generation). The Window Message Event Handler in OpenUI's frontend processes untrusted data from postMessage() calls without adequate validation or output encoding. This is a classic reflected/stored XSS weakness where user-controlled input flows directly into the DOM or HTML context. The affected CPE indicates wandb OpenUI as the product family, with all versions up to and including 1.0 containing this flaw. The postMessage API, while powerful for cross-origin communication, is frequently the source of DOM-based XSS when handlers trust their message sources without validation.
Know when Wandb gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
4DescriptionCVE.org
A vulnerability was determined in wandb OpenUI up to 1.0. Affected by this vulnerability is an unknown functionality of the file frontend/public/annotator/index.html of the component Window Message Event Handler. This manipulation causes cross site scripting. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. The vendor was contacted early about this disclosure but did not respond in any way.
Executive ViewAI
Organizations using wandb OpenUI should be aware of moderate risk from CVE-2026-4995, a cross-site scripting vulnerability rated CVSS 5.1. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Proof-of-concept code is publicly available. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Related Vulnerabilities in wandb OpenUI Multiple Vulnerabilities
View all 3Path traversal in the Weights & Biases (wandb) Python client before 0.29.0 lets a malicious or compromised W&B backend p
HTML injection in wandb OpenUI up to version 1.0 allows remote unauthenticated attackers to inject arbitrary HTML via ma
Artifact Integrity Validation in wandb 0.25.2.dev1 uses MD5 (a cryptographically broken hash algorithm) within ArtifactM
EUVD-2026-16917
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB