Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A10:2025 - Mishandling of Exceptional Conditions
ASVS 5.0
V16 - Security Logging and Error Handling Exception handling framework
|
| Impact | Although CVSS scoring data is unavailable, this vulnerability presents significant real-world risk due to its impact scope. The required authentication (authenticated host) narrows the attack surface to established agents or compromised endpoints already enrolled in Fleet; however, once authenticated, the attacker can unilaterally crash infrastructure serving potentially thousands of managed devices. The availability impact is critical-a single authenticated host can disable MDM management, disrupt API operations, and require manual server restart, making this a practical denial-of-service weapon in post-compromise scenarios or environments with weak host security. The attack complexity is trivial (sending a single malformed message), and exploitation requires no special network positioning. This is a high-priority patch despite missing CVSS data because of the ease of exploitation and broad blast radius affecting infrastructure operations, not just a single host. |
| Exploit ScenarioDerived | An attacker with an enrolled Fleet agent (authenticated host) or compromised endpoint sends a crafted gRPC message to the Launcher endpoint containing an invalid log type value outside the expected enumeration. The Fleet server fails to validate or catch this exception, causing the process to crash immediately and terminating all active connections to the MDM infrastructure. While the scenario requires prior host enrollment or compromise, the trivial nature of crafting a malformed gRPC message means exploitation could occur within seconds of gaining authenticated access, making this a critical post-compromise capability. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 27, 2026
Denial-of-service vulnerability in Fleet device management software prior to version 4.81.0 allows authenticated hosts to crash the entire Fleet server process by sending a malformed log type value to the gRPC Launcher endpoint, disrupting all connected devices, MDM enrollments, and API consumers. The vulnerability requires prior authentication but affects availability across the entire infrastructure. Vendor-released patch: version 4.81.0.
RemediationAI
Upgrade Fleet to version 4.81.0 or later, which contains the fix for input validation on the gRPC Launcher endpoint. The patch adds proper exception handling and validation for log type values to prevent server termination on unexpected inputs. Administrators should apply this update urgently, especially in production MDM environments. Refer to the GitHub security advisory at https://github.com/fleetdm/fleet/security/advisories/GHSA-w254-4hp5-7cvv for detailed upgrade instructions and rollout guidance. Until patching is complete, monitor server logs for unexpected exceptions from the Launcher endpoint and implement network segmentation to limit which hosts can reach the gRPC endpoint if available.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in go, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Fleet's gRPC Launcher endpoint implements log type validation at the application layer. The vulnerability stems from improper input validation (CWE-703: Improper Check or Handling of Exceptional Conditions) where unexpected log type values trigger an uncaught exception or unhandled edge case, causing the server process to terminate abnormally. gRPC is a high-performance RPC framework using Protocol Buffers for serialization; malformed message payloads that violate schema constraints can propagate uncontrolled through the application if validation boundaries are incomplete. The affected product cpe:2.3:a:fleetdm:fleet:*:*:*:*:*:*:*:* encompasses all versions prior to 4.81.0.
Know when Fleet gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Primary rating from Vendor (GitHub_M).
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
Fleet is open source device management software. Prior to 4.81.0, a denial-of-service vulnerability in Fleet's gRPC Launcher endpoint allows an authenticated host to crash the entire Fleet server process by sending an unexpected log type value. The server terminates immediately, disrupting all connected hosts, MDM enrollments, and API consumers. Version 4.81.0 patches the issue.
Executive ViewAI
Organizations using Fleet should be aware of notable risk from CVE-2026-34388 rated CVSS 6.6. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Denial of Service attacks render applications or systems unavailable by overwhelming resources or triggering failure conditions.
Fleet device management software has a signature verification bypass that allows attackers to install malicious firmware
Fleet is an open source osquery manager. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable,
Unauthenticated attackers can bypass authentication in Fleet (versions before 4.87.0) by using non-secret device identif
OS command injection in Fleet's generator for Fleet-maintained macOS app install and uninstall scripts allows crafted Ho
Privilege escalation in SUSE Rancher Fleet (0.14.x before 0.14.11, 0.15.x before 0.15.7, and 0.16.x before 0.16.2) lets
SQL injection in Fleet device management software before version 4.80.1 allows authenticated users to manipulate the ord
Unauthenticated denial of service in FleetDM Fleet before 4.83.0 allows remote attackers to exhaust server memory by sen
Unauthenticated denial-of-service in Fleet Device Management before 4.89.0 allows remote attackers to crash the server b
Fleet device management software versions prior to 4.78.3 suffer from broken access control that permits any authenticat
fleetdm/fleet is an open source device management, built on osquery. Rated high severity (CVSS 8.1), this vulnerability
Fleet before 2.1.2 allows exposure of SMTP credentials. Rated high severity (CVSS 7.5), this vulnerability is remotely e
Cross-tenant authorization bypass in SUSE Rancher Fleet allows a party who can perform agent-initiated cluster registrat
EUVD-2026-16795
GHSA-w254-4hp5-7cvv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB