Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | Without a CVSS vector, EPSS score, or confirmation of KEV status, a complete quantitative risk assessment is challenging. However, the qualitative signals are concerning: Stored XSS vulnerabilities are inherently high-severity due to their persistent nature and broad victim scope (all site visitors). The attack vector is likely Network (via plugin input fields or settings), and complexity is typically Low for this vulnerability class. Patchstack's documentation suggests the vulnerability is confirmed and documented, implying proof-of-concept or functional demonstration exists. The lack of a CVSS score may indicate the CVE is recent or pending formal scoring by NVD. For a WordPress plugin affecting potentially thousands of sites, this represents a meaningful risk if the plugin is widely deployed. Organizations running WP TripAdvisor Review Slider should treat this as a high-priority remediation target, especially if the plugin is exposed to untrusted input or user-submitted reviews. |
| Exploit ScenarioDerived | An attacker with access to submit a review or modify plugin settings injects JavaScript code (e.g., |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Stored Cross-Site Scripting (XSS) vulnerability exists in the WP TripAdvisor Review Slider WordPress plugin through version 14.1, allowing attackers to inject malicious scripts that persist in the database and execute in the browsers of site visitors. The vulnerability affects all versions up to and including 14.1, and an attacker with sufficient privileges to inject content can compromise user sessions, steal credentials, or perform arbitrary actions on behalf of site administrators. No CVSS score or EPSS data is currently available, and active exploitation status via KEV is unknown, but Patchstack has documented this as a confirmed vulnerability with a reference implementation.
RemediationAI
Immediately upgrade the WP TripAdvisor Review Slider plugin to a patched version beyond 14.1 (consult the vendor or Patchstack for the exact patched version number). Visit the official plugin repository or the vendor's website for patch availability. If no patch is immediately available, consider disabling the plugin until a fix is released, as Stored XSS in a public-facing plugin poses significant risk. As a temporary mitigation, restrict write access to plugin settings and review input fields to trusted administrator roles only, and consider using a Web Application Firewall (WAF) rule to detect and block script injection patterns in review submissions. Monitor the Patchstack database and official WordPress plugin repository for security updates.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is classified under CWE-79 (Improper Neutralization of Input During Web Page Generation), which describes the failure to properly sanitize or escape user-supplied input before rendering it in HTML context. The affected product is the jgwhite33 WP TripAdvisor Review Slider plugin (CPE: cpe:2.3:a:jgwhite33:wp_tripadvisor_review_slider:*:*:*:*:*:*:*:*), a WordPress plugin designed to display TripAdvisor reviews on websites. The plugin likely fails to sanitize review data, custom fields, or plugin settings before storing them in the WordPress database or rendering them in front-end templates. Because the XSS is classified as Stored (rather than Reflected), the malicious payload persists in the database, making it a higher-severity attack vector that affects all subsequent visitors to the compromised page.
Know when Wp Tripadvisor Review Slider gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in jgwhite33 WP TripAdvisor Review Slider wp-tripadvisor-review-slider allows Stored XSS.This issue affects WP TripAdvisor Review Slider: from n/a through <= 14.1.
Executive ViewAI
CVE-2026-32490 presents notable security risk, a cross-site scripting vulnerability rated CVSS 6.5. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
More in Wp Tripadvisor Review Slider
View allThe WP TripAdvisor Review Slider WordPress plugin before 10.8 does not properly sanitise and escape a parameter before u
The WP TripAdvisor Review Slider WordPress plugin before 11.9 does not sanitise and escape some of its settings, which c
SQL injection in the WP TripAdvisor Review Slider WordPress plugin (all versions through 14.3) enables authenticated adm
SQL Injection in the WP TripAdvisor Review Slider WordPress plugin (all versions through 14.6) allows authenticated atta
EUVD-2026-15832
GHSA-77pg-69m3-j9m7
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB