Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | Without a published CVSS vector, EPSS score, or CVSS base score, quantitative risk assessment is limited; however, qualitative signals indicate moderate to significant real-world risk. XSS vulnerabilities (CWE-79) are consistently among the most exploitable and damaging web application flaws, with low attack complexity and network-based attack vectors. The fact that Drupal—a high-profile open-source CMS—officially reported this issue suggests active discovery and likely rapid public awareness. The dual-version range (two separate branches affected) indicates the vulnerability may be present in both legacy and recent code paths. The absence of automated exploitation data and the requirement for specific user interaction or configuration typical of UI icon modules suggest this is not a fully autonomous, worm-capable exploit, but remains easily exploitable by human attackers and likely automatable with minor customization. |
| Exploit ScenarioDerived | An attacker crafts a malicious icon configuration or UI element containing embedded JavaScript (e.g., <img src=x onerror=alert('xss')>) and either submits it directly via an admin form or tricks an administrator into importing a compromised configuration file. When the UI Icons module renders the icon in a web page without proper escaping, the attacker's JavaScript executes in the context of the victim's browser, potentially stealing session cookies, redirecting to phishing pages, or modifying page content. The attack requires either direct access to configuration interfaces or social engineering of a trusted user, but once triggered, the payload executes with the privileges of the logged-in user. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Cross-Site Scripting (XSS) vulnerability exists in the Drupal UI Icons module due to improper neutralization of user input during web page generation. This vulnerability affects UI Icons versions 0.0.0 through 1.0.0 and versions 1.1.0 through 1.1.0, allowing attackers to inject malicious scripts that execute in the context of victim browsers. No CVSS score, EPSS data, or confirmed KEV status is currently available; however, the XSS classification and Drupal reporting indicate this requires prompt patching to versions 1.0.1 or 1.1.1.
RemediationAI
Immediately upgrade Drupal UI Icons to version 1.0.1 if running the 1.0.x branch, or to version 1.1.1 if running the 1.1.x branch. Download patches from https://www.drupal.org/sa-contrib-2026-010 and apply via Drupal's module update mechanism or manual file replacement. Until patches can be applied, apply input validation and output encoding patches at the application level if source code access is available, or disable the UI Icons module if not actively required. Additionally, implement Content Security Policy (CSP) headers to restrict script execution and monitor access logs for suspicious payloads or unusual icon configuration requests that may indicate exploitation attempts.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The Drupal UI Icons module (CPE: cpe:2.3:a:drupal:ui_icons:*:*:*:*:*:*:*:*) is a user interface component library for the Drupal content management system. The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation), which is the canonical XSS weakness category. This indicates that the module fails to sanitize or escape user-supplied input before rendering it in HTML output, allowing attackers to inject executable JavaScript code. The root cause stems from inadequate input validation and output encoding mechanisms within the icon rendering or configuration display logic.
Know when Ui Icons gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal UI Icons allows Cross-Site Scripting (XSS).This issue affects UI Icons: from 0.0.0 before 1.0.1, from 1.1.0 before 1.1.1.
Executive ViewAI
CVE-2026-2349 presents moderate security risk, a cross-site scripting vulnerability rated CVSS 6.1. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-15453
GHSA-7478-wj8x-xfw9
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB