Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While CVSS and EPSS scores are not provided in the intelligence data, the vulnerability's characteristics indicate moderate-to-high real-world risk. The attack vector is network-based and requires user interaction (victims must visit a page controlled or influenced by an attacker), typical of stored or reflected XSS. No explicit KEV (Known Exploited Vulnerability) status or public proof-of-concept code is mentioned in the available references, suggesting this may be a responsible disclosure with limited active exploitation at the time of analysis. However, the presence of a Drupal security advisory (SA-CONTRIB-2026-009) and the ENISA EUVD tracking (EUVD-2026-15451) indicate this is treated as a legitimate security concern by the vendor. The fact that patches exist for both affected version branches (1.0.5+ and 2.0.1+) further confirms remediation is available, reducing the practical risk for organizations that patch promptly. For unpatched systems, the risk is significant because XSS in an administration/editing interface can lead to account compromise, privilege escalation, and data theft from site administrators and editors. |
| Exploit ScenarioDerived | An attacker creates a malicious Drupal post or comment containing XSS payload within a field that Quick Edit renders. When a site administrator or content editor visits the page and hovers over or attempts to use the quick edit interface, the JavaScript payload executes in their browser with their privileges and session cookie, allowing the attacker to steal authentication tokens, modify content, create new admin accounts, or perform other actions as the victim user. This scenario is particularly dangerous because quick edit is typically enabled for administrative users who have higher-level permissions and access to sensitive site configuration. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Cross-Site Scripting (XSS) vulnerability exists in Drupal Quick Edit due to improper neutralization of user input during web page generation. This vulnerability affects Quick Edit versions 0.0.0 through 1.0.4 and versions 2.0.0 through 2.0.0, allowing attackers to inject malicious scripts that execute in the context of authenticated users' browsers. The vulnerability is classified under CWE-79 (Improper Neutralization of Input During Web Page Generation) and has been disclosed by the Drupal security team with patches available for affected versions.
RemediationAI
Immediately upgrade Drupal Quick Edit to version 1.0.5 or later for the 1.x branch, or to version 2.0.1 or later for the 2.x branch. Consult the official Drupal security advisory at https://www.drupal.org/sa-contrib-2026-009 for detailed patching instructions specific to your Drupal version. As a temporary mitigation for systems that cannot be patched immediately, restrict access to the Quick Edit interface by disabling the module or using Drupal's permission system to limit quick edit capabilities to highly trusted administrative users only. Additionally, implement Content Security Policy (CSP) headers to restrict script execution and reduce the impact of any injected XSS payloads. Review access logs and user activity for signs of exploitation, particularly targeting administrative and editor accounts.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Drupal Quick Edit is a core/contributed module that provides in-place editing capabilities for content fields without requiring users to navigate to a separate edit form. The vulnerability stems from inadequate input sanitization when rendering editable content regions on the page, specifically failing to properly escape or neutralize user-supplied input before it is inserted into the HTML DOM during the quick edit interface generation. This is a classic CWE-79 (Cross-site Scripting) vulnerability where untrusted data flows directly into the page output without validation or encoding. The affected CPE entry (cpe:2.3:a:drupal:quick_edit:*:*:*:*:*:*:*:*) encompasses all Quick Edit module versions across all Drupal installations, making this a broad-impact vulnerability affecting any site using the module in vulnerable versions.
Know when Quick Edit gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Quick Edit allows Cross-Site Scripting (XSS).This issue affects Quick Edit: from 0.0.0 before 1.0.5, from 2.0.0 before 2.0.1.
Executive ViewAI
CVE-2026-2348 presents moderate security risk, a cross-site scripting vulnerability rated CVSS 5.4. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-15451
GHSA-vmwp-f54q-chhh
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB