Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS:4.0 vector (AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N) indicates low real-world urgency compared to the moderate base score: the attack requires network access (AV:N) with low complexity (AC:L), but critically requires prior authentication with moderator privileges (PR:L), which significantly restricts the attacker pool. The impact is confined to confidentiality (VC:L) with no integrity or availability impact, meaning data exfiltration rather than system compromise. Without disclosed EPSS data or KEV status indicating active exploitation, and given that patches are available and the vulnerability requires legitimate moderator credentials, this should be prioritized as a medium-priority update rather than a critical incident. Organizations running Discourse should apply patches promptly but need not declare emergency response; however, forums with sensitive moderation activities or strict data governance should treat this with higher urgency. |
| Exploit ScenarioDerived | A moderator with permissions to moderate only a specific category (e.g., 'Support') exploits the authorization bypass to query the API endpoint that returns post metadata, retrieving sensitive information such as IP addresses, email references, or system flags from posts in restricted categories they should not access (e.g., 'Private Staff Discussion'). The attack succeeds because the authorization check at the metadata endpoint fails to validate the moderator's assigned scope, allowing the attacker to exfiltrate data in a single automated API call. Such a scenario could expose private user information or internal team discussions if a moderator account is compromised or if a malicious internal moderator seeks to access unauthorized content. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 20, 2026
A moderator authorization bypass vulnerability in Discourse allows authenticated moderators to access post metadata they should not have permission to view due to insufficient authorization checks. The vulnerability affects Discourse versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, with patched versions now available. While the CVSS score of 5.3 indicates moderate severity and the attack requires authenticated access with moderator privileges, this represents a meaningful confidentiality risk in multi-tenant forum environments where metadata isolation between moderation scopes is critical.
RemediationAI
Upgrade Discourse to version 2026.1.2, 2026.2.1, or 2026.3.0-latest.1 or later as appropriate to your current release train; consult https://github.com/discourse/discourse/security/advisories/GHSA-5qm9-r98f-g4mq for detailed patch instructions. For instances unable to patch immediately, implement compensating controls by restricting moderator account privileges to only those moderators requiring access to sensitive categories, and audit moderator activity logs to detect unauthorized metadata access attempts. Additionally, consider implementing network segmentation to limit moderator IP ranges if operationally feasible, and review and tighten Discourse authorization policies to enforce principle of least privilege for moderator role assignments.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 3 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from CWE-862 (Missing Authorization), a class of weakness where an application fails to properly implement access control checks for protected resources. In Discourse, the issue manifests in the authorization logic that governs access to post metadata—information such as edit history, flag reasons, user IP addresses, or other sensitive metadata that should be restricted based on moderator scope and forum policies. The root cause appears to be insufficient validation of whether a moderator's authorization level and assigned scope permit access to specific post records before returning associated metadata. Discourse, being an open-source discussion platform written in Ruby on Rails, relies on its authorization middleware and database query filters to enforce these restrictions; the bug indicates a gap where metadata retrieval bypassed these protective layers.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a moderator could exploit insufficient authorization checks to access metadata of posts they should not have permission to view. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch.
Executive ViewAI
Organizations using Discourse should be aware of moderate risk from CVE-2026-30889, a missing authorization vulnerability rated CVSS 4.9. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Related Vulnerabilities in Discourse Authorization and Information Disclosure
View all 6Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
EUVD-2026-13490
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB