Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2021 - Broken Access Control
ASVS 5.0
V4 - Access Control Authorization enforcement, RBAC validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS score of 2.2 reflects realistic constraints: the attack requires high privileges (PR:H—authenticated moderator account), high attack complexity (AC:H), and only impacts confidentiality minimally (C:L) with no availability impact. The attack vector is network-based (AV:N) but the high privilege requirement severely limits the threat actor pool. There is no evidence of active exploitation (KEV status not indicated as active), and the integrity impact appears limited to policy documents rather than user data. However, this is a real privilege escalation with concrete business impact—unauthorized modification of ToS and privacy policies could expose organizations to legal liability and user trust damage. The availability of patches for all supported versions (2026.3.0-latest.1, 2026.2.1, and 2026.1.2) reduces urgency, but the lack of workarounds means patching is mandatory. |
| Exploit ScenarioDerived | A disgruntled moderator with legitimate platform access could modify the site's Terms of Service or privacy policy to insert malicious terms, redirect users to phishing sites via policy links, or remove liability clauses without administrative approval. The attack requires network access (standard for web platforms) and an existing moderator account, but the high attack complexity suggests the authorization bypass may require specific conditions (e.g., timing, specific API endpoint usage, or role state). An administrator would likely notice policy document changes in audit logs, making this suitable for insider threats rather than mass exploitation. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 20, 2026
A privilege escalation vulnerability in Discourse allows moderators to edit site policy documents (Terms of Service, guidelines, privacy policy) despite explicit access restrictions, enabling unauthorized modification of critical site governance documents. This affects Discourse versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2. The vulnerability has a low CVSS score of 2.2 due to high attack complexity and privileged access requirement, but represents a clear integrity violation of role-based access controls.
RemediationAI
Immediately upgrade to patched versions: Discourse 2026.3.0-latest.1 or later, 2026.2.1 or later, or 2026.1.2 or later depending on the release series currently deployed. Follow the official Discourse upgrade documentation at https://github.com/discourse/discourse/security/advisories/GHSA-jj9p-p7m6-jq96. Since no workarounds are available, patching cannot be deferred. For organizations unable to patch immediately, implement strict role-based access control audits to identify and restrict moderator accounts to only their intended permissions, and monitor audit logs for unauthorized policy document modifications. Test patches in a staging environment before production deployment.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 3 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Discourse is an open-source discussion platform built on Ruby on Rails. The vulnerability stems from improper privilege enforcement in the authorization layer, classified under CWE-269 (Improper Access Control / Privilege Issues). Specifically, the vulnerability allows moderators to bypass access control checks that should restrict modification of site policy documents to administrators only. This is an authorization bypass rather than an authentication bypass—authenticated moderators with elevated privileges can perform actions outside their intended scope due to insufficient server-side permission validation on policy document endpoints.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 allow a moderator to edit site policy documents (ToS, guidelines, privacy policy) that they are explicitly prohibited from modifying. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Executive ViewAI
CVE-2026-30888 is a low-severity vulnerability in Discourse involving privilege management (CVSS 2.2). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. Apply vendor updates when available as part of routine maintenance.
Apply vendor patch during routine maintenance. Standard security controls provide adequate interim protection.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Related Vulnerabilities in Discourse Authorization and Information Disclosure
View all 6Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
EUVD-2026-13488
NVD
CVE.org
EPSS
GitHub
VulDB
Exploit-DB