Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privileged post author
-
ExploitEnumerate victim post UUID
-
ExecutionSend PATCH /api/v1/posts with mismatched postId and id
-
ImpactOverwrite victim post title, slug, content and board
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Object-level authorization, IDOR prevention
|
| Exploitation Conditions | Requires an authenticated LogChimp account with privileges to author posts (PR:L) - not exploitable unauthenticated. The attacker must also know or enumerate the UUID (id) of a victim's post. The attack is performed against the PATCH /api/v1/posts API by supplying mismatched body parameters: postId set to a post the attacker owns (which passes the ownership check in postExists.ts/updatePost.ts) and id set to the victim post's UUID, which pre-fix was used as the actual update target. Limiting factors: valid authentication plus ownership of at least one post, and knowledge of victim post UUIDs; affected deployments are LogChimp 0.9.0-alpha.1 through 0.9.2 (fixed in 0.9.3). There is no confidentiality impact - the flaw enables tampering/overwrite of other users' post fields only. |
| Impact | This is a genuine but not emergency-grade priority. The supplied CVSS 4.0 vector (AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L) scores 7.1 (High): network-reachable API, low attack complexity, no user interaction, and only low privileges needed, with high integrity impact and minor availability impact but no confidentiality impact. The barrier is PR:L - an attacker must hold an authenticated post-author account, which on any LogChimp instance that allows open self-registration is a trivially low bar, consistent with the vendor 'this_week' priority rather than 'act_now'. Countervailing signals point away from mass exploitation: the CVE is not listed in CISA KEV (no confirmed active exploitation), no EPSS score is present in the input so exploitation probability cannot be quantified, and no public exploit code is identified. The fixing commit and VulnCheck advisory do, however, fully document the mechanism (trusting req.body.id as the update target while authorizing on postId), lowering the effort to reproduce. Net: a credible authenticated-tampering/defacement risk warranting prompt patching, but absent KEV/EPSS data there is no evidence of widespread or automated exploitation. |
| Exploit ScenarioDerived | An authenticated LogChimp user who owns at least one post enumerates another user's post UUID, then sends a PATCH request to the /api/v1/posts endpoint with postId set to their own post and id set to the victim's UUID; the server authorizes on the attacker-owned postId but writes to the victim post, overwriting its title, slug, content, boardId and roadmap_id. The attack is network-reachable with low complexity and no user interaction, needing only a low-privileged post-author account. No public exploit code is identified, though the vendor fixing commit and the VulnCheck advisory describe the mechanism in detail. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Nov 03, 2026
Authorization bypass in LogChimp 0.9.0-alpha.1 through 0.9.2 allows authenticated post authors to overwrite other users' post title, slug, content, boardId and roadmap_id by sending a PATCH /api/v1/posts request with mismatched postId and id body parameters. The attacker sets postId to a post they own to pass the ownership check and id to an enumerated victim post UUID, which pre-fix was used as the actual update target; there is no confidentiality impact. The vendor fixed this in v0.9.3, no public exploit was identified at the time of analysis, and the priority is this_week - a genuine but not emergency-grade risk.
RemediationAI
Upgrade to LogChimp v0.9.3 or later. The vendor patch is commit https://github.com/logchimp/logchimp/commit/a78b69af342908472ad400285187e43729295a7c and the fixed release is https://github.com/logchimp/logchimp/releases/tag/v0.9.3; the patch makes updatePost use req.post.postId from the ownership-checked context and removes the body-supplied id as the update target. No specific workaround is documented in the available references, so the vendor upgrade is the complete remediation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
LogChimp's server package implements post editing through the postExists middleware and updatePost controller. In the vulnerable code path, postExists validated ownership using a caller-supplied postId, while updatePost separately accepted req.body.id via validUUID and used that value as the postId in the database update. CWE-639 (Authorization Bypass Through User-Controlled Key) describes the root cause: the authorization decision and the write target were both derived from user-controlled identifiers, so they could refer to different posts. The fix changes updatePost to use req.post.postId from the ownership-checked context and removes the body-supplied id as the update target. The flaw requires an authenticated account with post-authoring privileges and knowledge or enumeration of a victim post UUID; it affects integrity (H) and availability (L) but not confidentiality.
Know when Logchimp gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
Network API, low complexity, no user interaction; requires an authenticated post-author account (PR:L); high integrity impact from overwriting others' posts, minor availability loss from content destruction, no confidentiality impact.
Primary rating from Vendor (VulnCheck).
CVSS VectorVendor: VulnCheck
DescriptionCVE.org
LogChimp 0.9.0-alpha.1 before 0.9.3 contains an authorization bypass vulnerability that allows authenticated post authors to modify any other post by supplying mismatched postId and id body parameters. Attackers can set postId to their own post and id to an enumerated victim post UUID to overwrite its title, slug, content, boardId and roadmap_id.
Executive ViewAI
A high-severity authorization bypass in LogChimp versions 0.9.0-alpha.1 through 0.9.2 allows authenticated post authors to modify other users' post content, titles, slugs, board and roadmap assignments, compromising data integrity and undermining user trust. While no public exploit has been identified, the vulnerability affects all users who rely on post integrity, and leadership should prioritize remediation to prevent potential insider misuse or future exploitation.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
EUVD-2026-115905
NVD
CVE.org
Vulnrichment
GitHub
Exploit-DB