Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessReach site over network unauthenticated
-
ExploitSend crafted AJAX request to WP Roster action
-
ExecutionBypass absent capability/nonce check
-
ImpactDelete roster member user accounts
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Access control enforcement
MITRE ATT&CK
1 technique across 1 tactic: Defense Evasion The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No special conditions - remote unauthenticated exploitation against default configurations of the WP Roster plugin, provided it is installed and active at a version before 2.35. The vulnerable AJAX action performs no capability or nonce check, so no authentication, privilege, or user interaction is required. What limits impact: the confirmed effect is restricted to deleting the WordPress user accounts of roster members (I:L; no data disclosure or broader system compromise per the vector), and exploitation requires that the site actually runs this plugin with roster-member user accounts present. |
| Impact | Signals are mostly consistent and point to a real but moderate-priority issue rather than an emergency. The CVSS 3.1 vector (AV:N/AC:L/PR:N/UI:N) describes a remotely reachable, low-complexity flaw requiring no privileges and no user interaction - PR:N confirms unauthenticated access per the vector. However, the impact is deliberately scoped low (C:N/I:L/A:N, base 5.3): the only confirmed effect is deletion of the WordPress user accounts of roster members, not full site compromise. The EPSS score is low (0.15%, 4th percentile), the CVE is NOT listed in CISA KEV, and no exploit code is referenced, so there is no public exploit identified at time of analysis. The vuln.today decision label is 'this_month', which aligns the low EPSS and absent active-exploitation signal with the easy, unauthenticated trigger - meaning this should be remediated on a normal monthly cadence, not treated as act_now/emergency. One nuance worth verifying: NVD models account deletion as an integrity impact (I:L) rather than availability, which is defensible but means the operational effect (loss of access for deleted users) may feel more like an availability problem to affected sites. |
| Exploit ScenarioDerived | An attacker who can reach the WordPress site sends an unauthenticated request to the vulnerable WP Roster AJAX action, which performs no capability or nonce verification, and specifies a roster member's account for deletion. Because no login, token, or user interaction is needed, the request succeeds against any site running the plugin before 2.35. No public exploit code is referenced, so an attacker would craft the request from the plugin's AJAX handler details. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 28, 2026
Unauthenticated attackers can delete WordPress user accounts of roster members on sites running the WP Roster plugin before 2.35, because one of its AJAX actions lacks capability and nonce checks. The issue is rated CVSS 5.3 with integrity-only impact and is exploitable remotely without authentication or user interaction when the plugin is active and roster-member accounts exist. EPSS is 0.15%, no public exploit has been identified at time of analysis, and the vendor patch is version 2.35.
RemediationAI
Update the WP Roster plugin to version 2.35 or later; the vendor-released patch version is 2.35. The WPScan advisory is https://wpscan.com/vulnerability/af573c89-e246-4c52-bd15-fa92c317c263/. No alternate mitigation or workaround is described in the supplied references.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
WP Roster is a WordPress plugin, and the flaw sits in an AJAX action that performs neither a capability check nor a nonce check. In WordPress, those checks are the normal gatekeeping for AJAX handlers: nonces bind a request to an intended action and user session, while capability checks ensure the caller has the required role. Their absence means the handler can be reached without authentication; the resulting confirmed impact is deletion of the WordPress user accounts of roster members, matching an integrity-only CVSS 5.3 score (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N). CWE-284 (Improper Access Control) captures the root cause class. EUVD lists affected versions as WP Roster 0 <2.35; no CPE strings were supplied, and further request-level trigger details are not described in the available sources.
Know when WordPress gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Unauthenticated, low-complexity AJAX request with no checks gives AV:N/AC:L/PR:N/UI:N; effect is limited account deletion (integrity) so C:N/I:L/A:N, scope unchanged.
Primary rating from Vendor (wpscan).
CVSS VectorVendor: wpscan
Lifecycle Timeline
4DescriptionCVE.org
The WP Roster WordPress plugin before 2.35 does not perform any capability or nonce checks on one of its AJAX actions, allowing unauthenticated attackers to delete the WordPress user accounts of roster members.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra para
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail comman
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The GiveWP - Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
Remote code execution in WordPress 6.9.x (before 6.9.5) and 7.0.x (before 7.0.2) arises from a REST API batch endpoint r
EUVD-2026-111731
GHSA-j835-2vx3-j669
NVD
CVE.org
EPSS
Exploit-DB