Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain WordPress admin credentials
-
DeliveryAuthenticate to wp-admin dashboard
-
ExploitInject XSS payload into list description field
-
ExecutionPayload persisted to database
-
PersistVictim admin loads affected settings page
-
ImpactInjected script executes in victim browser
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an account with the WordPress Administrator role or higher, as the vulnerable list description setting is accessible only to that privilege level. Triggering the XSS additionally requires a second victim user - likely also administrator-level - to load the affected Icegram Express settings page in their browser, satisfying the UI:R CVSS requirement. The Icegram Express plugin must be installed and active on the target WordPress site. No non-default server configuration, network positioning, or protocol-level prerequisite is required beyond administrator-level WordPress authentication. |
| Impact | The CVSS base score of 3.5 (Low) accurately characterizes the constrained real-world risk. The PR:H metric confirms that an attacker must already hold WordPress Administrator-level credentials before the XSS payload can be planted, which is a substantial precondition in well-managed environments. The UI:R requirement further demands that a second victim user load the affected page for the payload to fire, adding another exploitation barrier. The publicly available PoC via WPScan raises some concern, but even a mid-sized municipal IT team in mielec would rightly deprioritize this issue behind unauthenticated or lower-privilege vulnerabilities affecting the same platform. The vulnerability is most relevant in multi-administrator WordPress deployments where a compromised or rogue admin account could leverage the stored XSS to pivot laterally to other privileged sessions. EPSS data and KEV status are absent from the provided input, so automated exploitation probability and confirmed active exploitation cannot be assessed; no public exploit identified at time of analysis beyond the WPScan-documented PoC. |
| Exploit ScenarioDerived | An attacker who obtains WordPress Administrator credentials - via phishing, credential stuffing, or a prior compromise - navigates to the Icegram Express list settings and inserts a JavaScript payload into the list description field. The payload is stored in the database and executes in the browser of any administrator or privileged user who subsequently loads the affected settings page, enabling session token theft or ghost actions under their identity. A public proof-of-concept is available via the WPScan entry. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 02, 2026
Stored Cross-Site Scripting in Icegram Express WordPress plugin versions before 5.8.6 allows administrator-level users to inject malicious scripts into HTML attributes via the list description setting. When another user subsequently loads the affected page, the injected payload executes in their browser, enabling session hijacking, credential capture, or unauthorized actions on their behalf. A publicly available proof-of-concept exploit has been confirmed by WPScan, though real-world impact is substantially constrained by the high-privilege prerequisite required to plant the payload.
RemediationAI
Update Icegram Express to version 5.8.6 or later, which introduces proper HTML attribute escaping for the list description field. The patch is available through the standard WordPress plugin update interface or directly from the WordPress.org plugin repository. No official workarounds are documented; in environments where immediate patching is not possible, restricting the Administrator role to the smallest set of trusted users reduces the attack surface, though this is a compensating measure and not a substitute for applying the fix. Full advisory details are available at https://wpscan.com/vulnerability/263e7dc0-61bb-468e-9e15-a6b6789923f4/.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Icegram Express is a WordPress email list management and newsletter plugin. The vulnerability arises from insufficient output escaping applied to the list description setting when it is reflected inside an HTML attribute context - a classic stored XSS pattern (CWE-79, though NVD lists CWE as N/A for this entry). Because the payload is persisted to the WordPress database and rendered on subsequent page loads, the attack surface extends to any user who loads the affected admin page after injection, rather than being limited to a single reflected interaction. The affected CPE (cpe:2.3:a:unknown:icegram_express:*:*:*:*:*:*:*:*) carries a placeholder 'unknown' vendor field; the plugin is published by Icegram on WordPress.org.
Know when Icegram Express gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
PR:H reflects mandatory WordPress Administrator access to plant the payload; UI:R for victim page load; C:L and I:L consistent with stored XSS scope; no availability impact.
Primary rating from Vendor (WPScan).
CVSS VectorVendor: WPScan
Lifecycle Timeline
2DescriptionCVE.org
The Icegram Express WordPress plugin before 5.8.6 does not properly escape a list description setting before outputting it within an HTML attribute, which could allow users with the Administrator role and above to perform Stored Cross-Site Scripting attacks.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
More in Icegram Express
View allThe Icegram Express WordPress plugin before 5.7.50 does not sanitise and escape some of its Template settings, which cou
The Email Subscribers by Icegram Express - Email Marketing, Newsletters, Automation for WordPress & WooCommerce plugin f
The Icegram Express plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 5.6.23 v
The Icegram Express plugin for WordPress is vulnerable to SQL Injection via the ‘options[list_id]’ parameter in all vers
The Icegram Express formerly known as Email Subscribers WordPress plugin before 5.7.52 does not sanitise and escape some
Missing Authorization vulnerability in Icegram.1.21. Rated medium severity (CVSS 5.4), this vulnerability is remotely ex
A vulnerability in Icegram Email Subscribers & Newsletters email-subscribers.5.2. Rated medium severity (CVSS 4.7), this
EUVD-2025-210828
GHSA-r39r-vh49-3w8m
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB