Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V2 - Validation and Business Logic Input validation, allowlisting
|
| Impact | The CVSS 6.3 score with vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L indicates moderate risk with a favorable attack profile: network-accessible, low attack complexity, and no user interaction required. However, the PR:L (Privileges Required: Low) constraint is significant—an attacker must already have valid credentials to Livy's REST or JDBC interface, reducing the pool of threat actors substantially. The EPSS score is not provided in the available data, but given the required authentication boundary, real-world exploitability is lower than the CVSS number alone suggests. The vulnerability is not listed as actively exploited in known exploitation vectors (KEV status unknown from provided data), and no public proof-of-concept code is mentioned. Under SSVC decision logic: exploitation status is unconfirmed (no KEV), technical impact is moderate (confidentiality, integrity, and availability all affected), and the attack surface is restricted to authenticated users. This should be prioritized for patching in environments where Livy is exposed to multiple users or untrusted internal networks, but is lower priority in isolated, single-user, or air-gapped deployments. |
| Exploit ScenarioDerived | An authenticated user with valid credentials to a Livy instance connected to Spark 3.1+ submits a REST POST request to create a new Spark session, embedding a malicious Spark configuration parameter (e.g., a configuration option introduced in Spark 3.1 that modifies file access semantics or file system principals). Because Livy does not validate this configuration value, it passes it directly to the Spark cluster. The Spark cluster processes the configuration and allows the subsequent file operations requested by the user to access files owned by other users or in restricted directories. The attacker successfully reads sensitive data files they would otherwise not have permission to access. No elevated privileges or social engineering is required—the attacker merely needs an existing Livy account and knowledge of which Spark 3.1+ configuration options can be abused for this purpose. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
Apache Livy versions 0.7.0 and 0.8.0 contain an improper input validation vulnerability (CWE-20) that allows authenticated users to bypass file access controls by injecting malicious Spark configuration values when connecting to Apache Spark 3.1 or later. An attacker with access to Livy's REST or JDBC interface can craft requests with arbitrary Spark configuration parameters to gain unauthorized access to files they do not have permissions to read or modify. This vulnerability is of moderate severity (CVSS 6.3) but requires valid authentication and is fixed in version 0.9.0 and later.
RemediationAI
Immediately upgrade Apache Livy to version 0.9.0 or later, which contains the security fix. For users unable to upgrade immediately, restrict access to Livy's REST and JDBC interfaces to a minimum set of trusted authenticated users and use network-level access controls (firewall rules, VPN requirements) to limit exposure to the affected endpoints. Consider deploying a reverse proxy in front of Livy that validates and sanitizes Spark configuration parameters before they reach the application, explicitly blocking any configuration keys that could be abused for file access manipulation. Additionally, review audit logs for any suspicious Spark configuration submissions and validate file access patterns to detect potential unauthorized access attempts. Downgrade Apache Spark to a version prior to 3.1 if operationally feasible, though this is typically not a viable long-term solution given the security and feature improvements in newer Spark versions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in maven, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Apache Livy is an open-source REST/JDBC interface for interacting with Apache Spark clusters. The vulnerability stems from improper sanitization of Spark configuration values passed through the REST and JDBC APIs (CVE-2025-60012 affects cpe:2.3:a:apache:livy:0.7.0 and cpe:2.3:a:apache:livy:0.8.0). The root cause is classified as CWE-20 (Improper Input Validation), indicating that Livy fails to adequately validate or filter Spark configuration parameters before forwarding them to the Spark cluster. Starting with Apache Spark 3.1, new configuration options were introduced that can be abused to manipulate file access permissions or redirect file operations. Since Livy acts as a trusted intermediary between clients and Spark, it should enforce strict whitelisting of permitted configurations; instead, it appears to pass user-supplied configurations directly to Spark without proper validation, allowing attackers to exploit Spark 3.1+ features to circumvent file-level access controls.
Know when Apache Livy gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Malicious configuration can lead to unauthorized file access in Apache Livy.
This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later.
A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to.
For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values.
Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.
Blast Radius
ecosystem impact- 4 maven packages depend on org.apache.livy:livy-server (4 direct, 0 indirect)
Ecosystem-wide dependent count for version 0.7.0-incubating.
Executive ViewAI
CVE-2025-60012 presents moderate security risk, a input validation vulnerability rated CVSS 6.3. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: deploy WAF rules, restrict network access, enable logging.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2025-208637
GHSA-hm8x-rpgg-7855
NVD
CVE.org
EPSS
VulDB
Exploit-DB