Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 7.3 score reflects high severity with network accessibility (AV:N), low attack complexity (AC:L), no privilege requirements (PR:N), and no user interaction needed (UI:N), indicating a readily exploitable vulnerability. The attack scope is unchanged (S:U) with confidentiality, integrity, and availability impacts (C:L/I:L/A:L). Real-world risk is significant: (1) the module is available to unauthenticated users, (2) exploitation requires only network access with no special conditions, (3) Drupal sites are high-value targets, and (4) XSS vulnerabilities are historically among the most actively exploited web vulnerabilities. Without KEV/CISA confirmation or public POC confirmation from available data, assume this is likely in early disclosure phase with elevated risk trajectory. The combination of low attack complexity, no user interaction requirement, and broad affected user base (any Drupal site with etracker <3.1.0) makes this a critical priority for patching. |
| Exploit ScenarioDerived | An attacker discovers the etracker module is enabled on a target Drupal site and crafts a malicious URL or form submission containing JavaScript payload (e.g., |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 14, 2026
Stored/Reflected Cross-Site Scripting (XSS) vulnerability in the Drupal etracker module that allows unauthenticated remote attackers to inject malicious scripts into web pages without requiring user interaction. The vulnerability affects etracker versions prior to 3.1.0, enabling attackers to steal session tokens, perform unauthorized actions, or redirect users to malicious sites. The CVSS 7.3 score and network-accessible attack vector indicate this is a significant vulnerability affecting any Drupal installation with the vulnerable etracker module enabled.
RemediationAI
Immediate actions: (1) Update the etracker module to version 3.1.0 or later immediately—this is the official patched version that neutralizes the XSS input. (2) If immediate patching is not possible, disable the etracker module temporarily via Drupal admin or drush: drush pm-disable etracker. (3) Implement Content Security Policy (CSP) headers with script-src restrictions to mitigate XSS impact. (4) Review web server logs and database audit logs for evidence of exploitation (unusual script tags in module-related parameters). (5) Force user session invalidation post-patch to clear any stolen tokens. (6) Apply Drupal security updates for core and all contrib modules. Refer to https://www.drupal.org/project/etracker for official advisory and patch downloads.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from CWE-79 (Improper Neutralization of Input During Web Page Generation), which occurs when user-supplied input is not properly sanitized or escaped before being rendered in HTML context. The Drupal etracker module fails to properly neutralize user inputs that may be reflected or stored in web pages, allowing attackers to inject JavaScript payloads. Drupal's security model relies on proper use of sanitization functions (like Xss::filter() or check_plain()) and output escaping through templating engines. The etracker module likely accepts user input (through form submissions, URL parameters, or configuration) without applying adequate input validation or output encoding, violating OWASP Top 10 2021 A03:2021 - Injection principles.
Know when Etracker gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal etracker allows Cross-Site Scripting (XSS).This issue affects etracker: from 0.0.0 before 3.1.0.
Executive ViewAI
A Cross-Site Scripting (XSS) vulnerability in Drupal etracker versions below 3.1.0 allows attackers to inject malicious scripts that could compromise user sessions, steal credentials, or deface web pages. Organizations using affected etracker versions face immediate risk of data theft and reputational damage, particularly if the module processes user input or displays untrusted content.
Deploy WAF rules to detect and block XSS patterns in etracker module requests; implement strict Content Security Policy (CSP) headers to limit script execution; restrict module access to authenticated users only via network ACLs; disable user-facing etracker features if possible; apply input sanitization middleware at the application layer; monitor for exploitation attempts in access logs. Note: These are temporary mitigations only—patch availability must be monitored closely for rapid deployment.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2025-18290
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB