Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend crafted HTTP request
-
ExploitExploit missing authorization
-
ExecutionModify automation settings or data
-
ImpactImpact integrity and availability
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No special conditions required - remote unauthenticated exploitation against default configurations of Uncanny Automator versions up to 6.4.0.2. The CVSS vector indicates no privileges or user interaction needed, and the attack vector is network. |
| Impact | CVSS 3.1 vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L indicates network-based, low complexity, no privileges required, and no user interaction, with low integrity and availability impact. EPSS score is 0.09% (percentile 25%), suggesting low exploitation probability. No KEV listing or public exploit code has been reported. The risk is moderate: while the CVSS score is 6.5, the lack of active exploitation and low EPSS reduce immediate priority. However, the unauthenticated nature and network attack vector mean it could be exploited in automated attacks if details become public. |
| Exploit ScenarioDerived | An unauthenticated attacker sends a crafted HTTP request to a WordPress site running a vulnerable version of Uncanny Automator, exploiting the missing authorization to modify automation rules or access restricted data. No public exploit code has been identified, but the low complexity makes it feasible to develop. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 26, 2026
Missing authorization in Uncanny Automator for WordPress up to version 6.4.0.2 allows unauthenticated attackers to exploit incorrectly configured access control security levels, potentially leading to unauthorized modification of automation settings or data. The vulnerability has a CVSS score of 6.5 with network attack vector and low complexity, but no public exploit or active exploitation has been identified at this time.
RemediationAI
Update Uncanny Automator to version 6.5.0.1 or later, which contains the fix for this vulnerability. The vendor advisory is available at https://patchstack.com/database/wordpress/plugin/uncanny-automator/vulnerability/wordpress-uncanny-automator-6-5-0-1-broken-access-control-vulnerability?_s_id=cve. No workarounds are documented; upgrading is the recommended action.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is a Missing Authorization (CWE-862) in Uncanny Automator, a WordPress plugin that enables automation of tasks and workflows. The affected product is identified via CPE cpe:2.3:a:uncannyowl:uncanny_automator:*:*:*:*:*:wordpress:*:*, indicating all versions up to 6.4.0.2 are vulnerable. The root cause is that the plugin fails to properly enforce access controls on certain functionality, allowing unauthenticated users to perform actions that should require higher privileges.
Know when Uncanny Automator gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Network attack, low complexity, no privileges, no user interaction, low integrity and availability impact.
Primary rating from NVD.
CVSS VectorNVD
Lifecycle Timeline
4DescriptionCVE.org
Missing Authorization vulnerability in Uncanny Owl Uncanny Automator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Uncanny Automator: from n/a through 6.4.0.2.
Executive ViewAI
Organizations using Missing Authorization vulnerability in Uncanny Owl Uncanny Automator should be aware of notable risk from CVE-2025-48133, a missing authorization vulnerability rated CVSS 6.5. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in Uncanny Automator
View allThe Uncanny Automator - Easy Automation, Integration, Webhooks & Workflow Builder Plugin for WordPress is vulnerable to
Missing Authorization vulnerability in Uncanny Owl Uncanny Automator Pro allows Exploiting Incorrectly Configured Access
The Uncanny Automator plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 6
Cross Site Request Forgery (CSRF) vulnerability in Uncanny Owl Uncanny Automator Pro.3. Rated high severity (CVSS 8.8),
SQL injection in the Uncanny Automator WordPress plugin (versions 7.3.2 and earlier) lets an authenticated administrator
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Uncanny Owl
The Uncanny Automator - Easy Automation, Integration, Webhooks & Workflow Builder Plugin plugin for WordPress is vulnera
The Uncanny Automator plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capabilit
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Uncanny Automator, Uncanny Owl Uncanny Autom
EUVD-2025-17029
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB