Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privilege user
-
DeliveryObtain valid OAuth bearer token
-
ExploitAccess MCP endpoint with token
-
ExecutionInvoke admin-level MCP tools
-
ImpactEscalate to Administrator role
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Least privilege enforcement
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Successful exploitation requires the AI Engine plugin version 3.4.9 to be installed with MCP functionality enabled, and the attacker must have valid WordPress credentials (Subscriber role or higher). The vulnerability affects sites that allow user registration or have existing low-privileged accounts. Sites with registration disabled and no untrusted users are at lower risk. The MCP OAuth bearer-token functionality must be accessible for the privilege escalation to succeed. |
| Impact | The CVSS 3.1 score of 8.8 reflects high impact across confidentiality, integrity, and availability with low attack complexity and no user interaction required. The attack vector is network-based but requires low privileges (authenticated as Subscriber or higher), making this exploitable by any registered user on the WordPress site. EPSS data not provided, suggesting exploitation probability hasn't been assessed. No CISA KEV listing indicates no confirmed active exploitation. The high CVSS score is warranted given the complete privilege escalation to Administrator, but real-world risk depends on whether the site allows user registration and if MCP functionality is actively used. |
| Exploit ScenarioDerived | An attacker registers as a Subscriber on the target WordPress site, obtains a valid OAuth token through normal authentication, then uses this token to access MCP admin tools that should require Administrator privileges. Through these MCP tools, the attacker can perform administrative actions and escalate their WordPress user role to Administrator, gaining full control of the site. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 17, 2026
Authenticated attackers can escalate privileges to Administrator in AI Engine WordPress plugin version 3.4.9 through improper authorization in the MCP OAuth bearer-token implementation. The plugin accepts any valid OAuth token for Model Context Protocol (MCP) access without verifying administrator privileges, allowing low-privileged users (Subscriber+) to execute admin-level MCP tools. No public exploit or active exploitation identified at time of analysis.
RemediationAI
Update to a version after 3.4.9 that includes the security fix implemented in changeset 3533527 (https://plugins.trac.wordpress.org/changeset/3533527/ai-engine). The changeset indicates a patch has been committed upstream. As an immediate workaround, disable the MCP functionality if not required, or restrict user registration to prevent untrusted users from obtaining Subscriber accounts. Monitor user accounts for unexpected privilege changes and review administrator account creation logs.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
AI Engine is a WordPress plugin providing chatbot and AI framework functionality with Model Context Protocol (MCP) support. The vulnerability stems from CWE-269 (Improper Privilege Management) where the OAuth bearer-token authorization path for MCP access fails to enforce WordPress capability checks. When processing OAuth tokens, the plugin grants MCP access based solely on token validity rather than verifying the token holder has administrator privileges, effectively bypassing WordPress's role-based access control system.
Know when Wordpress Plugin gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The AI Engine - The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Privilege Escalation in version 3.4.9. This is due to missing WordPress capability enforcement in the MCP OAuth bearer-token authorization path, where any valid OAuth token causes MCP access to be granted without verifying administrator privileges. This makes it possible for authenticated (Subscriber+) attackers to invoke admin-level MCP tools and escalate privileges to Administrator.
Executive ViewAI
CVE-2026-8719 is a privilege escalation vulnerability in AI Engine WordPress plugin v3.4.9 affecting authenticated users who can escalate to administrator privileges through improper OAuth token validation. Any subscriber-level user or higher can execute administrator-only functions, potentially compromising site integrity, data access, and business operations if the plugin manages sensitive AI-powered workflows.
No vendor-released patch identified at time of analysis. Interim mitigations: disable AI Engine plugin if feasible; restrict MCP OAuth endpoint access via firewall/WAF to trusted IP ranges; revoke all existing OAuth tokens and implement additional authentication layers; monitor admin account activity and MCP API calls for unauthorized access patterns; reduce Subscriber+ user count to minimum necessary personnel.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
More in Wordpress Plugin
View allThe Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
SQL injection in the NotificationX WordPress plugin (versions up to and including 2.8.2) allows unauthenticated remote a
The POST SMTP Mailer - Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress i
The MasterStudy LMS WordPress Plugin - for Online Courses and Education plugin for WordPress is vulnerable to union base
The Email Subscribers by Icegram Express plugin for WordPress is vulnerable to SQL Injection via the ‘hash’ parameter in
EUVD-2026-30678
GHSA-39f2-3f7m-6r66
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB