Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate to Jenkins with Overall/Manage account
-
DeliveryNavigate to Appearance configuration page
-
ExploitSubmit configuration changes
-
ExecutionBypass missing fine-grained permission check
-
ImpactModify restricted Appearance settings
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires that the attacker already possess the Overall/Manage permission in Jenkins - a highly privileged role normally reserved for trusted operators. The target Jenkins instance must be running weekly version 2.579 or earlier, or LTS 2.568.2 or earlier. The attacker must be able to reach the Jenkins web UI over the network and authenticate. No unauthenticated or low-privilege exploitation path exists. The impact is limited to Appearance configuration - other configuration domains are not accessible through this flaw. |
| Impact | Real-world risk is low. The CVSS 3.5 base score reflects limited blast radius: PR:H restricts exploitation to actors who already hold Overall/Manage permission (a highly privileged role typically granted to trusted administrators), C:L/I:L caps the confidentiality and integrity impact to the Appearance subsystem only, and there is no availability impact. EPSS of 0.16% (6th percentile) corroborates the low exploitation likelihood. The vulnerability is not listed in CISA KEV and no public proof-of-concept code has been identified. The practical impact is confined to cosmetic/branding configuration tampering, making this a low-priority hygiene fix rather than an urgent emergency patch. |
| Exploit ScenarioDerived | An attacker who legitimately holds Overall/Manage permission - such as a developer promoted to a management role - navigates to the Jenkins Appearance configuration page via the web UI. The insufficient permission check allows them to alter branding, theme, or other appearance-related settings that should require a higher-level permission, enabling unauthorized modification of the instance's visual configuration without triggering an access-denied response. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 04, 2026
Improper permission enforcement in Jenkins's Appearance configuration page allows authenticated users holding the Overall/Manage permission to modify Appearance configuration options beyond their authorized scope. Affected are Jenkins 2.579 and earlier (weekly) and LTS 2.568.2 and earlier. The vendor has released fixes in Jenkins 2.580 and LTS 2.568.3; no public exploit or active exploitation has been identified, and EPSS places this at the 6th percentile of exploitation likelihood.
RemediationAI
Vendor-released patches are available: upgrade Jenkins weekly to version 2.580 or upgrade Jenkins LTS to version 2.568.3. Both fix versions are confirmed in the EUVD entry and vendor advisory at https://www.jenkins.io/security/advisory/2026-09-02/#SECURITY-3981. If an immediate upgrade is not feasible, restrict Overall/Manage role assignments to the minimum required set of trusted operators, reducing the population of users who could reach the vulnerable endpoint. Note that the Appearance page itself cannot be practically disabled without modifying the Jenkins core, so role restriction is the only meaningful short-term compensating control.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Jenkins implements a tiered permission model where Overall/Manage grants management capabilities short of full administrative control. CWE-862 (Missing Authorization) is the root cause: the Appearance configuration endpoint fails to enforce the correct, more restrictive permission check before accepting changes from Overall/Manage holders, who should only be permitted a subset of configuration operations. The affected codebase is identified via CPE cpe:2.3:a:jenkins_project:jenkins:*:*:*:*:*:*:*:* covering both weekly and LTS release trains up to the respective fix versions.
Know when Jenkins gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
PR:H because exploitation requires Overall/Manage permission; UI:N because the privileged actor operates the page themselves without needing another user's interaction; C:L/I:L bounded to Appearance config only.
Primary rating from Vendor (jenkins).
CVSS VectorVendor: jenkins
Lifecycle Timeline
3DescriptionCVE.org
Jenkins 2.579 and earlier, LTS 2.568.2 and earlier does not correctly perform permission checks in the Appearance configuration page, allowing attackers with Overall/Manage permission to modify Appearance configuration options they should not have access to.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Denial of service against HTTP/2 server implementations allows remote unauthenticated attackers to exhaust server resour
A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/
The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary co
The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers to execute arbitrary code via a
Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow remote authenticated users to ex
The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote attackers to obtain sensitive j
The remoting module in Jenkins before 1.650 and LTS before 1.642.2 allows remote attackers to execute arbitrary code by
A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/
A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153 and earlier, LTS 2.138.3 and ea
A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.50 and earlier in src/main/java/org/jenkinsci/
A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier in. Rated high severity (CVSS 8.
A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in src/main/java/org/jenkinsci/plugins
EUVD-2026-70119
GHSA-r4vq-pcpc-w89c
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB