Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister/obtain subscriber account
-
DeliverySubmit XSS payload via WP Docs entry
-
ExploitPayload stored in WordPress database
-
ExecutionAdministrator browses affected documentation page
-
PersistMalicious script executes in admin browser
-
ImpactSession token exfiltrated or admin action performed
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires the attacker to hold a subscriber-level (or higher) account on the target WordPress installation, meaning subscriber self-registration must be enabled or the attacker must obtain credentials through another means. Victim interaction is required: a higher-privileged user (typically an administrator or editor) must browse or review the content submitted by the subscriber. The vulnerability is specific to WordPress sites running the WP Docs plugin at version 2.3.1 or earlier. Sites that disable open user registration or restrict WP Docs content submission to trusted roles significantly limit exploitability. No special server-side configuration beyond the default plugin installation is required to be vulnerable. |
| Impact | The CVSS 6.5 score reflects a medium-severity, network-accessible stored XSS requiring subscriber-level authentication and victim interaction. While the raw score is not critical, the scope change (S:C) elevates practical risk because a subscriber can target administrator sessions, potentially enabling privilege escalation, credential harvesting, or administrative action hijacking. Even a mid-sized municipal IT team in sanok running a documentation-heavy WordPress deployment should treat this as a meaningful elevation-of-privilege risk rather than a routine low-severity XSS. EPSS data is not present in the input, and neither CISA KEV status nor any public exploit code is reported, which moderates urgency. The A:L component in the vendor CVSS is atypical for XSS (which usually carries no availability impact) and may be an overstatement; this is flagged in confidence notes. The primary real-world risk is administrator account compromise via session hijacking on sites with open subscriber registration. |
| Exploit ScenarioDerived | An attacker registers or obtains a subscriber-level WordPress account on a target site running WP Docs ≤2.3.1. The attacker submits a documentation entry containing an obfuscated JavaScript payload - for example a cookie-stealer or form-overlay - through the WP Docs interface. When an administrator reviews or browses the documentation, the script executes in their browser session, exfiltrating their session token or performing authenticated administrative actions on the attacker's behalf. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 10, 2026
Stored Cross-Site Scripting in the WP Docs WordPress plugin (versions ≤2.3.1) allows authenticated subscribers to inject malicious scripts that execute in the browsers of other users, including administrators. The CVSS vector (PR:L/UI:R/S:C) confirms this is a subscriber-initiated, stored XSS with scope change, meaning a low-privilege account can affect higher-privilege sessions. No public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
The primary remediation is to update the WP Docs plugin to a version above 2.3.1 as advised by Patchstack (https://patchstack.com/database/wordpress/plugin/wp-docs/vulnerability/wordpress-wp-docs-plugin-2-3-1-cross-site-scripting-xss-vulnerability); an exact patched release number is not independently confirmed from available data, so administrators should verify the latest available version in the WordPress plugin repository. If an immediate update is not possible, restrict subscriber registration on the WordPress site to prevent untrusted accounts from submitting content through WP Docs, which eliminates the PR:L attack surface. Additionally, a Web Application Firewall (WAF) rule blocking common XSS payloads in plugin-specific POST endpoints can serve as a short-term compensating control, though this may interfere with legitimate documentation submissions. Review existing subscriber-submitted WP Docs content for suspicious script tags as a post-incident hygiene step.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
WP Docs is a WordPress plugin authored by fahad_mahmood (CPE: cpe:2.3:a:fahad_mahmood:wp_docs:*:*:*:*:*:*:*:*) that provides in-plugin documentation capabilities. The root cause is CWE-79: Improper Neutralization of Input During Web Page Generation, the classical stored XSS class where subscriber-supplied input is written to the database without adequate output encoding and later rendered unescaped in the browser of other visitors or administrative users. The scope change (S:C in CVSS) indicates the malicious script executes in a security context beyond the authenticated subscriber's own session, making this a privilege-escalation vector via browser-side code injection.
Know when Wp Docs gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Network-accessible stored XSS at subscriber level with scope change; A:N because XSS does not cause availability impact in this context.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Subscriber Cross Site Scripting (XSS) in WP Docs <= 2.3.1 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
The WP Docs plugin for WordPress is vulnerable to time-based SQL Injection via the 'dir_id' parameter in all versions up
Stored Cross-Site Scripting (XSS) in WP Docs plugin for WordPress (all versions through 2.2.9) allows authenticated atta
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Fahad Mahmo
Unauth. Rated medium severity (CVSS 6.1), this vulnerability is remotely exploitable, no authentication required, low at
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fahad Mahmood WP D
Missing Authorization vulnerability in Fahad Mahmood WP Docs wp-docs allows Exploiting Incorrectly Configured Access Con
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Fahad Mahmo
EUVD-2026-75515
GHSA-wh9q-3cg8-c55m
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB