Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSubmit crafted XSS payload to Obfuscate-processed content field
-
DeliveryModule fails to sanitize input on render
-
ExploitMalicious script embedded in generated HTML
-
ExecutionVictim user loads affected page
-
PersistScript executes in victim's browser context
-
ImpactSession token exfiltration or unauthorized action performed
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires that the target Drupal site has the Obfuscate contributed module installed and enabled at a version between 0.0.0 and before 2.0.2. The CVSS vector (PR:N) confirms no authentication is needed to submit the malicious payload; however, user interaction (UI:R) is required - a victim must navigate to and render the page containing the injected content for the XSS to execute. Exploitation is therefore limited by: (1) the Obfuscate module must be present and active on the target site, (2) the attacker must be able to submit input processed by the module (e.g., via a public-facing content form), and (3) a user - ideally one with elevated session privileges - must view the affected page. Sites that restrict content submission to authenticated, trusted roles significantly reduce their exposure even before patching. |
| Impact | The CVSS 6.1 medium score reflects a network-reachable (AV:N), low-complexity (AC:L), no-privilege-required (PR:N) vulnerability that still demands user interaction (UI:R) to trigger, limiting opportunistic mass exploitation. The changed scope (S:C) elevates impact beyond what the base confidentiality and integrity scores (both Low) might suggest in isolation, as cross-origin script execution can facilitate session token theft against privileged users. EPSS at 0.03% (8th percentile) corroborates low real-world exploitation activity at time of analysis - this is not being actively targeted by automated or widespread campaigns. There is no CISA KEV listing and no known public exploit code, further reducing urgency. In practice, this is a genuine but non-critical risk: sites running the Obfuscate module with public content submission should patch promptly, but there is no evidence of active exploitation warranting emergency response. |
| Exploit ScenarioDerived | An attacker submits a content item (such as a node or field value) containing a crafted XSS payload through a publicly accessible form on a Drupal site running the vulnerable Obfuscate module. When an authenticated user - such as a site administrator or editor - navigates to a page that renders the obfuscated content, the injected script executes in their browser, potentially exfiltrating their session cookie or performing administrative actions on their behalf. No public exploit code has been identified, but the low attack complexity (AC:L) and absence of privilege requirements (PR:N) make this straightforward to reproduce manually. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 20, 2026
Cross-site scripting in the Drupal Obfuscate contributed module (versions 0.0.0 through before 2.0.2) allows remote unauthenticated attackers to inject malicious scripts into pages rendered for other users, with impact scoped across security boundaries (S:C). The vulnerability stems from improper neutralization of input during web page generation, enabling session hijacking or UI redress attacks against users who view attacker-controlled content processed by the module. No public exploit has been identified at time of analysis, and EPSS at 0.03% (8th percentile) reflects low current exploitation probability.
RemediationAI
Update the Drupal Obfuscate module to version 2.0.2 or later, as confirmed by the vendor patch available through Drupal Security Advisory SA-CONTRIB-2026-033 (https://www.drupal.org/sa-contrib-2026-033). Administrators can apply the update via the Drupal admin interface under Extend > Update or using Drush with the command 'drush pm:update obfuscate'. If an immediate update is not feasible, disabling the Obfuscate module entirely is an effective compensating control that removes the attack surface; the trade-off is loss of content obfuscation functionality until the patch can be applied. Additionally, tightening content submission permissions to restrict untrusted or anonymous users from submitting input processed by the module can reduce exposure in the interim, though this does not constitute a fix.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected component is the Drupal Obfuscate contributed module (CPE: cpe:2.3:a:drupal:obfuscate:*:*:*:*:*:*:*:*), a Drupal add-on typically used to obfuscate sensitive content such as email addresses or phone numbers to deter scraping. The root cause is CWE-79 (Improper Neutralization of Input During Web Page Generation), meaning user-supplied input passed through this module is insufficiently sanitized or encoded before being embedded into HTML output. When rendered in a victim's browser, injected script payloads execute within the page's origin context. The changed scope flag (S:C) in the CVSS vector indicates the vulnerability's impact extends beyond the Obfuscate module itself - for example, into the broader Drupal session or parent browser context.
Know when Obfuscate gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Primary rating from Vendor (drupal) · only source for this CVE.
CVSS VectorVendor: drupal
Lifecycle Timeline
3DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Obfuscate allows Cross-Site Scripting (XSS).
This issue affects Obfuscate: from 0.0.0 before 2.0.2.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-30988
GHSA-rg7p-g694-c73p
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB