Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain or register Contributor WordPress account
-
DeliveryCraft malicious XSS payload in MailOptin content field
-
ExploitSubmit content triggering admin review workflow
-
ExecutionAdministrator views or approves poisoned content
-
PersistInjected JavaScript executes in admin browser session
-
ImpactExfiltrate session cookie or perform privileged administrative action
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires a valid WordPress Contributor-level account on the target installation; the CVSS PR:L metric confirms this authenticated prerequisite. User interaction is required (UI:R) - a higher-privileged user, typically an administrator, must view or review the content containing the injected payload for execution to occur. No special server-side configuration or non-default plugin settings are indicated as additional prerequisites; the flaw appears to exist in standard MailOptin content-handling functionality. Exploitation is constrained to multi-user WordPress sites where the Contributor role is assigned to potentially untrusted individuals. Sites where all users are fully trusted employees or where contributor registration is closed face negligible practical risk despite the network-accessible attack vector. |
| Impact | The CVSS 6.5 Medium score is driven by AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L. The PR:L requirement is the primary limiting factor - an attacker must hold a valid Contributor account, which restricts opportunistic mass exploitation. However, the scope change (S:C) elevates real-world impact significantly: successful exploitation targets administrator browser sessions, potentially enabling session hijacking or unauthorized privileged actions. No EPSS score was provided in the source intelligence, and the vulnerability does not appear in CISA KEV, suggesting no confirmed active exploitation at this time. The original CVSS assigns A:L (low availability), which is atypical for XSS and may reflect client-side browser disruption rather than server availability; this analysis treats it as a minor anomaly rather than a confirmed server-impact signal. Real-world risk is highest for WordPress sites with open contributor registration or externally-granted Contributor roles - single-author or fully trusted-user sites face negligible practical risk. |
| Exploit ScenarioDerived | An attacker who registers or compromises a Contributor account on a WordPress site running MailOptin ≤ 1.2.78.0 crafts a MailOptin-related input field or post content containing a malicious JavaScript payload and submits it through the normal contributor workflow. When a site administrator opens the pending content for review or views a page where the payload renders, the script executes silently in the administrator's browser - enabling session cookie theft, unauthorized administrative actions such as creating backdoor accounts, or redirection to phishing infrastructure. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Aug 06, 2026
Stored Cross-Site Scripting in MailOptin WordPress plugin (versions ≤ 1.2.78.0) allows Contributor-level authenticated users to inject malicious JavaScript payloads that execute in the browser context of higher-privileged users - typically site administrators - when they view the affected content. The CVSS scope change (S:C) confirms the injected script escapes the contributor's own context, making this an effective privilege escalation vector in multi-author WordPress environments. No public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Update MailOptin to a version above 1.2.78.0. The exact patched release version is not independently confirmed from the available intelligence data - verify the current safe version via the WordPress plugin repository or the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/mailoptin/vulnerability/wordpress-mailoptin-plugin-1-2-78-0-cross-site-scripting-xss-vulnerability before deploying. As an interim compensating control, audit all accounts holding the Contributor role and revoke access from any untrusted or unnecessary users; this directly eliminates the PR:L attack prerequisite. Disabling contributor-level content submission workflows entirely removes the injection surface at the cost of losing that authoring capability. Implementing a strict Content Security Policy (CSP) header with script-src restricted to known safe origins can limit the execution impact of any residual XSS, though CSP is a defense-in-depth measure and not a substitute for patching.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
MailOptin is a WordPress plugin developed by properfraction, used for email opt-in forms, lead generation, and marketing automation. CWE-79 (Improper Neutralization of Input During Web Page Generation) identifies the root cause as insufficient sanitization or escaping of Contributor-supplied input before it is rendered in an HTML context. The CPE string cpe:2.3:a:properfraction:mailoptin:*:*:*:*:*:*:*:* indicates all mainline releases through 1.2.78.0 are affected without version-range exclusions. In WordPress's role hierarchy, the Contributor role can draft and submit posts but cannot publish - however, this vulnerability demonstrates that content awaiting administrator review can carry executable payloads, exploiting the review workflow itself as a delivery mechanism.
Know when Mailoptin gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Contributor auth required (PR:L), admin must view content (UI:R), scope changes to admin session (S:C); no server-side availability impact justifies A:N over the source data's A:L.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Contributor Cross Site Scripting (XSS) in MailOptin <= 1.2.78.0 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Privilege escalation in the MailOptin WordPress plugin (by properfraction) affects all versions up to and including 1.2.
The Popup, Optin Form & Email Newsletters for Mailchimp, HubSpot, AWeber - MailOptin plugin for WordPress is vulnerable
Unauthenticated Optin Campaign Cache Deletion vulnerability in MailOptin plugin <= 1.2.49.0 at WordPress. Rated medium s
Auth. Rated medium severity (CVSS 4.8), this vulnerability is remotely exploitable, low attack complexity. No vendor pat
EUVD-2026-53907
GHSA-7h59-5f8r-wcwf
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB