Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V15 - Secure Coding and Architecture Integer underflow checks
|
| Impact | CVSS v4.0 score of 2.3 with vectors AV:N/AC:H/AT:P/PR:N/UI:P indicates low severity: network-accessible but requires high complexity, persistent attacker interaction, and user interaction; impact is limited to low confidentiality and availability loss with no integrity impact. The EUVD classification of affected versions up to 5.9.0 suggests this was a tracked vulnerability but EPSS exploitation probability data is unavailable from provided sources. No CISA KEV designation or public proof-of-concept is documented, indicating this is not confirmed actively exploited. Risk is further mitigated by requiring the non-default parsing implementation to be explicitly enabled. Real-world priority should be low unless specific deployments rely on the legacy ASN.1 parser in security-critical certificate validation contexts; the combination of limited impact scope, high attack complexity, required user interaction, and opt-in vulnerable configuration suggests this is a lower-priority issue compared to high-CVSS flaws with simpler attack paths. |
| Exploit ScenarioDerived | An attacker sends a carefully crafted X.509 certificate with a malformed Subject Alternative Name extension containing an entry length larger than its enclosing sequence to a wolfSSL-based application performing certificate validation. If that application has explicitly enabled the original ASN.1 parser (non-default), the parser's length counter underflows during SAN processing, causing subsequent certificate data to be read from incorrect memory offsets. This could disclose adjacent memory contents or trigger a crash depending on memory layout, though exploitation requires the attacker to control the certificate data and relies on high complexity conditions and persistent interaction to achieve a reliable outcome. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
Integer underflow in wolfSSL's ASN.1 certificate parser allows remote attackers to trigger information disclosure and potential memory access violations when processing malformed X.509 certificates with oversized Subject Alternative Name extensions. The vulnerability affects wolfSSL versions up to 5.9.0 but only impacts systems using the non-default original ASN.1 parsing implementation; no public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Upgrade to wolfSSL version 5.10.0 or later, which includes the fix for the ASN.1 integer underflow. If immediate patching is not feasible, disable or avoid explicit use of the original ASN.1 parsing implementation (the default configuration is safe). No workaround is available for systems requiring the legacy parser. Refer to the wolfSSL GitHub repository (https://github.com/wolfSSL/wolfssl/pull/10024) for technical details and verification that the fix has been applied in your deployed version.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in wolfSSL's ASN.1 parsing implementation used to process X.509 certificate extensions, specifically the Subject Alternative Name (SAN) field. When parsing ASN.1 DER-encoded data, the parser maintains an internal length counter to track remaining bytes in a sequence. A malformed certificate can specify an entry length that exceeds the enclosing sequence's declared length, causing this counter to underflow (wrap around due to unsigned integer arithmetic, CWE-191). This integer underflow leads to incorrect buffer boundary calculations during subsequent parsing operations, potentially allowing out-of-bounds memory reads. The flaw is confined to systems explicitly using the original ASN.1 parser rather than the default implementation, significantly limiting real-world exposure.
Know when Wolfssl gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
An integer underflow issue exists in wolfSSL when parsing the Subject Alternative Name (SAN) extension of X.509 certificates. A malformed certificate can specify an entry length larger than the enclosing sequence, causing the internal length counter to wrap during parsing. This results in incorrect handling of certificate data. The issue is limited to configurations using the original ASN.1 parsing implementation which is off by default.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Integer overflow occurs when an arithmetic operation produces a result that exceeds the maximum value a given integer type can store.
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Related Vulnerabilities in wolfSSL Cryptographic and Certificate Verification Flaws
View all 7wolfSSL prior to version 3.12.2 provides a weak Bleichenbacher oracle when any TLS cipher suite using RSA key exchange i
A specially crafted x509 certificate can cause a single out of bounds byte overwrite in wolfSSL through 3.10.2 resulting
Authentication bypass in wolfSSL TLS clients built with Raw Public Key (RPK) support allows a malicious or on-path serve
wolfSSL builds that enable the WOLFSSL_TRUST_PEER_CERT macro can be induced to accept a forged clone of a trusted-peer C
Certificate forgery in the wolfSSL client (versions 5.7.2 through 5.9.2) lets a remote attacker who already holds any ce
wolfSSL (formerly CyaSSL) before 3.6.8 allows remote attackers to cause a denial of service (resource consumption or tra
In wolfSSL before 5.5.1, malicious clients can cause a buffer overflow during a TLS 1.3 handshake. Rated high severity (
An issue was discovered in wolfSSL before 5.5.0. Rated high severity (CVSS 7.5), this vulnerability is remotely exploita
wolfSSL 4.3.0 has mulmod code in wc_ecc_mulmod_ex in ecc.c that does not properly resist timing side-channel attacks. Ra
In wolfSSL 4.1.0 through 4.2.0c, there are missing sanity checks of memory accesses in parsing ASN.1 certificate data wh
An issue was discovered in wolfSSL before 4.5.0, when single precision is not employed. Rated high severity (CVSS 7.0).
wolfSSL before 4.5.0 mishandles TLS 1.3 server data in the WAIT_CERT_CR state, within SanityCheckTls13MsgReceived() in t
EUVD-2026-21290
GHSA-9qgc-pcpx-g38q
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB