Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconGain administrative access to WordPress
-
DeliveryNavigate to plugin settings panel
-
ExploitInject XSS payload in unescaped input field
-
InstallSubmit malicious settings
-
C2Payload stored in database
-
ExecuteUser visits affected page
-
ImpactScript executes in user browser
-
Step 8Steal session or data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS score of 4.4 indicates low-to-moderate severity, and several factors validate this assessment. The attack requires high privilege level (PR:H-administrator credentials), high attack complexity (AC:H), and no user interaction (UI:N), limiting the practical attack surface to compromised or malicious administrators. The EPSS score is not provided, but based on CVSS metrics, real-world exploitation probability is low due to the requirement for administrative compromise as a prerequisite. The vulnerability is NOT in CISA's Known Exploited Vulnerabilities (KEV) catalog, and no public exploit code is referenced, indicating this is not actively exploited in the wild. However, the stored nature of the XSS (not reflected) means that once injected, the payload persists and automatically executes for all site visitors without additional attacker interaction, amplifying impact across the user base. The impact is limited to confidentiality and integrity (C:L, I:L) with no availability impact (A:N). For most organizations, this represents a lower-priority issue unless the threat model includes compromised administrator accounts; however, organizations with strict multi-site governance or shared hosting environments should prioritize patching to prevent privilege-abuse scenarios. |
| Exploit ScenarioDerived | An organization with a WordPress multi-site installation appoints a malicious or compromised administrator who accesses the WholeSale Products Dynamic Pricing Management settings panel and injects a JavaScript payload into a product pricing field. The injected script is stored in the database without proper sanitization. When any user (including site owners or customers) accesses a page displaying the affected product or pricing information, the injected JavaScript executes in their browser, potentially stealing session cookies, capturing form input, or redirecting users to phishing pages. Because the attack is stored, it persists until the administrator or a higher-privileged user discovers and removes the malicious content. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 14, 2026
Stored Cross-Site Scripting in WholeSale Products Dynamic Pricing Management WooCommerce plugin allows authenticated administrators to inject arbitrary web scripts via admin settings that execute for all users on affected pages. The vulnerability affects all versions up to and including 1.2 on multi-site WordPress installations or single-site installations with unfiltered_html disabled. While the CVSS score of 4.4 is moderate, exploitation requires high-privilege administrator credentials and the attack is limited by high attack complexity; however, the persistent nature of stored XSS means injected payloads affect all subsequent site visitors.
RemediationAI
The primary remediation is to upgrade the WholeSale Products Dynamic Pricing Management WooCommerce plugin to a patched version above 1.2; however, the exact patched version is not provided in the available data. Website administrators should check the WordPress plugin repository (https://plugins.trac.wordpress.org/browser/wholesale-products-dynamic-pricing-management-woocommerce/) for the latest release or contact the plugin developer (WP Code Factory) for patch availability. As an interim workaround, restrict the administrator role to only trusted personnel and consider using the WordPress role editor to remove access to plugin settings for non-essential administrators. Additionally, enable the unfiltered_html capability restriction across all installations to leverage WordPress's built-in sanitization, though this may affect some legitimate functionality requiring HTML input. Monitor admin activity logs for any suspicious settings changes, and audit existing admin settings for injected script content that may have been stored in previous versions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This vulnerability is a Stored Cross-Site Scripting (CWE-79) vulnerability affecting the WholeSale Products Dynamic Pricing Management WooCommerce plugin for WordPress (CPE:2.3:a:wpcodefactory:wholesale_products_dynamic_pricing_management_woocommerce). The plugin fails to properly sanitize and escape user input in admin settings fields, allowing malicious scripts to be stored in the database and subsequently reflected to all users who access pages containing the injected content. The vulnerability is specifically triggered through inadequate input validation in the admin settings interface (referenced in class-main.php around line 114), where the plugin accepts user-supplied data without sufficient sanitization before storage or output escaping before rendering. The attack vector is network-based (AV:N) but requires administrator-level privileges (PR:H), and the scope is changed (S:C), meaning the vulnerability can affect resources beyond the security scope of the vulnerable component-in this case, JavaScript execution in the context of legitimate site pages.
Know when Wholesale Products Dynamic Pricing Management Woocommerce gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The WholeSale Products Dynamic Pricing Management WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-22219
GHSA-gpxf-gw3r-8vx4
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB