Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V3 - Web Frontend Security Anti-CSRF tokens, SameSite cookies
MITRE ATT&CK
1 technique across 1 tactic: Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | This vulnerability presents a moderate real-world risk despite the low CVSS score. The CVSS vector (AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L) correctly reflects that exploitation requires user interaction and has limited scope, but CVSS does not fully capture CSRF severity in WordPress ecosystems. The attack vector is network-based with low complexity, and no authentication is required from the attacker's perspective-only social engineering. The integrity and availability impacts (I:L/A:L) are real: unauthorized modification or deletion of download paths can disrupt website functionality and user access to digital assets. WordPress plugin vulnerabilities, particularly in administrative functions, are frequently targeted by attackers scanning for exploitable sites. The presence of confirmed patched versions (5.1.11 and later) indicates this has been addressed upstream. Without EPSS data, KEV status, or confirmed POC availability, the risk should be weighted toward organizational responsibility: any WordPress site using Download Monitor 5.1.10 or earlier that has users with administrative privileges is exposed to administrative disruption via CSRF. |
| Exploit ScenarioDerived | An attacker crafts a malicious webpage or email containing an embedded link or image tag that targets the vulnerable Download Monitor handlers. When a logged-in WordPress administrator visits the attacker's page or clicks the link while their WordPress session is active, the browser automatically sends their authenticated session cookies, causing their browser to silently submit a forged request to delete or disable critical download paths on their website. The administrator may notice missing or disabled downloads but may not immediately connect the incident to the click they performed, allowing the attacker to disrupt service availability or data access without direct authentication. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
Cross-Site Request Forgery in Download Monitor plugin for WordPress up to version 5.1.10 allows unauthenticated attackers to delete, disable, or enable approved download paths by tricking site administrators into clicking a malicious link, due to missing nonce verification in the actions_handler() and bulk_actions_handler() methods. The vulnerability requires user interaction (UI:R) and has a moderate CVSS score of 5.4, with impacts limited to integrity and availability of download path configurations rather than confidentiality.
RemediationAI
Site administrators must upgrade Download Monitor to version 5.1.11 or later immediately. This patched version restores nonce verification to the actions_handler() and bulk_actions_handler() methods, restoring CSRF protection. For sites unable to update immediately, temporary mitigation includes restricting administrative access to trusted IP ranges and limiting administrator user accounts to essential personnel. Workaround is not feasible without code modification, as nonce validation must be implemented in the plugin itself. Verification of the patch can be confirmed by reviewing the changeset at https://plugins.trac.wordpress.org/changeset?old_path=/download-monitor/tags/5.1.10&new_path=/download-monitor/tags/5.1.11, and further threat intelligence is available from Wordfence at https://www.wordfence.com/threat-intel/vulnerabilities/id/33d70481-4652-44f4-99cf-67cc1ffab66a.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The Download Monitor WordPress plugin contains a critical CSRF vulnerability rooted in CWE-352 (Cross-Site Request Forgery). The vulnerability exists in the class-dlm-downloads-path.php file within the actions_handler() and bulk_actions_handler() methods, which process administrative requests to manage download paths without validating WordPress nonce tokens. Nonces are WordPress's primary defense mechanism against CSRF attacks-they are time-limited, user-specific tokens that must be present and valid for state-changing operations. The absence of nonce verification means that any state-changing HTTP request to these handlers will be processed if initiated by an authenticated administrator, regardless of the request's origin. An attacker can craft HTML or JavaScript that, when loaded by a logged-in administrator, silently triggers administrative actions on their behalf.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Primary rating from Vendor (wordfence) · only source for this CVE.
CVSS VectorVendor: wordfence
DescriptionCVE.org
The Download Monitor plugin for WordPress is vulnerable to Cross-Site Request Forgery in the actions_handler() and bulk_actions_handler() methods in class-dlm-downloads-path.php in all versions up to, and including, 5.1.10. This is due to missing nonce verification on these functions. This makes it possible for unauthenticated attackers to delete, disable, or enable approved download paths via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Request Forgery exploits the automatic credential inclusion behavior of web browsers.
Related Vulnerabilities in Download Monitor CSRF
View all 2In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
EUVD-2026-19992
GHSA-jhmj-fqr7-r4cv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB