Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain WordPress admin credentials
-
DeliveryAccess widget configuration panel
-
ExploitInject stored XSS payload into image widget field
-
ExecutionVictim visits page rendering poisoned widget
-
PersistMalicious script executes in victim browser
-
ImpactSession token or credential exfiltration
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress user holding administrator-level (high-privilege) access to the site's widget administration area - confirmed by PR:H in the CVSS:3.1 vector. A separate victim user must actively browse to a page rendering the poisoned widget (UI:R), making fully passive exploitation impossible. The vulnerability is constrained to WordPress installations running Image Widget version 4.4.11 or earlier. Key limiting factors: (1) the attacker must already possess valid WordPress admin credentials, ruling out unauthenticated remote attackers; (2) a victim must visit the affected page after payload injection; (3) environments with a single trusted administrator have no realistic attacker path absent prior credential compromise. The attack is not automatable at scale per SSVC assessment. |
| Impact | The CVSS 5.9 Medium score is shaped primarily by PR:H, meaning only WordPress administrators can plant the payload - a significant constraint that shrinks the realistic attacker pool to insiders or accounts that have already been compromised by other means. EPSS at 0.03% (9th percentile) is very low, aligning with SSVC's assessments of exploitation: none and automatable: no. Real-world priority is therefore low for most environments. However, the S:C scope change deserves attention in multi-admin or multi-tenant WordPress deployments: one admin could use this to attack visitors, other logged-in editors, or co-administrators. If the attacker already controls a WordPress admin account, higher-impact attack paths (file upload, plugin installation, remote code execution via theme editor) exist, making this vulnerability secondary in a breach scenario. No CVSS/description conflict was identified; the PR:H requirement is consistent with the widget configuration context. |
| Exploit ScenarioDerived | An attacker who holds or obtains WordPress administrator credentials navigates to the Image Widget configuration panel and injects a JavaScript payload - for example, a cookie-exfiltration script - into a widget input field such as the image link or title. Once saved, every visitor who loads any page rendering that widget silently executes the script in their browser, enabling session token theft, credential phishing redirects, or defacement. No public proof-of-concept has been identified at time of analysis, but the technique is a well-documented exploitation pattern for stored XSS in WordPress plugins. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 24, 2026
Stored XSS in StellarWP's Image Widget WordPress plugin (all versions through 4.4.11) allows a high-privileged attacker to plant persistent malicious JavaScript into widget configuration fields, which then executes in the browsers of any visitor loading pages that render the widget. The CVSS scope-change indicator (S:C) confirms the payload crosses from the admin backend into the victim's browser context. No public exploit code or active exploitation has been observed; EPSS at 0.03% (9th percentile) and SSVC exploitation status of 'none' indicate negligible current threat activity.
RemediationAI
Monitor the Patchstack advisory at https://patchstack.com/database/Wordpress/Plugin/image-widget/vulnerability/wordpress-image-widget-plugin-4-4-11-cross-site-scripting-xss-vulnerability?_s_id=cve and the WordPress plugin repository for a patched release beyond version 4.4.11; no exact fix version has been confirmed in the available data, so do not upgrade blindly to an unverified build. If immediate patching is not possible, restrict widget configuration access to the minimum number of fully trusted administrator accounts and audit existing widget configurations for unexpected script tags or event-handler attributes. Deploying a strict Content Security Policy header (e.g., script-src 'self') on the affected site will limit the blast radius of any stored payload by blocking inline script execution in victim browsers, though this may break other site functionality and must be tested. Temporarily deactivating the Image Widget plugin on public-facing sites is the most definitive interim control with no residual XSS exposure, at the cost of losing widget display functionality.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected component is the Image Widget plugin for WordPress, authored by StellarWP, identified by CPE cpe:2.3:a:stellarwp:image_widget:*:*:*:*:*:*:*:*. The root cause is CWE-79 (Improper Neutralization of Input During Web Page Generation), a classic Stored XSS class: user-supplied values - likely widget title, image link, alt text, or similar configuration fields - are persisted to the WordPress database and subsequently reflected into HTML output without adequate output encoding or escaping. Because WordPress widgets are rendered site-wide on any page or post where the widget is placed, a single injected payload can be replayed to all site visitors. The CVSS S:C (Changed Scope) confirms the exploit crosses the trust boundary from the administrative configuration interface to the unprivileged visitor's browser context.
Know when Image Widget gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
Admin credentials required (PR:H); victim must visit page (UI:R); scope changes to browser (S:C); XSS confers no availability impact (A:N).
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in StellarWP Image Widget image-widget allows Stored XSS.This issue affects Image Widget: from n/a through <= 4.4.11.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-26214
NVD
CVE.org
EPSS
Vulnrichment
GitHub PoC
Exploit-DB