Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as technician to GLPI
-
DeliveryOpen target asset locked tab
-
ExploitStore crafted JavaScript payload
-
ExecutionWait for admin to view asset
-
PersistScript executes in admin session
-
ImpactHijack session and abuse GLPI privileges
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Attacker must hold a valid GLPI account with the 'technician' role (CVSS PR:H) and the ability to write to the asset locked tab on a target asset. A second authenticated user - typically a higher-privileged administrator - must subsequently view the affected asset's locked tab in their browser to trigger payload execution (CVSS UI:A). Exploitation is constrained to GLPI instances running 10.0.4 through 10.0.24 (or 11.x prior to 11.0.7) and requires network reachability to the GLPI web interface; no special non-default configuration is required since the locked tab is a standard asset feature. |
| Impact | Risk signals are mixed and point to a real but bounded threat. The CVSS 4.0 vector AV:N/AC:L/AT:N/PR:H/UI:A reflects network reachability and low attack complexity but explicitly requires high privileges (a technician account already inside GLPI) and active user interaction by a victim, which dampens mass-exploitation potential. CISA SSVC reports exploitation as 'none' and 'not automatable' with 'total' technical impact, and no EPSS score was supplied; the issue is not in CISA KEV and no public exploit identified at time of analysis. The headline 8.4 score is therefore more representative of session-takeover impact than of likelihood - this is a privileged-insider or credential-compromise risk against helpdesk/admin staff, not an internet-facing pre-auth RCE. |
| Exploit ScenarioDerived | A malicious or compromised technician account stores a crafted JavaScript payload in the locked tab of a high-value asset record; when an administrator later opens that asset's locked tab in the GLPI web UI, the script executes in the admin's browser session and can issue authenticated requests to escalate privileges, exfiltrate inventory or credential data, or pivot ticket workflows. No public exploit identified at time of analysis, but the attack pattern is trivial for anyone with the required role. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jun 03, 2026
Stored cross-site scripting in GLPI 10.0.4 through 10.0.24 allows an authenticated technician to persist a malicious JavaScript payload in the asset locked tab, which executes in the browser of any subsequent user who views the affected asset. The flaw carries a CVSS 4.0 score of 8.4 driven by high impact on confidentiality, integrity, and availability of the victim session, though exploitation requires high privileges (technician role) and user interaction. No public exploit identified at time of analysis and SSVC reports no observed exploitation.
RemediationAI
Vendor-released patch: upgrade to GLPI 10.0.25 on the 10.x branch or 11.0.7 on the 11.x branch as detailed in advisory GHSA-hwjc-8228-55x4 (https://github.com/glpi-project/glpi/security/advisories/GHSA-hwjc-8228-55x4). If patching must be deferred, restrict the technician role to trusted personnel and audit which accounts hold lock-management permissions on assets, since exploitation requires that privilege level; additionally, consider enforcing a strict Content Security Policy on the GLPI front-end to limit inline script execution, accepting that some legitimate UI scripts or plugins may break, and review recent locked-tab entries on critical assets for injected markup before applying the upgrade.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
GLPI is a widely deployed open-source IT service management and asset tracking platform written in PHP, used to inventory hardware, manage tickets, and track infrastructure. The vulnerability is rooted in CWE-79 (Improper Neutralization of Input During Web Page Generation), meaning user-supplied content stored in the asset 'locked' tab is rendered back into the GLPI web UI without sufficient HTML/JavaScript encoding. The affected CPE is cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* covering the GLPI application across versions 10.0.4 up to but not including 10.0.25, with a parallel 11.x branch patched in 11.0.7.
Know when Glpi gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
3DescriptionCVE.org
GLPI is a free asset and IT management software package. Starting in version 10.0.4 and prior to version 10.0.25, a technician can store an XSS payload in the asset locked tab. Upgrade to 10.0.25 or 11.0.7 to receive a patch.
Executive ViewAI
GLPI versions 10.0.4-10.0.24 contain a stored cross-site scripting vulnerability (CVSS 8.4) with no public exploit identified at time of analysis. The flaw allows technician-level users to inject malicious code into asset records, compromising the browser sessions of any subsequent viewer and potentially enabling unauthorized account access or data theft.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
inc/central.class.php in GLPI before 0.84.2 does not attempt to make install/install.php unavailable after an installati
GLPI IT asset management platform contains an unauthenticated SQL injection through the inventory endpoint. Attackers ca
/vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. Rat
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking an
inc/ticket.class.php in GLPI 0.83.9 and earlier allows remote attackers to unserialize arbitrary PHP objects via the _pr
GLPI through 10.0.12 allows CSV injection by an attacker who is able to create an asset with a crafted title. Rated high
In GLPI before 9.4.6, an attacker can execute system commands by abusing the backup functionality. Rated high severity (
GLPI through 9.4.3 is prone to account takeover by abusing the ajax/autocompletion.php autocompletion feature. Rated hig
SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to exec
GLPI is a Free Asset and IT Management Software package. Rated high severity (CVSS 8.1), this vulnerability is remotely
Multiple SQL injection vulnerabilities in GLPI before 0.83.9 allow remote attackers to execute arbitrary SQL commands vi
Multiple SQL injection vulnerabilities in GLPI 0.90.4 allow an authenticated remote attacker to execute arbitrary SQL co
EUVD-2026-34097
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB