PostgreSQL
CVE-2026-40887
CRITICAL
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Parameterized queries, prepared statements
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Persistence The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 26, 2026
Unauthenticated SQL injection in Vendure Shop API allows remote attackers to execute arbitrary SQL commands against the backend database. Affected versions include @vendure/core before 2.3.4, 3.0.0 through 3.5.6, and 3.6.0 through 3.6.1. Public exploit code exists, but no active exploitation is confirmed at this time.
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Know when PostgreSQL gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Primary rating from Vendor (https://github.com/vendurehq/vendure) · only source for this CVE.
CVSS VectorVendor: https://github.com/vendurehq/vendure
Lifecycle Timeline
3DescriptionCVE.org
Summary
An unauthenticated SQL injection vulnerability exists in the Vendure Shop API. A user-controlled query string parameter is interpolated directly into a raw SQL expression without parameterization or validation, allowing an attacker to execute arbitrary SQL against the database. This affects all supported database backends (PostgreSQL, MySQL/MariaDB, SQLite).
The Admin API is also affected, though exploitation there requires authentication.
Affected versions
@vendure/core< 2.3.4@vendure/core>= 3.0.0, < 3.5.7@vendure/core>= 3.6.0, < 3.6.2
Note: versions 2.3.4 and above in the 2.x line are patched. There were no 2.4.x or 2.x releases between 2.3.x and 3.0.0.
Patched versions
@vendure/core2.3.4@vendure/core3.5.7@vendure/core3.6.2
Details
In ProductService.findOneBySlug, the request context's languageCode value is interpolated into a SQL CASE expression via a JavaScript template literal:
.addSelect(
`CASE translation.languageCode WHEN '${ctx.languageCode}' THEN 2 WHEN '${ctx.channel.defaultLanguageCode}' THEN 1 ELSE 0 END`,
'sort_order',
)TypeORM has no opportunity to parameterize this value because it is embedded directly into the SQL string before being passed to the query builder.
The languageCode value can originate from the HTTP query string and is set on the request context for every incoming API request. The value is cast to the LanguageCode TypeScript type at compile time, but no runtime validation is performed -- the raw query string value is used as-is.
Attack vector
An unauthenticated attacker can append a crafted languageCode query parameter to any Shop API request to inject arbitrary SQL into the query. No user interaction is required. The vulnerable endpoint is exposed on every default Vendure installation.
Mitigation
Upgrade to a patched version immediately.
If you cannot upgrade right away, apply the following hotfix to RequestContextService.getLanguageCode to validate the languageCode input at the boundary. This blocks injection payloads before they can reach any query:
private getLanguageCode(req: Request, channel: Channel): LanguageCode | undefined {
const queryLanguageCode = req.query?.languageCode as string | undefined;
const isValidFormat = queryLanguageCode && /^[a-zA-Z0-9_-]+$/.test(queryLanguageCode);
return (
(isValidFormat ? (queryLanguageCode as LanguageCode) : undefined) ??
channel.defaultLanguageCode ??
this.configService.defaultLanguageCode
);
}This replaces the existing getLanguageCode method in packages/core/src/service/helpers/request-context/request-context.service.ts. Invalid values are silently dropped and the channel's default language is used instead.
The patched versions additionally convert the vulnerable SQL interpolation to a parameterized query as defense in depth.
Blast Radius
ecosystem impact- 1 npm packages depend on @vendure/core (1 direct, 0 indirect)
Ecosystem-wide dependent count for version 3.0.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
SQL injection exploits the way applications construct database queries by mixing user input directly into SQL statements.
Affected Products (CPE)CVE.org
More in PostgreSQL
View allPostgreSQL libpq functions PQescapeLiteral(), PQescapeIdentifier(), PQescapeString(), and PQescapeStringConn() improperl
An issue was discovered in Appsmith before 1.52. Rated critical severity (CVSS 9.8), this vulnerability is remotely expl
Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, and 9.0.x before 9.0.13 allows re
Unauthenticated arbitrary file write in Splunk Enterprise (below 10.2.4 and 10.0.7) and Splunk Cloud Platform (below 10.
Unauthenticated SQL injection in Sangoma Switchvox SMB Edition 8.3 (build 104997) lets remote attackers execute arbitrar
PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allow
The build_tablename function in pgsql.c in the PostgreSQL (aka pgsql) extension in PHP through 5.6.7 does not validate t
A vulnerability in the h2oai/h2o-3 REST API versions 3.46.0.4 allows unauthenticated remote attackers to execute arbitra
In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and users in the 'pg_execute_serve
Parse Server is an open source http web server backend. Rated critical severity (CVSS 10.0), this vulnerability is remot
Hard-coded default PostgreSQL credentials shipped in the docker-compose.yaml of langgenius Dify through version 1.5.1 al
A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, allows for
GHSA-9pp3-53p2-ww9v
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB