Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain low-privilege WordPress account
-
DeliveryInject script via vulnerable Kadence block
-
ExploitPayload stored in site content
-
ExecutionAdmin or user renders affected page
-
ImpactScript executes in victim's session
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress account with at least low-level posting privileges (PR:L - e.g., contributor/author able to insert Kadence blocks) to store the malicious payload, AND a subsequent victim (such as an administrator or site visitor) must view the affected content for the script to fire (UI:R). The exact vulnerable block or input field is not described in the available sources. Limiting factors that reduce real-world risk: the need for a pre-existing authenticated account, the dependency on victim interaction, and the requirement that the Kadence Blocks plugin (version up to and including 3.8.0.2) be installed and in use. These constraints make opportunistic mass exploitation unlikely relative to an unauthenticated flaw. |
| Impact | This is a moderate-severity Stored XSS (CWE-79) in the Kadence Blocks WordPress plugin, rated CVSS 6.5 by Patchstack. The vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L indicates network-reachable, low-complexity exploitation that requires an authenticated low-privilege account (PR:L) AND victim interaction (UI:R, a user rendering the poisoned content), with a scope change (S:C) reflecting that injected script executes in another security context (e.g., an administrator's browser session). Prioritization signals are mixed and partly absent: the vuln.today decision label is 'this_month' (a mid-tier, not act_now/emergency, urgency), there is NO CISA KEV listing, NO EPSS score is supplied in the input, and NO proof-of-concept or exploit code is referenced - the only reference is the Patchstack vulnerability database entry itself. Taken together these signals describe a real but non-emergency issue: the dual prerequisites of a low-privilege authenticated session plus user interaction meaningfully constrain mass exploitation, so this is better treated as a 'patch on the normal monthly cycle' item than a drop-everything priority, consistent with the 'this_month' label. The absence of an EPSS value means exploitation-probability cannot be quantified from the provided data and should not be assumed. |
| Exploit ScenarioDerived | An attacker holding a low-privilege authenticated account (such as a contributor or author) uses a vulnerable Kadence block to save content containing a malicious script payload. When an administrator or other user later views that content in wp-admin or on the site, the stored script executes in their browser, potentially performing actions as that higher-privileged user. No public exploit code is referenced, and exploitation requires both the authenticated account and the victim viewing the content (AV:N/AC:L/PR:L/UI:R). |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 29, 2026
Stored cross-site scripting in the Kadence Blocks WordPress plugin through 3.8.0.2 allows an authenticated low-privileged user to persist malicious input that executes when an administrator or site visitor views the affected content. Patchstack rates the issue CVSS 6.5 and this_month priority; the assessed vector requires PR:L and UI:R, so exploitation depends on a pre-existing posting-capable account and victim interaction. No public exploit identified at time of analysis.
RemediationAI
The provided sources do not specify an exact fixed release; consult the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/kadence-blocks/vulnerability/wordpress-gutenberg-blocks-by-kadence-blocks-plugin-3-8-0-2-cross-site-scripting-xss-vulnerability?_s_id=cve for the vendor's patched version and update past 3.8.0.2 as soon as it is available. Because exploitation requires an authenticated low-privileged account able to insert Kadence Blocks content plus victim interaction, interim risk reduction centers on limiting contributor or author roles that can create or edit block content (trade-off: reduced publishing workflow) and reviewing existing Kadence Blocks posts for injected markup (trade-off: editorial effort); disabling the plugin removes the attack surface but also removes its block functionality. The supplied sources do not include a vendor-stated workaround beyond updating.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected component is the WordPress plugin Gutenberg Blocks by Kadence Blocks, published by Liquid Web / StellarWP and identified by CPE cpe:2.3:a:liquid_web_/_stellarwp:gutenberg_blocks_by_kadence_blocks:*:*:*:*:*:*:*:*; versions through 3.8.0.2 are affected. CWE-79 describes improper neutralization of input during web page generation; in this stored XSS variant the payload is saved in content managed by the plugin and later rendered to other users without sufficient encoding or sanitization. The assessed vector is CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N, meaning a network-reachable flaw requiring an authenticated low-privileged account, victim interaction, scope change, and low confidentiality and integrity impact with no availability impact. The exact vulnerable block or input field and the precise trigger are not described in the available sources.
Know when Gutenberg Blocks By Kadence Blocks gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Authenticated low-privilege user stores the payload (PR:L) and a victim must render it (UI:R); stored XSS crosses into another context (S:C) with limited C/I and no genuine availability impact (A:N).
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liquid Web / StellarWP Gutenberg Blocks by Kadence Blocks kadence-blocks allows Stored XSS.This issue affects Gutenberg Blocks by Kadence Blocks: from n/a through 3.8.0.2.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Stored cross-site scripting in the Kadence Blocks WordPress plugin (Gutenberg Blocks by Kadence Blocks, versions from n/
Stored cross-site scripting in the WordPress plugin Gutenberg Blocks by Kadence Blocks (versions through 3.8.0.1) lets a
Sensitive data exposure in the Gutenberg Blocks by Kadence Blocks WordPress plugin (versions <= 3.7.8) allows authentica
EUVD-2026-112866
GHSA-8mp3-f366-f4qp
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB