Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconAttacker gains contributor or editor account credentials or access
-
DeliveryInjects XSS payload into Post Expirator input field (title, metadata, or custom field)
-
ExploitPayload is stored in WordPress database
-
InstallAdministrator accesses Post Expirator admin page or post editor
-
C2DOM-based XSS payload executes in admin's browser with admin privileges
-
ExecuteAttacker steals session token or triggers unauthorized administrative action
-
ImpactAdmin account compromised or malicious changes made to site
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated user with at least contributor-level or editor-level WordPress privileges (PR:L) to inject malicious input into Post Expirator plugin fields. Additionally, a site administrator must view the affected page or admin interface where the malicious input is reflected in the DOM (UI:R). The vulnerability does not execute against default, unmodified installations without user interaction-attackers cannot exploit this remotely or unauthentically against a passive plugin installation. Organizations where all WordPress user accounts are tightly controlled and contributors/editors are fully trusted may have reduced risk, but multi-author sites or sites with guest contributor programs remain vulnerable until patched. |
| Impact | CVSS 6.5 reflects a medium-severity vulnerability with network accessibility and low attack complexity, but several factors reduce real-world risk. EPSS score of 0.03% (8th percentile) indicates minimal exploitation probability, suggesting this vulnerability is neither trivial to weaponize nor attractive to threat actors-likely due to the requirement for prior authentication (PR:L) and mandatory user interaction (UI:R). The scope change (S:C) indicates potential cross-application impact, but only within a single WordPress installation's admin context. No public exploit code or active exploitation (KEV) is confirmed. While administrators are frequent targets for privilege escalation or information theft, the combination of low EPSS, no KEV status, and the limited reach (WordPress admin users only) suggests this is a lower-priority vulnerability compared to unauthenticated remote code execution or vulnerabilities affecting default/unmodified configurations. Organizations running Post Expirator should patch, but this should not take precedence over critical infrastructure vulnerabilities. |
| Exploit ScenarioDerived | An authenticated WordPress user with contributor or editor privileges crafts a malicious payload and injects it into a post title, meta field, or other input processed by Post Expirator. When a site administrator views the Post Expirator settings page, dashboard, or post management interface, the DOM-based XSS payload executes in the admin's browser context. The attacker's script could steal the admin's WordPress session cookie, trigger unauthorized post deletions, create new admin accounts, or redirect the admin to a phishing page-all without the admin realizing they have been compromised. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
DOM-based cross-site scripting (XSS) in PublishPress Post Expirator WordPress plugin versions 4.9.4 and earlier allows authenticated users with limited privileges to inject malicious scripts that execute in the browsers of higher-privileged administrators viewing affected pages, potentially leading to unauthorized actions or credential theft. The vulnerability requires user interaction (administrator viewing the malicious content) and is confined to the application context, making it a medium-severity risk despite the high CVSS score-EPSS scoring of 0.03% percentile indicates low real-world exploitation probability.
RemediationAI
Upgrade PublishPress Post Expirator to a patched version released after 4.9.4 as available from the official WordPress plugin repository or PublishPress website. No specific patched version number is independently confirmed in the provided advisory data, so administrators should consult the Patchstack advisory (https://patchstack.com/database/Wordpress/Plugin/post-expirator/vulnerability/wordpress-post-expirator-plugin-4-9-4-cross-site-scripting-xss-vulnerability?_s_id=cve) or the plugin's official changelog for the recommended upgrade path. As an interim measure, restrict admin user access to only trusted personnel and limit plugin usage to sites where user-supplied content in Post Expirator fields is carefully reviewed before being displayed to administrators. Implementing a Web Application Firewall (WAF) with XSS detection rules may provide additional protection while patches are being deployed.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
PublishPress Post Expirator is a WordPress plugin (CPE: cpe:2.3:a:publishpress:post_expirator:*:*:*:*:*:*:*:*) that manages the expiration and automated handling of published posts. The vulnerability stems from improper sanitization and neutralization of user-supplied input during dynamic DOM manipulation (CWE-79: Improper Neutralization of Input During Web Page Generation). Rather than server-side reflected or stored XSS, this is DOM-based XSS, meaning the malicious payload is processed client-side in the browser's Document Object Model without being fully sanitized by the plugin's JavaScript code. The flaw likely exists in plugin-specific admin interface code that renders user data into the DOM without adequate escaping or Content Security Policy protections.
Know when Post Expirator gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PublishPress Post Expirator post-expirator allows DOM-Based XSS.This issue affects Post Expirator: from n/a through <= 4.9.4.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-20148
NVD
CVE.org
EPSS
Vulnrichment
GitHub PoC
Exploit-DB