Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 vector (AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L) indicates a local attack vector requiring low privilege (PR:L) with low complexity and no user interaction. The integrity impact is high (I:H) and availability impact is low (A:L), reflecting the ability to overwrite configuration. The local-only attack vector significantly constrains real-world risk, as an attacker must already have local system access or a valid API credential. However, the low authentication barrier (CLI sessions are intended as less-privileged credentials) and high integrity impact create meaningful risk in multi-tenant or shared-access Pi-hole deployments. The EPSS score and KEV status are not provided, preventing comparison against exploitation prevalence; however, the low attack vector and requirement for existing authentication suggest this is primarily a privilege-escalation concern rather than an entry vector. In environments where multiple users share Pi-hole access with CLI credentials, this represents a moderate-to-high priority due to authorization bypass enabling configuration tampering. |
| Exploit ScenarioDerived | An attacker with a valid CLI API credential (obtained through phishing, credential reuse, or shared system access) sends a Teleporter archive upload request to the /api/teleporter endpoint. Because the endpoint does not validate that the session is restricted to read-only operations, the archive is processed and the configuration is overwritten, allowing the attacker to modify DNS settings, change admin credentials, disable logging, or inject malicious upstream DNS servers-all without being able to mutate configuration through the properly-secured /api/config endpoint. No public exploit code is documented, but the straightforward nature of the authorization bypass (missing validation on a single endpoint) makes exploitation trivial once a CLI credential is available. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
Pi-hole FTL versions 6.0 through 6.5 allow authenticated local users with CLI API session privileges to bypass authorization controls and overwrite configuration settings via Teleporter archive imports. The vulnerability exists because the /api/teleporter endpoint incorrectly permits CLI-scoped sessions (intended to be read-only) to execute privileged Teleporter operations, while the /api/config endpoint correctly enforces restrictions. This authentication bypass is fixed in Pi-hole FTL 6.6.
RemediationAI
Upgrade Pi-hole FTL to version 6.6 or later, which includes proper authorization checks for the /api/teleporter endpoint. Users unable to immediately patch should restrict the assignment of CLI API credentials to trusted users only and monitor API access logs for unexpected Teleporter import requests. If webserver.api.cli_pw is not in active use, disabling the CLI password feature eliminates the attack surface. Consult the official security advisory at https://github.com/pi-hole/FTL/security/advisories/GHSA-r7g8-3fj7-m5qq for detailed upgrade instructions and confirmation of patched versions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Pi-hole FTL is the DNS/DHCP server component of Pi-hole that provides both an interactive API and statistical data for the Web interface. The vulnerability stems from inconsistent authorization enforcement across API endpoints. The webserver.api.cli_pw configuration feature creates CLI-scoped API sessions that should be restricted to read-only operations for configuration queries. However, the /api/teleporter endpoint fails to validate session scope before processing Teleporter archive uploads, allowing CLI sessions to import configuration archives that modify system state. This is classified as CWE-863 (Incorrect Authorization), indicating that the authorization check was either missing or improperly implemented at the Teleporter endpoint. The affected product is identified by CPE cpe:2.3:a:pi-hole:ftl:*:*:*:*:*:*:*:* for all versions from 6.0 to 6.5.
Know when Ftl gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
FTLDNS (pihole-FTL) provides an interactive API and also generates statistics for Pi-hole's Web interface. From 6.0 to before 6.6, Pi-hole FTL supports a CLI password feature (webserver.api.cli_pw) that creates “CLI” API sessions intended to be read-only for configuration changes. While /api/config correctly blocks CLI sessions from mutating configuration, /api/teleporter allowed Teleporter imports for CLI sessions, enabling a CLI-scoped session to overwrite configuration via a Teleporter archive (authorization bypass). This vulnerability is fixed in 6.6.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Remote code execution in Pi-hole FTL engine versions 6.0 through 6.5 allows authenticated attackers to execute arbitrary
Remote code execution in Pi-hole FTL engine versions 6.0 through 6.5 allows authenticated attackers to inject arbitrary
Remote code execution in Pi-hole FTL 6.0 through 6.5 allows authenticated attackers to execute arbitrary commands via ne
Remote code execution in Pi-hole FTL DNS engine versions 6.0 through 6.5 allows authenticated attackers to execute arbit
Remote code execution in Pi-hole FTL engine versions 6.0 through 6.5 allows authenticated attackers with low privileges
Session hijacking in Pi-hole FTL versions prior to 6.6.1 stems from a race condition in the CivetWeb-based HTTP session
The ftlserver component of TIBCO Software Inc.'s TIBCO FTL - Community Edition, TIBCO FTL - Developer Edition, TIBCO FTL
The realm configuration component of TIBCO Software Inc.'s TIBCO FTL Community Edition, TIBCO FTL Developer Edition, TIB
The realm server (tibrealmserver) component of TIBCO Software Inc. Rated high severity (CVSS 8.8), this vulnerability is
The ftlserver component of TIBCO Software Inc.'s TIBCO FTL - Community Edition, TIBCO FTL - Developer Edition, TIBCO FTL
The FTL Server (tibftlserver), FTL C API, FTL Golang API, FTL Java API, and FTL .Net API components of TIBCO Software In
The Windows Installation component of TIBCO Software Inc.'s TIBCO FTL - Community Edition, TIBCO FTL - Developer Edition
EUVD-2026-19676
NVD
CVE.org
EPSS
Vulnrichment
GitHub
Exploit-DB