Skip to main content

Workbench CVE-2026-34951

| EUVDEUVD-2026-19357 MEDIUM
Cross-site Scripting (XSS) (CWE-79)
2026-04-06 security-advisories@github.com
5.1
CVSS 4.0 · Vendor: github
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK

2 techniques across 2 tactics: Initial Access, Execution

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

CVSS v4.0 score of 5.1 (medium severity) reflects limited impact: remote network attack vector (AV:N), low complexity (AC:L), no authentication required (PR:N), but requires user interaction (UI:A) and results only in low confidentiality and integrity impact (VC:L, VI:L). The EPSS exploitation probability is not provided, preventing comparative risk analysis. No KEV status or public proof-of-concept code is reported. From an SSVC perspective, this is a reflected XSS on an error page-exploitation requires social engineering to trick a user into clicking a malicious link containing the payload, making practical attack success dependent on user awareness. The limited impact scope (error pages only) and user interaction requirement substantially reduce real-world risk versus stored XSS or high-impact reflected XSS. This is a legitimate medium-risk issue, not an inflated CVSS score.

Exploit ScenarioDerived

An attacker crafts a malicious URL containing a JavaScript payload in the footerScripts parameter and shares it via email or social media with a Workbench user. When the user clicks the link, the unvalidated parameter is reflected in the error page, executing the attacker's script in the victim's browser within the Workbench application context. The script could steal session cookies, capture credentials, or redirect the user to a phishing site. Exploitation requires the user to click the malicious link and is limited to the scope of the Workbench application session.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Apr 06, 2026

Reflected cross-site scripting (XSS) in Salesforce Workbench prior to version 65.0.0 allows unauthenticated remote attackers to inject arbitrary JavaScript via the footerScripts parameter on error pages, requiring user interaction to execute malicious payload. The vulnerability stems from improper input sanitization during web page generation. Vendor-released patch: version 65.0.0. No public exploit code or active exploitation confirmed at time of analysis.

RemediationAI

Upgrade Salesforce Workbench to version 65.0.0 or later to obtain the patch. This is the primary remediation. As a temporary workaround prior to upgrading, users should avoid clicking on links containing the footerScripts parameter from untrusted sources, and disable JavaScript execution or use a content security policy (CSP) to restrict inline script execution if operationally feasible. For details on the patch and upgrade process, consult the vendor advisory at https://github.com/forceworkbench/forceworkbench/security/advisories/GHSA-j94x-h584-rjf9.

Affected VersionsENISA

forceworkbench < 65.0.0

Affected Packages

euvd forceworkbench fix: 65.0.0

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

Workbench is a web-based administration and development tool for interacting with Salesforce.com organizations via the Force.com APIs. The vulnerability exists in the error page rendering logic, where the footerScripts parameter is reflected directly into the HTML response without sanitization or encoding. This is a classic reflected XSS vulnerability (CWE-79: Improper Neutralization of Input During Web Page Generation) where user-supplied input flows from HTTP request parameter to the DOM without validation or output encoding. The attack surface is the error page handler that processes the footerScripts parameter and renders it as part of the page template.

Know when Workbench gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

Vendor (github) PRIMARY 5.1 MEDIUM
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Primary rating from Vendor (github) · only source for this CVE.

CVSS VectorVendor: github

Attack Vector
Network
Attack Complexity
Low
Attack Requirements
None
Privileges Required
None
User Interaction
Active
Vulnerable system: Confidentiality
Low
Vulnerable system: Integrity
Low
Vulnerable system: Availability
None
Subsequent system: Confidentiality
None
Subsequent system: Integrity
None
Subsequent system: Availability
None

Lifecycle Timeline

2
Patch available
Apr 16, 2026 - 05:29 EUVD
65.0.0
CVE Published
Apr 06, 2026 - 16:16 nvd
MEDIUM 5.1

DescriptionCVE.org

Workbench is a suite of tools for administrators and developers to interact with Salesforce.com organizations via the Force.com APIs. Prior to 65.0.0, Workbench contains a reflected cross-site scripting vulnerability via the footerScripts parameter, which does not sanitize user-supplied input before rendering it in the page response. Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Workbench allows XSS Targeting Error Pages. This vulnerability is fixed in 65.0.0.

Threat Intelligence Overview

EPSS Score
0.0%
Top 86% exploitable
Data Quality
6 sources
Confidence: High
EUVD NVD CVE.org EPSS Vulnrichment GitHub VulDB

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation
None
System Exposure· derived
Open
Automatable
No
Human Impact· derived
Medium
Technical Impact
Partial

Priority Score

26
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +26
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy