Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 4.0 vector indicates network-accessible attack (AV:N) with low complexity (AC:L), no special privileges required (PR:N), and no user interaction needed (UI:N), though the integrity impact is limited (VI:L) with no confidentiality or availability impact. The EPSS score and exploitation probability cannot be determined from provided data. However, the absence of any public exploit code or CISA KEV confirmation suggests real-world exploitation risk is currently low despite the favorable attack conditions. The vulnerability is meaningful because stored XSS can enable account hijacking, session theft, and defacement when the application lacks strong output encoding on all user-facing content fields. Organizations using versions 2.27.0-2.47.x should treat this as a moderate-priority patch given the wide version range affected and the persistence mechanism, though immediate emergency response is not warranted without active exploitation signals. |
| Exploit ScenarioDerived | An attacker with network access to a Frappe LMS instance crafts a course lesson, learning activity, or course description containing malicious JavaScript (e.g., stealing session cookies or harvesting credentials). Because the application does not properly encode user input when storing or rendering content, the script persists in the database. When other users (including administrators or instructors) access that course or lesson, the injected script executes in their browsers with their privileges, potentially allowing the attacker to impersonate users, steal authentication tokens, or redirect learners to phishing pages. The attack requires no special authentication or user interaction beyond normal platform usage. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 02, 2026
Stored cross-site scripting (XSS) in Frappe Learning Management System versions 2.27.0 through 2.47.x allows unauthenticated remote attackers to inject and persist malicious scripts that execute in the browsers of other users. The vulnerability affects content structure functionality and has been patched in version 2.48.0. No public exploit code or active exploitation has been confirmed at time of analysis.
RemediationAI
Vendor-released patch: Frappe LMS version 2.48.0 or later. Organizations should upgrade immediately by pulling the latest release from https://github.com/frappe/lms/releases/tag/v2.48.0 or by updating through their package management system. The patch implements proper input validation and output encoding across content structure fields, as documented in upstream pull request https://github.com/frappe/lms/pull/2185 and commit b8283860a7f029ea2fa0245131c398c079088921. No workarounds are available prior to patching; input validation at the application layer cannot fully compensate for a stored XSS in persistent content. Administrators should verify the upgrade by checking the installed version and reviewing server logs for any suspicious content modifications during the affected version timeframe.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Frappe LMS is a web-based learning platform built on the Frappe framework that manages educational content and course structure. The vulnerability stems from improper input validation and output encoding in content handling mechanisms (CWE-79: Improper Neutralization of Input During Web Page Generation). The stored XSS flaw allows attackers to bypass input sanitization and inject malicious JavaScript that persists in the application database, affecting all users who subsequently view the compromised content. The affected product is identified by CPE cpe:2.3:a:frappe:lms:*:*:*:*:*:*:*:* covering all versions in the affected range.
Know when Frappe gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
Frappe Learning Management System (LMS) is a learning system that helps users structure their content. From version 2.27.0 to before version 2.48.0, Frappe LMS was vulnerable to stored XSS. This issue has been patched in version 2.48.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Stored cross-site scripting leading to code execution in Frappe Framework 15.89.0 (and the ERPNext application built on
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Rated high severity (CVS
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Rated high severity (CVS
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Rated high severity (CVS
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Rated high severity (CVS
Authenticated SQL injection in Frappe ERPNext through 15.89.0 allows low-privilege users to extract arbitrary database c
SQL injection in Frappe ERPNext through 15.89.0 lets an authenticated attacker with a valid session and access to the Pa
Authenticated server-side template injection in Frappe ERPNext through 15.89.0 lets a user who can create or modify an A
An SQL injection vulnerability exists in the frappe.desk.reportview.get functionality of ERPNext 11.1.38. Rated high sev
Arbitrary file read in the Frappe full-stack web application framework allows remote unauthenticated attackers to retrie
SQL injection in Frappe HelpDesk 1.14.0 dashboard functionality allows authenticated attackers to execute arbitrary SQL
In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at erpnext/buying/doctype/request_for_quotation/re
EUVD-2026-18462
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB