Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Leading special element handling
|
| Impact | The CVSS 5.4 score (AV:N/AC:H/PR:N/UI:N/S:C) reflects network-reachable, unauthenticated attack surface with high complexity and partial impact (confidentiality and integrity, no availability loss). SSVC assessment categorizes this as low-urgency: exploitation status is 'none' (no confirmed active use), automatable status is 'no' (requiring manual crafting of specific URL patterns), and technical impact is 'partial' (not total system compromise). The CVSS AC:H (high complexity) qualifier significantly reduces real-world risk compared to simpler attack vectors. This is a genuine but limited-risk issue: cache poisoning and authentication bypass are serious in principle, but the high attack complexity and lack of automation or active exploitation suggest this is a lower-priority vulnerability relative to common Web application flaws. Organizations with strict cache integrity requirements or public-facing authentication systems proxied through Varnish should prioritize patching; others may defer based on patch availability and operational impact. |
| Exploit ScenarioDerived | An attacker sends an HTTP/1.1 request to a Varnish-proxied website with a crafted root-path URL (/) that is mishandled by the cache. Due to the unchecked req.url, Varnish caches the response with incorrect metadata or bypasses authentication checks. Subsequent requests from legitimate users receive the poisoned cached response, potentially exposing sensitive data or allowing attackers to inject malicious content. The attack requires moderate knowledge of the target application and Varnish configuration to succeed, explaining the high attack complexity rating. No public exploit code or active exploitation in the wild has been identified at the time of this analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 27, 2026
Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12 mishandle HTTP/1.1 URLs with a root path (/) in unchecked req.url scenarios, enabling cache poisoning and authentication bypass attacks. Unauthenticated remote attackers can exploit this with moderate complexity to poison cached content or bypass authentication controls affecting downstream clients. No active exploitation has been confirmed, though the vulnerability carries a 5.4 CVSS score reflecting network accessibility and partial impact to confidentiality and integrity.
RemediationAI
Upgrade Varnish Cache to version 8.0.1 or later, which includes the fix for improper HTTP/1.1 URL path handling. Varnish Enterprise users should update to 6.0.16r12 or later. For users unable to immediately patch, review and strengthen validation of req.url in Varnish Configuration Language (VCL) policies, ensuring that root path requests (/) are explicitly handled and do not bypass intended caching or authentication logic. Disable or restrict caching of authentication-sensitive responses until patched. Consult the official advisory at https://vinyl-cache.org/security/VSV00018.html for detailed configuration workarounds and patch deployment instructions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Varnish Cache is an HTTP accelerator and reverse proxy that caches web content to improve performance. The vulnerability stems from improper URL handling in HTTP/1.1 request processing, specifically when the path component is set to the root path (/). CWE-180 (Incorrect Behavior of Shift and Rotation Operator) typically involves bitwise operation errors, but in this context likely indicates unsafe transformation or normalization of URL path components. When req.url is not properly validated before use in caching decisions or authentication checks, attackers can craft malicious requests with root paths that bypass security controls. The affected versions are Varnish Cache before 8.0.1 (CPE: cpe:2.3:a:varnish:varnish_cache:*:*:*:*:*:*:*:*) and Varnish Enterprise before 6.0.16r12 (CPE: cpe:2.3:a:varnish:varnish_enterprise:*:*:*:*:*:*:*:*).
Know when Varnish Enterprise gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
Sources disagree (Medium–Critical)AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
vuln.today treats the vendor’s rating as authoritative. A higher third-party CVSS (e.g. CISA-ADP) is shown for transparency but does not drive the headline severity.
CVSS VectorNVD
Lifecycle Timeline
4DescriptionNVD
Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12, in certain unchecked req.url scenarios, mishandle URLs with a path of / for HTTP/1.1, potentially leading to cache poisoning or authentication bypass.
Executive ViewAI
CVE-2026-34475 presents moderate security risk rated CVSS 5.4. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in Varnish Enterprise
View allVarnish Enterprise before version 6.0.16r12 is vulnerable to a workspace overflow denial of service attack that crashes
libvmod-digest before 1.0.3, as used in Varnish Enterprise 6.0.x before 6.0.11r5, has an out-of-bounds memory access dur
Varnish Cache before 7.6.2 and Varnish Enterprise before 6.0.13r10 allow client-side desync via HTTP/1 requests. Rated m
Varnish Enterprise before 6.0.13r13 allows remote attackers to obtain sensitive information via an out-of-bounds read fo
EUVD-2026-16801
NVD
CVE.org
EPSS
Vulnrichment
VulDB
GitHub PoC
Exploit-DB