Discourse
CVE-2026-33426
LOW
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2021 - Broken Access Control
ASVS 5.0
V4 - Access Control Authorization enforcement, RBAC validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While the CVSS v3.1 base score is 3.5 (low), the risk profile presents nuance. The attack vector is network-based (AV:N) with low complexity (AC:L), making exploitation trivial once prerequisites are met. However, the privilege requirement (PR:H) restricts the attack surface significantly—only users already granted tag-editing permissions can exploit this, which typically means moderators or administrators. The impact is limited to confidentiality and integrity at a low level (C:L/I:L), with no availability impact (A:N). The vulnerability does not appear in the CISA KEV (Known Exploited Vulnerabilities) catalog, suggesting no active exploitation in the wild. No public proof-of-concept code is documented. From an SSVC perspective, this is exploitable but requires insider access; technical impact is limited to tag data manipulation. Risk priority should be medium-to-low for most organizations, elevated only if tag groups are used to manage sensitive topic access control. |
| Exploit ScenarioDerived | A moderator with tag-editing permissions but intentionally restricted from viewing sensitive topic tags (e.g., internal security issues or private support channels) leverages the vulnerability to create synonyms for those hidden tags, effectively revealing their existence and allowing tag-based topic discovery without proper authorization. Since the attack requires high privileges and user interaction (network-based but requires an authenticated session), exploitation is limited to insider threats or compromised moderator accounts; however, the low complexity (AC:L) means the attacker needs only basic familiarity with the tag management interface to succeed. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 20, 2026
Discourse versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain an authorization bypass vulnerability where users with tag-editing permissions can edit and create tag synonyms for tags within restricted tag groups, even when those users lack visibility into the restricted tags themselves. This represents a broken access control issue (CWE-862) with low CVSS score (3.5) due to high privilege requirement and limited impact scope, though it enables unauthorized information disclosure and tag manipulation within the platform. No public exploit code or active exploitation in the wild has been reported at this time.
RemediationAI
Upgrade Discourse immediately to version 2026.1.2, 2026.2.1, or 2026.3.0-latest.1 or later, depending on your current release branch. Refer to the GitHub security advisory at https://github.com/discourse/discourse/security/advisories/GHSA-2289-4m46-2hxh for specific upgrade instructions and compatibility notes. No workarounds are available according to the vendor advisory, making patching the only mitigation. In the interim, restrict tag-editing permissions to only trusted administrative users, and conduct an audit of tag synonym creation logs to identify any unauthorized changes made during the vulnerable period. Consider enabling audit logging if not already enabled to track all tag management operations.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists within Discourse, an open-source discussion platform (CPE: cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*) that manages user-generated content and community discussions. The root cause is classified under CWE-862 (Authorization Bypass Through User-Controlled Key), indicating insufficient permission checks in the tag synonym creation and editing logic. Specifically, the platform fails to properly validate whether a user with tag-editing permissions should be allowed to interact with tags belonging to restricted tag groups they cannot view. This suggests the permission model checks for tag-edit capability in isolation rather than enforcing contextual visibility controls, allowing privilege escalation at the tag-management layer without corresponding visibility controls.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
DescriptionGitHub Advisory
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, users with tag-editing permissions could edit and create synonyms for tags hidden in restricted tag groups, even if they lacked visibility into those tags. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Executive ViewAI
CVE-2026-33426 is a low-severity vulnerability in Discourse involving missing authorization (CVSS 3.5). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. Apply vendor updates when available as part of routine maintenance.
Apply vendor patch during routine maintenance. Standard security controls provide adequate interim protection.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Affected Products (CPE)GitHub Advisory
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB